summaryrefslogtreecommitdiff
path: root/app-metrics/elasticsearch_exporter/elasticsearch_exporter-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /app-metrics/elasticsearch_exporter/elasticsearch_exporter-1.3.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'app-metrics/elasticsearch_exporter/elasticsearch_exporter-1.3.0.ebuild')
-rw-r--r--app-metrics/elasticsearch_exporter/elasticsearch_exporter-1.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-metrics/elasticsearch_exporter/elasticsearch_exporter-1.3.0.ebuild b/app-metrics/elasticsearch_exporter/elasticsearch_exporter-1.3.0.ebuild
new file mode 100644
index 000000000000..77d0612e73c4
--- /dev/null
+++ b/app-metrics/elasticsearch_exporter/elasticsearch_exporter-1.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_COMMIT=fe20e49
+MY_PV=${PV/_/}
+inherit go-module
+DESCRIPTION="Elasticsearch stats exporter for Prometheus"
+HOMEPAGE="https://github.com/justwatchcom/elasticsearch_exporter"
+SRC_URI="https://github.com/justwatchcom/elasticsearch_exporter/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="acct-group/elasticsearch_exporter
+ acct-user/elasticsearch_exporter"
+ RDEPEND="${DEPEND}"
+BDEPEND="dev-util/promu"
+
+src_prepare() {
+ default
+ sed -i -e "/-s$/d" -e "s/{{.Revision}}/${GIT_COMMIT}/" .promu.yml || die
+}
+
+src_compile() {
+ promu build --prefix bin || die
+}
+
+src_install() {
+ dobin bin/elasticsearch_exporter
+ dodoc {README,CHANGELOG}.md
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ keepdir /var/log/elasticsearch_exporter
+ fowners ${PN}:${PN} /var/log/elasticsearch_exporter
+}