summaryrefslogtreecommitdiff
path: root/app-metrics/dnsmasq_exporter/dnsmasq_exporter-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-metrics/dnsmasq_exporter/dnsmasq_exporter-0.2.0.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-metrics/dnsmasq_exporter/dnsmasq_exporter-0.2.0.ebuild')
-rw-r--r--app-metrics/dnsmasq_exporter/dnsmasq_exporter-0.2.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-metrics/dnsmasq_exporter/dnsmasq_exporter-0.2.0.ebuild b/app-metrics/dnsmasq_exporter/dnsmasq_exporter-0.2.0.ebuild
new file mode 100644
index 000000000000..f7d8c48ba78d
--- /dev/null
+++ b/app-metrics/dnsmasq_exporter/dnsmasq_exporter-0.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="prometheus exporter for dnsmasq"
+HOMEPAGE="https://github.com/google/prometheus_exporter"
+
+EGO_VENDOR=(
+ "github.com/alecthomas/template a0175ee3bccc"
+ "github.com/alecthomas/units 2efee857e7cf"
+ "github.com/beorn7/perks v1.0.0"
+ "github.com/golang/protobuf v1.3.1"
+ "github.com/konsorten/go-windows-terminal-sequences v1.0.1"
+ "github.com/matttproud/golang_protobuf_extensions v1.0.1"
+ "github.com/miekg/dns v1.1.14"
+ "github.com/prometheus/client_golang v0.9.4"
+ "github.com/prometheus/client_model fd36f4220a90"
+ "github.com/prometheus/common v0.4.1"
+ "github.com/prometheus/procfs v0.0.2"
+ "github.com/sirupsen/logrus v1.2.0"
+ "golang.org/x/crypto 0709b304e793 github.com/golang/crypto"
+ "golang.org/x/net adae6a3d119a github.com/golang/net"
+ "golang.org/x/sync 112230192c58 github.com/golang/sync"
+ "golang.org/x/sys 5ac8a444bdc5 github.com/golang/sys"
+ "gopkg.in/alecthomas/kingpin.v2 v2.2.6 github.com/alecthomas/kingpin"
+)
+SRC_URI="https://github.com/google/dnsmasq_exporter/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ $(go-module_vendor_uris)"
+
+LICENSE="BSD MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ acct-group/dnsmasq_exporter
+ acct-user/dnsmasq_exporter"
+ RDEPEND="${DEPEND}"
+
+src_compile() {
+ go build || die
+}
+
+src_install() {
+ dobin dnsmasq_exporter
+ keepdir /var/log/ddnsmasq_exporter
+ fowners ${PN}:${PN} /var/log/ddnsmasq_exporter
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}