summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-leechcraft/lc-core
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-leechcraft/lc-core')
-rw-r--r--app-leechcraft/lc-core/Manifest2
-rw-r--r--app-leechcraft/lc-core/lc-core-9999.ebuild57
-rw-r--r--app-leechcraft/lc-core/metadata.xml16
3 files changed, 75 insertions, 0 deletions
diff --git a/app-leechcraft/lc-core/Manifest b/app-leechcraft/lc-core/Manifest
new file mode 100644
index 000000000000..1c2713c09cf3
--- /dev/null
+++ b/app-leechcraft/lc-core/Manifest
@@ -0,0 +1,2 @@
+EBUILD lc-core-9999.ebuild 1190 BLAKE2B 235595fe3dc8c4abbaf2e28c63e20e7b887830eb2fd22d25f532e8da5fc8c2f56c44f718ac7a7946cd00082e52c67d3ddba822079549251793bb663c88b95d1a SHA512 45df8aa3158f56ef8d82cf7a2f6b2c9417783b3b6b8cec2afb9825fb0a5e8d526904d81f93a4475fa13c7dada5da91e09d16da3aecc8c519562e2359cb9b58ef
+MISC metadata.xml 633 BLAKE2B 62070ab45e1be6576733dedf35c3778a28876138617bab4868f0b8bae1df3b54921e278048e1b55b4e558194b21f9d82a8390a977d551ef5c3c7878f9bba4288 SHA512 45cc0f9aa42538cd9f9232e5981c9dbbc457e4dd89c9c82ab5dcfdb139df67d83149b6aafdaad4d04d03efda32b187c99605c30da5477a3de67eee9608a26e90
diff --git a/app-leechcraft/lc-core/lc-core-9999.ebuild b/app-leechcraft/lc-core/lc-core-9999.ebuild
new file mode 100644
index 000000000000..e2da5f1db2a7
--- /dev/null
+++ b/app-leechcraft/lc-core/lc-core-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/0xd34df00d/leechcraft.git"
+
+inherit leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug doc +sqlite postgres +qwt"
+
+COMMON_DEPEND=">=dev-libs/boost-1.62
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtscript:5
+ dev-qt/qtsql:5[postgres?,sqlite?]
+ dev-qt/qtdbus:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtconcurrent:5
+ dev-qt/linguist-tools:5
+ qwt? ( x11-libs/qwt:6[qt5] )"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtsvg:5
+ || (
+ kde-frameworks/oxygen-icons
+ x11-themes/kfaenza
+ )"
+
+REQUIRED_USE="|| ( postgres sqlite )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_PLUGINS=False
+ -DWITH_DOCS=$(usex doc)
+ -DWITH_QWT=$(usex qwt)
+ )
+ if [[ ${PV} != 9999 ]]; then
+ mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}/${PN#lc-}"/out/html/*
+}
diff --git a/app-leechcraft/lc-core/metadata.xml b/app-leechcraft/lc-core/metadata.xml
new file mode 100644
index 000000000000..79bb4d800dab
--- /dev/null
+++ b/app-leechcraft/lc-core/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Core of LeechCraft, the opensource modular network client providing a full-featured web browser, BitTorrent client and much more.</longdescription>
+ <use>
+ <flag name="qwt">Support for QML plotting item through <pkg>x11-libs/qwt</pkg></flag>
+ </use>
+</pkgmetadata>