summaryrefslogtreecommitdiff
path: root/app-laptop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
commit994fe442814c4d169bb0f1ee9745604928006b39 (patch)
tree630f10f7414f44018095dd9d3cf9df55852a9d41 /app-laptop
parentf8999218b5a6eafa151e7367030cbfdb69e045ed (diff)
gentoo auto-resync : 26:05:2024 - 00:07:27
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/Manifest.gzbin3603 -> 3599 bytes
-rw-r--r--app-laptop/mbpfan/Manifest2
-rw-r--r--app-laptop/mbpfan/mbpfan-2.4.0.ebuild53
3 files changed, 55 insertions, 0 deletions
diff --git a/app-laptop/Manifest.gz b/app-laptop/Manifest.gz
index b8e8291714b2..7bdadd3796dd 100644
--- a/app-laptop/Manifest.gz
+++ b/app-laptop/Manifest.gz
Binary files differ
diff --git a/app-laptop/mbpfan/Manifest b/app-laptop/mbpfan/Manifest
index e73c15f3f83d..9c0b7b995658 100644
--- a/app-laptop/mbpfan/Manifest
+++ b/app-laptop/mbpfan/Manifest
@@ -1,5 +1,7 @@
AUX mbpfan-2.3.0-clang16-build-fix.patch 273 BLAKE2B 92d11a6d902524085361bc801a8304d78ee44413016634f872f75dc6fea53959a8a893bfbb44d0fc4d6dbdccb9c666838f3dd284996fbb01ea729dbad4644d7b SHA512 d712c0a0e6b6e94b88d130fa11acfe4a73203b9cd5a4525bc1e635ca56e3d79dae356b2157e418a1b50564789836013f8f449a4d7c2dbb058242dfce84c5f318
DIST mbpfan-2.3.0.tar.gz 40984 BLAKE2B ac593e94ee5915935767b221b3f8b29d416fadf3294b4930ba1b441838758c5014dc960c90e5ce35e3475793aaf68b2981641323dd9ea22dd50772cd54f75078 SHA512 676817d7d9b9e9fa866539d4b0e3edc8d0d22761807695961451fe1d5845c22031d45f53222d37c5ed967757b4cf80523a3af7d28084d9af11248798a463cdfd
+DIST mbpfan-2.4.0.tar.gz 41723 BLAKE2B 91efc640a3d5d73fff61fd9c323a5ba82dae1bc55cfa9486b6ab657f5af3c2ecda5bd53c835a5d1ad3af42a6b3198a812a115fa8cc535d643f01f20d34818ded SHA512 fa906043552a895d274642dfe8e3a94fdece0bf9b430710d9ee4dc4f33b6762fbed3314e4a67ede11916514297d511031cc99b35b7a267b58aceefd73e4b1d22
EBUILD mbpfan-2.3.0-r1.ebuild 1332 BLAKE2B 9a2c82c0ddca78cc0b712e6f322d098d0389d90c81ef1c797d133ae6f258bc4eee33b9f9c5b60c768ff44ad6171b2bcd7701eff4719118ab15132d75784dc1c8 SHA512 fff4e57a662a01e0b2a842d5f0a518e86b8af61d5abec2427eb4f2bdf96c6f4d32c9a01dd28b06cd56da47a07d0db5a46b915b9fb3cacd9dc97243301d158423
+EBUILD mbpfan-2.4.0.ebuild 1457 BLAKE2B 73aad1e7799e86e65d99cd14e173a35b9df312c51a8e970940846f533cceb8a4309c96983bf7e10334ae05a50bb1bb44c37a13bc2de0028a745ad7a79f088885 SHA512 1bdc323d49ef6a27b51abe273b53268b865f1f10ddda1fa6d20991f6a68434385beb91e4976dec9bdf0330993d86a2f34bcb84b89c9ac5991e904faa8ad55a66
EBUILD mbpfan-9999.ebuild 1268 BLAKE2B d06dc087c6c857239069624770bdf8214847d44bc4f0156654e812666dd87fc2bcc2e3d04af0de513f655c58dbfcb6b3d57e919ef0adbf448aeede8352285780 SHA512 ced6de88ebfda6389f250234ed474373e64b759f970384f0866667e104e3760a14e911ca680ee286682e32deb6a3dbe78fee9cd6ac3210fbe60f91656a71a2ca
MISC metadata.xml 690 BLAKE2B bde3ec1fac36fe5dd4f3fa628f16a7fb6fe64179ae8f9e8ee8edb651abec9da089d1e875db956931d4182d8975bd1de04c43104260e1bba04f01433f0741fe7e SHA512 bbec74e4ae64483001c35aa3963e9e681d63c4e6205b838b0dc0d952b461497c0ff3ad5d52e8714d1804f2935d4db8f69da6aa79b01964f0a6da99ed6eb5f89c
diff --git a/app-laptop/mbpfan/mbpfan-2.4.0.ebuild b/app-laptop/mbpfan/mbpfan-2.4.0.ebuild
new file mode 100644
index 000000000000..71a3676ade72
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-2.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+else
+ SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.0-clang16-build-fix.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # Decompress the man page to enable PM auto compression
+ gzip -d "${ED}"/usr/share/man/man8/mbpfan.8.gz || die
+
+ # Remove the empty systemd unit directory
+ # It doesn't actually install the unit file
+ rmdir --ignore-fail-on-non-empty -p "${ED}"/lib/systemd/system || die
+ # Actually install the sytstemd unit file
+ systemd_dounit ${PN}.service
+ # Install openrc init file
+ newinitd ${PN}.init.gentoo ${PN}
+ # mbpfan-2.4.0 adds support for dinit (https://github.com/davmac314/dinit)
+ # As of writing this, dinit is not in the tree.
+
+ # make install doesn't install the docs in the right place
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+
+ einstalldocs
+}