summaryrefslogtreecommitdiff
path: root/app-laptop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-19 01:49:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-19 01:49:34 +0100
commit37cd441738bc6681ca075c01b6dd06056a27abbf (patch)
tree528a97a3994f491e0909f7e236f1691667ecbe77 /app-laptop
parent1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (diff)
gentoo auto-resync : 19:06:2023 - 01:49:34
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/Manifest.gzbin3248 -> 3247 bytes
-rw-r--r--app-laptop/tp_smapi/Manifest1
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.43-r3.ebuild46
3 files changed, 47 insertions, 0 deletions
diff --git a/app-laptop/Manifest.gz b/app-laptop/Manifest.gz
index b8f344ea7c9f..1901f3007212 100644
--- a/app-laptop/Manifest.gz
+++ b/app-laptop/Manifest.gz
Binary files differ
diff --git a/app-laptop/tp_smapi/Manifest b/app-laptop/tp_smapi/Manifest
index 791da4e1d528..e99476489185 100644
--- a/app-laptop/tp_smapi/Manifest
+++ b/app-laptop/tp_smapi/Manifest
@@ -2,4 +2,5 @@ AUX tp_smapi-0.40-confd 785 BLAKE2B da1e2a5ce6e441eebf1a3dffcce8a863688a525f6ee4
AUX tp_smapi-0.40-initd 1851 BLAKE2B 852fc13e2d74a570918c451966214ed8ca3daea9bdb66e856f48554261f4cafc8d8be7b76889a6a639f0dc1310d34036131a9982be0cdcf0e458707e7938b161 SHA512 ebf8ac628e00979f21e266fb6d187f02bfeeafc9482a0c5bed4fd4f092c7a27158747ccf629c802969ad2a8f13124276ef889927b3f1f01a7ce44fdcde103698
DIST tp_smapi-0.43.tgz 40122 BLAKE2B e14caa05d741d14b03c56c57badc5900a47735bc58966b5195ca34269a6227ecc50518ee5ce8cf47a4aacb314a0ed0332b987098f3be024b6af9024df6efdf9b SHA512 ec2e40a248e7eb5bff2ad9e57087058a8b4706d564bd340daba5a4700ad8a5389d1f9ec29984516a1167827ae55c28240dafb558df29e1f758a4f7af80caa1e7
EBUILD tp_smapi-0.43-r2.ebuild 1972 BLAKE2B 7233b4d28930f40417981c4f3b68924ffa505149970dd989e2487e529eda0b24fa4ef76902fdc01587d0837cf371430a68c7551724a1d9e6123bf6e451b4ed10 SHA512 7216a203f3330a6b1c6299ddc9ac9c3f6e511453e95fc11b12bb45dba9d9613ae56fed73e61ad469e46f70460770a05512804ddb24e6aa3a6572c5d279291b8e
+EBUILD tp_smapi-0.43-r3.ebuild 1067 BLAKE2B a51d7fd0cb31da0267b240404455406ab2776e77e2e74ee9065d62062af2c367a3f5ba5b2c8a83a09e9f5a14a7574909bad0c537f8127e63b02a2a5f09db560a SHA512 a05f14470ac995bcff009961334c0554fc8cea007154455823e35ec7f411d8d0d55f2ec74d001f48771ef4c90f01484bca4c8ea8e9390fd856c7a2612392bd9a
MISC metadata.xml 474 BLAKE2B dc28834282453dbb412e11a3677d2c4fe8bf2b9f90b4c700aa4de53b87ea0b1e80a9aeb8d24254a6e4d61e3e55c8fa3bf34db8eb55015ea788c5d49363618edf SHA512 94866e40b00e2ea573ac250e8e4f715c7cefc6118eba385ebbbfbe641d8ab6ccb691def271873bb50e6454f2bb7834fc7901c7dde8fa0ed5b132afee3af20970
diff --git a/app-laptop/tp_smapi/tp_smapi-0.43-r3.ebuild b/app-laptop/tp_smapi/tp_smapi-0.43-r3.ebuild
new file mode 100644
index 000000000000..bf08d020ede7
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.43-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="https://github.com/evgeni/tp_smapi"
+SRC_URI="https://github.com/evgeni/tp_smapi/releases/download/tp-smapi/${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="hdaps"
+
+pkg_setup() {
+ if use hdaps; then
+ local CONFIG_CHECK="~INPUT_UINPUT"
+ local WARNING_INPUT_UINPUT="Your kernel needs uinput for the hdaps module to perform better"
+ local CONFIG_CHECK="~!SENSORS_HDAPS"
+ local ERROR_SENSORS_HDAPS="${P} with USE=hdaps conflicts with in-kernel HDAPS (CONFIG_SENSORS_HDAPS)"
+ fi
+
+ linux-mod-r1_pkg_setup
+}
+
+src_compile() {
+ local modlist=( thinkpad_ec tp_smapi )
+ local modargs=( KSRC=${KV_DIR} KBUILD=${KV_OUT_DIR} )
+
+ if use hdaps; then
+ modlist+=( hdaps )
+ modargs+=( HDAPS=1 )
+ fi
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ newinitd "${FILESDIR}/${PN}-0.40-initd" smapi
+ newconfd "${FILESDIR}/${PN}-0.40-confd" smapi
+}