summaryrefslogtreecommitdiff
path: root/app-laptop/thinkfan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-laptop/thinkfan
reinit the tree, so we can have metadata
Diffstat (limited to 'app-laptop/thinkfan')
-rw-r--r--app-laptop/thinkfan/Manifest5
-rw-r--r--app-laptop/thinkfan/metadata.xml14
-rw-r--r--app-laptop/thinkfan/thinkfan-0.9.3.ebuild50
3 files changed, 69 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/Manifest b/app-laptop/thinkfan/Manifest
new file mode 100644
index 000000000000..07019940e8c5
--- /dev/null
+++ b/app-laptop/thinkfan/Manifest
@@ -0,0 +1,5 @@
+DIST thinkfan-0.9.3.tar.gz 39527 SHA256 b61c634996c450445d7e440bf41f7adcda86506063f832afa40d44e01061e45b SHA512 d2a29f9cae636c22b66958f8ec50cb60a162d745c3967257bb5e20cc9e152894d4e8a66f897ffa4e49353eba4a42e3499bb9e554719974284089a46cfc6280d7 WHIRLPOOL 3bdbc0ca3731fef85e385b3259cc9ce6bf4c3b15195138caf5b192847bbba411068d00df8e5673600796e15d4d965c116b73745e787bea9f5a68dbbb5ee118db
+EBUILD thinkfan-0.9.3.ebuild 1069 SHA256 f9238b914ecbac0d486032c86543acf9f020fb6de726f5e9a21b791096fac266 SHA512 ffec534bfe1c1eb08c1de3858347781d6f0dc349d7f3de39196a47166e65142d649e0e889141e9c90ce193f0f984ac386ce39cc45f6e70ff971278c3b6560247 WHIRLPOOL 57a42743f3766be96f827e2ca1669f180ce3c87f0f67b99f3a705fb7f4e587409934662191551ee874f32e17bc4e14f89134a9927c4da95e568d545074ad9b2e
+MISC ChangeLog 2439 SHA256 dfacbf4f5d3244b1da82a1710e0cc4f6298ce5a09988b8b4cf2e604fb001524f SHA512 d98148ecc47beda46bae3d2f97616d942fbdd1413e8d7f6f59bd6c4e6462fbcc4a7e658fc8e404b09f31ba44f8d408af0c68290091466ee25fb2c6c7fbd819dc WHIRLPOOL 81bb797d4bd6748b65318c35bfdc96286cdd5c0059e065c406174a6f6b355fd10b60883c1724b7e122713891907556b2c30df209c882c3a650052580fa08c7f6
+MISC ChangeLog-2015 3245 SHA256 6b2a006ebbfe768467b7d11e3cd2658af8e3a98214bbad18c4e42f4feb6ed201 SHA512 f8d328fcc757a86a238d1385cb7a843e3a673d9e687682e9ee9bacf2acaec468a6e6c0c48402b096bb3106228f67a2d7272f476fce3ca0604b0d296bbcbe34dd WHIRLPOOL ce55dd8cb3a7eb02f5f64d78f0fa9130dbee99b3bd47320aceba5182204075223af80c195f94144875953ee3180010c8479021bd02e4a1721d2e1b4d3d254704
+MISC metadata.xml 419 SHA256 d41324138271055ecfb54118b8235ca745d64b20db567cdd8b4c9d5bb707f598 SHA512 c0979a5886be1a527d7eb45176316320b6c116181f83ade62c6b900a01e6fb6538d738eb081e99dc6f3fd03589e34ac45f5c5da8eebbd33f13d04baa7fd913c8 WHIRLPOOL 0adf12d083fb3ae520cb7a1a121188e56678316cd46ff6e92894a501eaf3960e80a4f96758a497f68e7ff18a1a421a9fc20f9a24fb12ea257f71bfacbb5ef43e
diff --git a/app-laptop/thinkfan/metadata.xml b/app-laptop/thinkfan/metadata.xml
new file mode 100644
index 000000000000..79dc72426bd0
--- /dev/null
+++ b/app-laptop/thinkfan/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <use>
+ <flag name="atasmart">include libatasmart support to get disc temperature</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">thinkfan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-laptop/thinkfan/thinkfan-0.9.3.ebuild b/app-laptop/thinkfan/thinkfan-0.9.3.ebuild
new file mode 100644
index 000000000000..ca8dc1c15153
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.9.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils readme.gentoo-r1 systemd
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="atasmart"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e "s:#!/sbin/runscript:#!/sbin/openrc-run:" \
+ -i rcscripts/thinkfan.gentoo
+
+ sed -e "s:share/doc/${PN}:share/doc/${PF}:" \
+ -e "s:thinkfan.1:src/thinkfan.1:" \
+ -i CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ "-DCMAKE_BUILD_TYPE:STRING=Debug"
+ "-DUSE_ATASMART=$(usex atasmart)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd rcscripts/${PN}.gentoo ${PN}
+ systemd_dounit rcscripts/${PN}.service
+
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please read the documentation and copy an
+appropriate file to /etc/thinkfan.conf."