summaryrefslogtreecommitdiff
path: root/app-laptop/pbbuttonsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /app-laptop/pbbuttonsd
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/Manifest2
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild16
2 files changed, 11 insertions, 7 deletions
diff --git a/app-laptop/pbbuttonsd/Manifest b/app-laptop/pbbuttonsd/Manifest
index 8dec472ebd03..9a7a16378f56 100644
--- a/app-laptop/pbbuttonsd/Manifest
+++ b/app-laptop/pbbuttonsd/Manifest
@@ -7,5 +7,5 @@ AUX pbbuttonsd-0.8.1-lz.patch 920 BLAKE2B ab9a5cdf4b9ac2b1dd55229ab7dcfcf65bf4ff
AUX pbbuttonsd.rc6 355 BLAKE2B 41e646f547b684930949669760ffd7e09c6ef4591e6183b12d555dba45d100414cc5daa54ef26e2bba491841553961955cb0a29c9c5d6b37d4e13f9a3117a9fb SHA512 93165ce1d1c757e58b407656bf86084bb3fcfe0c55897fbb382f107ff9b3d69559255a11ac3017cf5741eb2923d753f5cc3f1b495e31e16b18b16757accfbdfb
AUX wireless 235 BLAKE2B 1fdc5401c1bcc927cad521bb7e6d502fd072c6aae119e59d92c19431985cccaecad5ba55a27af888e63881d0305ee732dce9b1e777e4b2322a98efaad13de310 SHA512 58cbfb80ec32ba6868fea500bcf58bf649a0f468a017ec8c200fe0edd0fd7f1fe17efaafca3e67c20df9fc5a6c80b2941237a375f6e73349a83593dcfacf2816
DIST pbbuttonsd-0.8.1a.tar.gz 589747 BLAKE2B a0410b7f165e8a0f5b6efa8fa86cc32a84e62da08141d285442d48f0e541d4d6d063e61a7e48aa7901135c4fc9640a7968be821619b3741ce30ba1497015aad4 SHA512 4aaf674872982925f7aa8e06a363f50830f13d9491f4a3b850c1852a8a6d4b2c72164f839c482eed059703dd25d900fe3bb774f78e7039ac2464ea7a1837bf99
-EBUILD pbbuttonsd-0.8.1a.ebuild 3251 BLAKE2B f671bdbfde56131bd0fe73cb8fa6398c6479c7fa2697815ed0c116945f96aec4f0274e251781efee8c8c692505f85d55ae3b414d2d547fb1c64b25a5e20559d0 SHA512 05df1091b4f54a8797a756d87549a4a88075993a5f8f4027127041209b3f65956f457fa9e682b914b6565c47ba19994af1adb81a76ca8f5944e7317cfe161cb1
+EBUILD pbbuttonsd-0.8.1a.ebuild 3365 BLAKE2B 18e56b5a9b8ddbde4bf6ad9040d7398474ab95947c4955465ee961a4e11759df9a50b8b44937bcee9828b287570a256181486477058636332075dad1c6557793 SHA512 324df66a1b56cece0644a6b81a985028ab0273dba99beca9b1690c3bcc2a278948862ee01a451789da6171bb4d8d1236a6cc77fae89bb6f828937936707c6350
MISC metadata.xml 511 BLAKE2B 74e7a1939ef37f6fb312232b3df04de1ba6b0bb2e8bd476c0ebdeb2d7efcda0015204e4c003388194ac481f3fcb551949b4dba5515b770cd2d6ab78dd43ab72b SHA512 5a56b1fe175cd76fa23d90e4499f0a6bacfacdb9cb2fd647dbabec42030021c0b4f27eb04b523b9ae7bc44706ee9404abdf5ff16aa92655fab5d00ac187eca5b
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild
index 8a17130c0544..f2e26d756df4 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools flag-o-matic
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Handles power management and special keys on laptops"
HOMEPAGE="http://pbbuttons.berlios.de"
@@ -74,15 +74,18 @@ src_compile() {
# Thanks to Stefan Bruda for this workaround
# Using -j1 fixes a parallel build issue with the docs
if use doc; then
- emake -j1
+ emake -j1 AR="$(tc-getAR)"
else
- emake
+ emake AR="$(tc-getAR)"
fi
}
src_install() {
dodir /etc/power
- use ibam && dodir /var/lib/ibam
+ if use ibam; then
+ dodir /var/lib/ibam
+ keepdir /var/lib/ibam
+ fi
default
@@ -93,8 +96,9 @@ src_install() {
use doc && dodoc -r doc/
dodir /etc/power/resume.d
+ keepdir /etc/power/resume.d
dodir /etc/power/suspend.d
- dodir /etc/power/scripts.d
+ keepdir /etc/power/suspend.d
exeinto /etc/power/scripts.d
doexe "${FILESDIR}"/wireless
ln -s "${D}"/etc/power/scripts.d/wireless "${D}"/etc/power/resume.d/wireless