summaryrefslogtreecommitdiff
path: root/app-laptop/nvidiabl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-laptop/nvidiabl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-laptop/nvidiabl')
-rw-r--r--app-laptop/nvidiabl/Manifest6
-rw-r--r--app-laptop/nvidiabl/files/nvidiabl-0.87-linux-4.0.patch23
-rw-r--r--app-laptop/nvidiabl/metadata.xml15
-rw-r--r--app-laptop/nvidiabl/nvidiabl-0.83.ebuild37
-rw-r--r--app-laptop/nvidiabl/nvidiabl-0.87.ebuild34
5 files changed, 115 insertions, 0 deletions
diff --git a/app-laptop/nvidiabl/Manifest b/app-laptop/nvidiabl/Manifest
new file mode 100644
index 000000000000..2b21beac5b26
--- /dev/null
+++ b/app-laptop/nvidiabl/Manifest
@@ -0,0 +1,6 @@
+AUX nvidiabl-0.87-linux-4.0.patch 904 BLAKE2B 0c08b3b88a71bac091cfc5c8ea584387e0be9317bae49924ac5ea9a3b8144fb62f53786d048766612b27edd85af827f29f37d630d4de269753c82e35936332f6 SHA512 85860cdd66605c88b1d806e8c6962d70c246dd34e463e9c990156b8a023bb7d47585e95a0444ca63827f64fc4a95064c9d12cdec29264b5d4a439dbcb33958ed
+DIST nvidiabl-0.83.tar.gz 448594 BLAKE2B c80b4f5e09f71004cc1e5eea033181a3de9906648775c415cf9c07e2a16e32fc7e45c32cbe4cd1cb264a2c4be00fc6bb80ac76a6109caf523663132fbf2df662 SHA512 cbf4f042acb9005c25d8d008973220f4d42fe890bfd86a34b72c0e56129dfcdcad2383acacf048e5e9da33aaf759053cdadeddac9e0946ae49a8a29ed03447dd
+DIST nvidiabl-0.87.tar.gz 36563463 BLAKE2B 6feab5505583a26d2426cb3a682e96dd72bb903b5c4187516b22fe4a0b4fb7bb0d7c797396c4b69ab62240baf65337dcb41efcd9952400e1c098f26f6e31ae10 SHA512 778f8b9e7d6d8e9ecbeef745bf3602e56b38757791d7b49ebf3326758117487f7494e232aaa9354b91fd17ee3578c80278e0e60175b274b1a1a93e952dc0dfe5
+EBUILD nvidiabl-0.83.ebuild 886 BLAKE2B 63e23276c6c22baa8dce2d84cddeca8a951e6cd57f123ab0d1f7b9b5073ebf995a7dca16e6e0352dfed95172eeda9485628e0e3213307b8f4ddb96da5c258c91 SHA512 f6c9be10669d2c4df5f7131b3f0407ed103a27fa10c802717a59efd19ee78d21a73b1695fa060f4465d965a3b286122ad8d2d042f8b8b22d61596e732cdb81db
+EBUILD nvidiabl-0.87.ebuild 910 BLAKE2B f73a517b6bbb7e304aad8a9a2a1183f48440299c5ce4bdf157ef1450cea4d23a1ad5ce966f0e4620958955d5c60b182d72af3da8f336d70a658b0d7ab3b718f8 SHA512 ab316b3421500eca4a562593075a0c79bbc7e0efc327c43109d0340be8ced1e2905a3069d0c10d780e5a6031dd687c655d20fe59a547cadb14b3fd577fec2613
+MISC metadata.xml 456 BLAKE2B 1ad02f89ac63a165bec586af632d8bb790bbbd90bff827d3a9407c460cd7a8a8fcaa00539f179cb4f2b22b43031c7db192785a6e6eed7fdfdf3ad177f9cb494b SHA512 d6330a8829f23e5bf3552ba6d04e863203342ba30ab75b3447696c416a33f63a0e8dcc318b3b4cb77ed98b4058a4f58cb0c3faf80946a3a7ea42fcce105320c5
diff --git a/app-laptop/nvidiabl/files/nvidiabl-0.87-linux-4.0.patch b/app-laptop/nvidiabl/files/nvidiabl-0.87-linux-4.0.patch
new file mode 100644
index 000000000000..b466bcb620c9
--- /dev/null
+++ b/app-laptop/nvidiabl/files/nvidiabl-0.87-linux-4.0.patch
@@ -0,0 +1,23 @@
+From dee67fbf8eeec1651dbee3c2045ce6a93da949dc Mon Sep 17 00:00:00 2001
+From: Thomas Wucher <mail@thomaswucher.de>
+Date: Tue, 14 Apr 2015 08:41:09 +0200
+Subject: [PATCH] Replace strnicmp by stncasecmp to fix build on Linux 4.0
+
+---
+ nvidiabl-module.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/nvidiabl-module.c b/nvidiabl-module.c
+index b789ea4..b306579 100644
+--- a/nvidiabl-module.c
++++ b/nvidiabl-module.c
+@@ -214,7 +214,7 @@ static int __init nvidiabl_init(void)
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,39)
+
+ for (iii = 0 ; iii < sizeof(backlight_type_ids) ; iii++) {
+- if (strnicmp(bl_type, backlight_type_ids[iii].id, sizeof(bl_type)) == 0) {
++ if (strncasecmp(bl_type, backlight_type_ids[iii].id, sizeof(bl_type)) == 0) {
+ props.type = backlight_type_ids[iii].type;
+ printk(KERN_INFO "nvidiabl: backlight type is %s\n", backlight_type_ids[iii].id);
+ }
+
diff --git a/app-laptop/nvidiabl/metadata.xml b/app-laptop/nvidiabl/metadata.xml
new file mode 100644
index 000000000000..d57b36ae2558
--- /dev/null
+++ b/app-laptop/nvidiabl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoobugzilla@jeltef.nl</email>
+ <name>Jelte Fennema</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">guillaumezin/nvidiabl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-laptop/nvidiabl/nvidiabl-0.83.ebuild b/app-laptop/nvidiabl/nvidiabl-0.83.ebuild
new file mode 100644
index 000000000000..60f196c88ea6
--- /dev/null
+++ b/app-laptop/nvidiabl/nvidiabl-0.83.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit linux-mod
+
+DESCRIPTION="Linux driver for setting the backlight brightness on laptops using
+NVIDIA GPU"
+HOMEPAGE="https://github.com/guillaumezin/nvidiabl"
+SRC_URI="https://github.com/guillaumezin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT="test"
+
+BUILD_TARGETS="modules"
+MODULE_NAMES="nvidiabl()"
+
+pkg_pretend() {
+ CONFIG_CHECK="FB_BACKLIGHT"
+ ERROR_FB_BACKLIGHT="Your kernel does not support FB_BACKLIGHT. To enable you
+it you can enable any frame buffer with backlight control or nouveau.
+Note that you cannot use FB_NVIDIA with nvidia's proprietary driver"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ BUILD_PARAMS="KVER=${KV_FULL}"
+ MAKEOPTS+=" V=1"
+ linux-mod_src_compile
+}
diff --git a/app-laptop/nvidiabl/nvidiabl-0.87.ebuild b/app-laptop/nvidiabl/nvidiabl-0.87.ebuild
new file mode 100644
index 000000000000..e4179351b278
--- /dev/null
+++ b/app-laptop/nvidiabl/nvidiabl-0.87.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit linux-mod eutils
+
+DESCRIPTION="Linux driver for setting the backlight brightness on laptops using NVIDIA GPU"
+HOMEPAGE="https://github.com/guillaumezin/nvidiabl"
+SRC_URI="https://github.com/guillaumezin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+pkg_setup() {
+ CONFIG_CHECK="FB_BACKLIGHT"
+ ERROR_FB_BACKLIGHT="Your kernel does not support FB_BACKLIGHT. To enable you
+it you can enable any frame buffer with backlight control or nouveau.
+Note that you cannot use FB_NVIDIA with nvidia's proprietary driver"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linux-4.0.patch
+}
+
+src_compile() {
+ BUILD_PARAMS="KVER=${KV_FULL}"
+ BUILD_TARGETS="modules"
+ MODULE_NAMES="nvidiabl()"
+
+ MAKEOPTS+=" V=1"
+ linux-mod_src_compile
+}