summaryrefslogtreecommitdiff
path: root/app-laptop/hdaps-gl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-laptop/hdaps-gl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-laptop/hdaps-gl')
-rw-r--r--app-laptop/hdaps-gl/Manifest4
-rw-r--r--app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff11
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild33
-rw-r--r--app-laptop/hdaps-gl/metadata.xml8
4 files changed, 56 insertions, 0 deletions
diff --git a/app-laptop/hdaps-gl/Manifest b/app-laptop/hdaps-gl/Manifest
new file mode 100644
index 000000000000..a16009241ff9
--- /dev/null
+++ b/app-laptop/hdaps-gl/Manifest
@@ -0,0 +1,4 @@
+AUX hdaps-gl-0.0.5-as-needed.diff 346 BLAKE2B 475c8784ee192f632686177b3d4cf25be97260893621b9bfcff2e649d36cdcf1d4059c9c643cf3153daabb234d8520b51f033de471e2b62d9702db0720bc0782 SHA512 6128fb53c82485a7141d7bff95aea3ab6d20593a9c535bee841c22bcba9504bdf3913eff07fab0de3b58225cab60b3a41638b250d37f1a0f4f67d03c02a29716
+DIST hdaps-gl-0.0.5.tar.gz 2495 BLAKE2B 00b9b79b906e32b5671ae97c30fe0e3007da8ef809078b664befe46e472af39977f6947dfbde53afee30d42e5b104ba055d5e5412d76263d5741db75c663b308 SHA512 6ebef6324fcdfaf5c2ec6cc8382d376c711e5d957a4ffdd4ee150317649ea0a47552e421f8008a3498ac49487657dca2f49b1a50169d7ab02ee5bef856625d19
+EBUILD hdaps-gl-0.0.5.ebuild 604 BLAKE2B 99848773670133279f29304b88170ecdd66b8e2b5fd01fe41ea9730f577bda063ca513521957741cfd6a719c808e856f8ddd89f0e26445d59e8e1550d2566b69 SHA512 3338f31513e579b73e7ae97eacdcf906076745db0ad01e297114d4db78dcfa8f83a41dec409d77d8cb5d9de84c23b8af282ae62e64bcef0c14b3cf9d1db2c6b4
+MISC metadata.xml 242 BLAKE2B b0338d200d4eb439908bd1e4990832314acd6c02985f36736137c4d7a00e7552f0bd9bc97c20bc3980ceec2551b27278c163711f0af5c6af01bfc52a2cfb8831 SHA512 8376434ff91f5848064ea6c4e040d35ada37f295c0120b65ee9418f6d140ca98a8fb442bdb1e03b292cecc404f323cb9b28ed83da353e5e4dd5eb7f842f2df18
diff --git a/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff b/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff
new file mode 100644
index 000000000000..0d0214033252
--- /dev/null
+++ b/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff
@@ -0,0 +1,11 @@
+--- hdaps-gl-0.0.5/Makefile 2005-08-30 20:06:53.000000000 +0200
++++ hdaps-gl-0.0.5-1/Makefile 2008-09-22 22:55:57.000000000 +0200
+@@ -10,7 +10,7 @@
+ all: hdaps-gl
+
+ hdaps-gl: hdaps-gl.c
+- $(CC) $(CFLAGS) $(LIBDIR) $(LIBRARIES) -o hdaps-gl hdaps-gl.c
++ $(CC) $(CFLAGS) $(LIBDIR) -o hdaps-gl hdaps-gl.c $(LIBRARIES)
+
+ clean:
+ rm -f hdaps-gl *.o
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
new file mode 100644
index 000000000000..7bc369635dc7
--- /dev/null
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenGL visualization for HDAPS data"
+HOMEPAGE="http://hdaps.sourceforge.net"
+SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/freeglut"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-as-needed.diff"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/app-laptop/hdaps-gl/metadata.xml b/app-laptop/hdaps-gl/metadata.xml
new file mode 100644
index 000000000000..4d89b7be7780
--- /dev/null
+++ b/app-laptop/hdaps-gl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">hdaps</remote-id>
+ </upstream>
+</pkgmetadata>