summaryrefslogtreecommitdiff
path: root/app-laptop/framework-laptop-kmod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-30 11:00:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-30 11:00:41 +0000
commit18a69c52453e0db481bfa441cf1d9616c97c9928 (patch)
tree9ea41629c5312d98d2ac8bda976eb877403cd2f7 /app-laptop/framework-laptop-kmod
parente984f0bb49fed14c51c7c15ed8d7b8bd2cca4b1d (diff)
gentoo auto-resync : 30:11:2023 - 11:00:41
Diffstat (limited to 'app-laptop/framework-laptop-kmod')
-rw-r--r--app-laptop/framework-laptop-kmod/Manifest3
-rw-r--r--app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild46
-rw-r--r--app-laptop/framework-laptop-kmod/metadata.xml11
3 files changed, 60 insertions, 0 deletions
diff --git a/app-laptop/framework-laptop-kmod/Manifest b/app-laptop/framework-laptop-kmod/Manifest
new file mode 100644
index 000000000000..06aba1e3f3e2
--- /dev/null
+++ b/app-laptop/framework-laptop-kmod/Manifest
@@ -0,0 +1,3 @@
+DIST framework-laptop-kmod-0_pre20231129.gh.tar.gz 10672 BLAKE2B 9fd39ca526e29054e31af264bc7f6521fdfe7348c5a4083fef4ba012cb5c2b84d5d91f4ba93d37c78052d5ee3b9e384f3adde234a41763ef2f324fab180f2517 SHA512 0fbcb2e34daac1e7d2d7b345b8e7b0d07777908a181fcbe5860af1a9da1de8db36c8b44bb8ab95bac36976fc9e83f156f11f940bf51a976096fdd7c065a07341
+EBUILD framework-laptop-kmod-0_pre20231129.ebuild 1015 BLAKE2B ce424fa36889c46329ec7651b2d6703fce07836989855a1133bbc675835f0814a7f2e3127f41a664a24c164e47bbbfc4fd27ee04437d72e513287b417a939892 SHA512 505cc8424b0dc0e1a28fb29f63ace04e15fa213f004a25ee9e392c26fec67b1b5309234fe8fde5ab5e4095ed8ffa2592febd9220d5d185082181f2122553e6e1
+MISC metadata.xml 344 BLAKE2B e35364b1c9e10982f93848cf7a64ade9132672edbca7e631ec5b8fb23dbea4e3ad251a33f6a3b95c694cb63ccaf279eb011730a3f18be588677170414d7c49cf SHA512 2203683eea9b10b06f551344fa91d8d27692fb1918c163893dbceaa8f481b0272861555ae60e1f0e13c1a023e46206a1a804a39585fbdf9bf1a10a9130e03bec
diff --git a/app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild b/app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild
new file mode 100644
index 000000000000..ae4a4b4c5960
--- /dev/null
+++ b/app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+COMMIT_HASH="fed64af4c19a15ef6bb7dca79b692d265e845699"
+DESCRIPTION="Kernel module to expose more Framework Laptop stuff"
+HOMEPAGE="https://github.com/DHowett/framework-laptop-kmod"
+SRC_URI="https://github.com/DHowett/framework-laptop-kmod/archive/${COMMIT_HASH}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CONFIG_CHECK="
+ ~CROS_EC
+ ~CROS_EC_LPC
+"
+
+DOCS=(
+ README.md
+)
+
+pkg_pretend() {
+ check_extra_config
+}
+
+src_compile() {
+ local modlist=(
+ framework_laptop
+ )
+ linux-mod-r1_src_compile
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+
+ #if kernel_is -lt 6 7 0; then
+ ewarn "For the Framework Laptop 13 AMD Ryzen 7040 series and the Framework Laptop 16a,"
+ ewarn "you will need to apply the patch series from this URL:"
+ ewarn "https://lore.kernel.org/chrome-platform/20231005160701.19987-1-dustin@howett.net/"
+ #fi
+}
diff --git a/app-laptop/framework-laptop-kmod/metadata.xml b/app-laptop/framework-laptop-kmod/metadata.xml
new file mode 100644
index 000000000000..af58c2e437f5
--- /dev/null
+++ b/app-laptop/framework-laptop-kmod/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">DHowett/framework-laptop-kmod</remote-id>
+ </upstream>
+</pkgmetadata>