summaryrefslogtreecommitdiff
path: root/app-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-05 16:24:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-05 16:24:39 +0100
commit4aec9255c99411cb07138353f1bdda61fe0b501d (patch)
tree034e5a94d1660a6fa13cec598dfb476647978e20 /app-i18n
parenta0f09b2c947909b614c52fcfbdce964469404101 (diff)
gentoo auto-resync : 05:09:2022 - 16:24:39
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/Manifest.gzbin18829 -> 18829 bytes
-rw-r--r--app-i18n/ibus-libpinyin/Manifest2
-rw-r--r--app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.0.ebuild69
3 files changed, 71 insertions, 0 deletions
diff --git a/app-i18n/Manifest.gz b/app-i18n/Manifest.gz
index d8ed63b1f6c1..be96035c2162 100644
--- a/app-i18n/Manifest.gz
+++ b/app-i18n/Manifest.gz
Binary files differ
diff --git a/app-i18n/ibus-libpinyin/Manifest b/app-i18n/ibus-libpinyin/Manifest
index 12b884d1248e..126f5364fcb7 100644
--- a/app-i18n/ibus-libpinyin/Manifest
+++ b/app-i18n/ibus-libpinyin/Manifest
@@ -1,3 +1,5 @@
DIST ibus-libpinyin-1.12.1.tar.gz 1766803 BLAKE2B 1de8a51b52688dede32c572b39bd379296480ab2b0f909357465370e346bdf50f4cade5ab3f105f62a74e59cf2dc5e8d5235aedde7571b70d3c5dcee86d2e36b SHA512 ad6e7507bdb468d506071135449383e5bd4fc878bcffda4be6e4e7915b79dbaf919d2fa941b92b177dc7790bd895eaa9a6d04a2610f85e1e80e8eb50f188211d
+DIST ibus-libpinyin-1.13.0.tar.gz 1726869 BLAKE2B f18ae81edb4ebf18f569fc13f3088f32e57c6a4512f7cafb33a18fdb08d5fdcdb17ff1861c3419db3063808f655510f6f4de63c274d798c48731ac4632203ba6 SHA512 8eca89c3c71ada37ec93307556fc476ad8719e58ca828f684dff6e74e1cb91df3e8c8ce03c87dbb72d5b7213e7c7ca367da8cf6b1dddb47d63afdf23d53bc54c
EBUILD ibus-libpinyin-1.12.1.ebuild 1454 BLAKE2B dca0fa3d0fc728850a37ecdb41a79b630d039b3f8c16ea9c5292870cb59f5b3c8f603efc6c29b422812030fe385b1b0d6c7d7dbc6c17fe4d0ca4ee4ef24f0bde SHA512 a1c03b373caa4053687562bbd55ca3795296d5f7d9c3060b077708a685466f33f8f0488939a1e22893e76e5f1c8b88ca2f2913b5dbbfdcddfca0c8ea36c8b16d
+EBUILD ibus-libpinyin-1.13.0.ebuild 1456 BLAKE2B c8926b46682e0b4b1b72711738d2c64938c576343e5ca53b4cb7d41c8300e130a05f9bd5aec8d6f3fbc75df5cf95846a1212dd4399dfca0b8e2b6718f2880129 SHA512 64919ed1e6a49df528558976a8238e672bf0d8209a5bf173c49c6606c2a0ac44f0cff7d770b62e9adb2de9c25c8c656d6f13d2a1782426495f15cb1e426e3ded
MISC metadata.xml 834 BLAKE2B ac644e5ceced4364c282f0766cfc5d85dfc14fc19fff46e96dee2aa8ff48c1c5d84dd496e3f83951983f311cbab0ea84652fab3e3a87e870dab999cf46821452 SHA512 dd1629baeddeb1ee4ab1670a4e29af865a75e40b7c6b58e9029af5900d5de9bfb98f71ccaf7eae508f0849ac85f4530d8770cc392d9bb8c31a881f8154ac5761
diff --git a/app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.0.ebuild b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.0.ebuild
new file mode 100644
index 000000000000..7f8fdf0ab762
--- /dev/null
+++ b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2015-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+LUA_COMPAT=( lua5-{1..3} )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools gnome2-utils lua-single python-single-r1
+
+DESCRIPTION="Intelligent Pinyin and Bopomofo input methods based on LibPinyin for IBus"
+HOMEPAGE="https://github.com/libpinyin/ibus-libpinyin https://sourceforge.net/projects/libpinyin/"
+SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua opencc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+BDEPEND="dev-db/sqlite:3
+ virtual/pkgconfig"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-i18n/libpinyin-2.2.1:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ virtual/libintl
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ boost? ( dev-libs/boost:= )
+ lua? ( ${LUA_DEPS} )
+ opencc? ( app-i18n/opencc:= )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^appdatadir/s:/appdata:/metainfo:" \
+ data/Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-english-input-mode \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable opencc)
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}