summaryrefslogtreecommitdiff
path: root/app-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-25 21:55:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-25 21:55:22 +0100
commit2a27c2168109b412410436b9cd6b71dbfe31f6ef (patch)
tree22d3cb59b0c68f1766670f2d010aa2d3b3b6ea22 /app-i18n
parentd0bb3151c569ab6e40c84c177f43bff3c7ce4780 (diff)
gentoo auto-resync : 25:08:2023 - 21:55:22
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/Manifest.gzbin17380 -> 17379 bytes
-rw-r--r--app-i18n/ibus-anthy/Manifest2
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.15.ebuild72
-rw-r--r--app-i18n/unicode-cldr/Manifest2
-rw-r--r--app-i18n/unicode-cldr/unicode-cldr-42.0.ebuild22
5 files changed, 74 insertions, 24 deletions
diff --git a/app-i18n/Manifest.gz b/app-i18n/Manifest.gz
index 058169a33502..04ee4428cc6d 100644
--- a/app-i18n/Manifest.gz
+++ b/app-i18n/Manifest.gz
Binary files differ
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index 3b1243cbf6f7..7527ce973a77 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1,3 +1,5 @@
DIST ibus-anthy-1.5.14.tar.gz 267418 BLAKE2B a4da45588d8736f10ccf26af52179da85bd3a17a8f1fbdba622058d1eaed933b0102fe12357613574e377df323145487838c3f74c052c813462b435905d5c941 SHA512 4d06d4e177df62d22c61bf6ebfda04ddbf545ea1947d0c315e3dfe5e48d9ddc57e5fcc89919ae3b9f7430e6124a5dfb1295f4ca7362fbc35714d627f80fae6d8
+DIST ibus-anthy-1.5.15.tar.gz 274290 BLAKE2B fb00ac3dc1b96c5567cb251a2e8984845c387402bdf9255e720972acb0163f59906ba7ad076d46da20ead75042a181b911d360d94bcaa85ef2e5a112daa33c18 SHA512 0acebb1b397f98d156ba9d6465bdb1025fb23a6b05b72c9b471827b45e22af55468b7674469f348712682446641c98d68f3d2aa339d2a1997a2df8c2bac45a7c
EBUILD ibus-anthy-1.5.14.ebuild 1310 BLAKE2B 806f7c1a3bbf5bb7a516060d7b110163cc00df002537ac0725c57ee4b9f4d243b58a72e0f4a974d4851c1784269e38dc45dac784713e54632337717188eeda40 SHA512 a820a7b41ab9effb17e4acfeeeef089c143c87539ddd9985d3a9afb47c212eb8e4c2bb1d3a21f18e7c6a6022122327ba6d226032b3ca7ea5b87bd68430e110c2
+EBUILD ibus-anthy-1.5.15.ebuild 1312 BLAKE2B 6fe73a84eb5a0871fbd16532d1e9d75116b49f85d95efca6427296b65320479b40f902ba124f01401cdb76f53f2fd34e8fbe48835e7a581947a921afb0da77e9 SHA512 e4ab1007ce2c9e48b6dbc2995a6b2b5f2bd86e38fdaad9d3eed831406a93b809412b24bcab147e9726a6e9f16fb73ba236c79e0e61a46d05afde3e8ef56949c2
MISC metadata.xml 325 BLAKE2B ae0af274a4321f66c02696f5f6440ce55a1a8406efe0f5c17c76606ab536b157f528eb93508d1ac95a893a54ada06c538d627754f8795271e3bb99eb4bbfdcc1 SHA512 64b47eae1d72f07324b98eb1dbc9a2a4b7cc0c74172e0df55e9d5abdaf10ebe1d90f4217b973979e3b53c5a21084fcad6785203a7b4280dc0706d4e6d1bd74f6
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.15.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.15.ebuild
new file mode 100644
index 000000000000..078f4951d2c6
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.15.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-i18n/unicode-cldr/Manifest b/app-i18n/unicode-cldr/Manifest
index 88f942134eaa..99ad04ef9352 100644
--- a/app-i18n/unicode-cldr/Manifest
+++ b/app-i18n/unicode-cldr/Manifest
@@ -1,7 +1,5 @@
-DIST unicode-cldr-common-42.0.zip 30178050 BLAKE2B 076e3eca12534feff8e0e54bdc1fa38fc0db0f78cac8b4e35b343763a8ac6787745aa36be165684f4d6dda423409c4431a8e4941c53ae7d340ead0b35edbca30 SHA512 315448fe6a9ac2d5a6a7fd1a27b38c5db30fed053654a803d50e3a8d06aa08ad153e8e57089fa094c561f41a54f37eecda0701b47a1813879902be71945aa38a
DIST unicode-cldr-common-43.0.zip 31934452 BLAKE2B 8390db2fb58ede0f55ebe369e5598c6a47b6ed01c95162d85365a699ceeb15d4d912a1ea26062c8f37a467c58fdaca27e99a9a133fec4afe15bf6ac6ba29b4f6 SHA512 930c64208d6f680d115bfa74a69445fb614910bb54233227b0b9ae85ddbce4db19e4ec863bf04ae9d4a11b2306aa7394e553384d7537487de8011f0e34877cef
DIST unicode-cldr-common-43.1.zip 31936262 BLAKE2B 1a52c4ffbe1040e01571a69bb4e66d7065c38be97f0e44214d5c13d973f2f9e620357e3b6ab40bb94c3506f097062a58973ca3259b240da12ffeb84e9a1fd567 SHA512 f9915c285b6fe1d4186b19c6c6b5f53876ee976a0851d1eade6b79843ddc43951bcce42363dc1e0fa455223a9ae8b8d85c167c23f1b4c49cfe39034bd202a3c8
-EBUILD unicode-cldr-42.0.ebuild 539 BLAKE2B 7868559c4eeb360f1834ba0ef6db44dbd3b1d9b9bd3c860c604c030034a43ea0e5435dbdfdb5c30880bee00b05931b3ae526e82b3486e8960768bff0528a75d1 SHA512 785a5b736434147e320a329850efcfc9fd2abdb1ff68cc9bb4ea667e313da8ffd3ed23f88083f80777b1fbba543e1537f656495b6f3c40d8dcbc554eb46dbb7d
EBUILD unicode-cldr-43.0.ebuild 539 BLAKE2B 7868559c4eeb360f1834ba0ef6db44dbd3b1d9b9bd3c860c604c030034a43ea0e5435dbdfdb5c30880bee00b05931b3ae526e82b3486e8960768bff0528a75d1 SHA512 785a5b736434147e320a329850efcfc9fd2abdb1ff68cc9bb4ea667e313da8ffd3ed23f88083f80777b1fbba543e1537f656495b6f3c40d8dcbc554eb46dbb7d
EBUILD unicode-cldr-43.1.ebuild 546 BLAKE2B 81a8e0062d5df8c3743c12b66b67150ca92b48810ef28eab049d0d7826541b3ecaec9a3bdc3d1837cfe09ccf44f00053f3802a04137e266ad4150ff3ff5fc892 SHA512 08cc84cee6ecf5e3b03438fe52872bbbf960c545248f8ea5d21d48baa42c177e119537d08c1803233496d76579a7b3adb10c69775402bd8018b5a277d2e41b1d
MISC metadata.xml 259 BLAKE2B 473457dc1808c494d8a08c731bc36bc3f6fd42ac730b0e7372e9749275ad413c56abc214d6b8d43c3e3f3d878a81e61d3ac1088b0606e99b449018828f056c4c SHA512 42603797647a4e2bdd69fc8548c0f035143c2a94b836763b39fc0dda770621970fbb233327c142107bca40f48b2b380fe97c6517e5fce633ba2c11f7a34402fc
diff --git a/app-i18n/unicode-cldr/unicode-cldr-42.0.ebuild b/app-i18n/unicode-cldr/unicode-cldr-42.0.ebuild
deleted file mode 100644
index 8185c0164e54..000000000000
--- a/app-i18n/unicode-cldr/unicode-cldr-42.0.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-DESCRIPTION="Unicode Common Locale Data Repository"
-HOMEPAGE="https://cldr.unicode.org/"
-SRC_URI="https://unicode.org/Public/${PN#*-}/${PV%.0}/${PN#*-}-common-${PV}.zip -> ${PN}-common-${PV}.zip"
-
-LICENSE="unicode"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
-IUSE=""
-
-RDEPEND=""
-BDEPEND="app-arch/unzip"
-S="${WORKDIR}"
-
-src_install() {
- insinto /usr/share/${PN/-//}
- doins -r common
-}