summaryrefslogtreecommitdiff
path: root/app-i18n/uim/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
commit78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (patch)
tree285997f09f32d26633ba2beffd30c972a4ec87a2 /app-i18n/uim/files
parentbf99f8024d68382f76665735c70ae912331bc2ca (diff)
gentoo auto-resync : 04:10:2022 - 13:17:38
Diffstat (limited to 'app-i18n/uim/files')
-rw-r--r--app-i18n/uim/files/uim-clang-16-configure.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/uim/files/uim-clang-16-configure.patch b/app-i18n/uim/files/uim-clang-16-configure.patch
new file mode 100644
index 000000000000..46e3bac01534
--- /dev/null
+++ b/app-i18n/uim/files/uim-clang-16-configure.patch
@@ -0,0 +1,41 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -601,6 +601,7 @@ if test "x$ac_cv_func_snprintf" = xyes; then
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
+ #include <stdio.h>
++#include <stdlib.h>
+ int main(void){char b[5];snprintf(b,5,"123456789");exit(b[4]!='\0');}
+ ]])],
+ [AC_MSG_RESULT(yes)],
+--- a/m4/openssl.m4
++++ b/m4/openssl.m4
+@@ -76,6 +76,7 @@ AC_MSG_CHECKING([OpenSSL header version])
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <openssl/opensslv.h>
+ #define DATA "conftest.sslincver"
+@@ -156,7 +157,9 @@ AC_ARG_WITH(openssl-header-check,
+ AC_MSG_CHECKING([whether OpenSSL's headers match the library])
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
++#include <stdlib.h>
+ #include <string.h>
++#include <openssl/crypto.h>
+ #include <openssl/opensslv.h>
+ int main(void) { exit(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); }
+ ]])],
+@@ -220,8 +223,8 @@ int main(void) { DTLSv1_method(); }
+ AC_MSG_CHECKING([if programs using OpenSSL functions will link])
+ AC_LINK_IFELSE(
+ [AC_LANG_SOURCE([[
+-#include <openssl/evp.h>
+-int main(void) { SSLeay_add_all_algorithms(); }
++#include <openssl/crypto.h>
++int main(void) { OpenSSL_version_num(); }
+ ]])],
+ [
+ AC_MSG_RESULT(yes)