summaryrefslogtreecommitdiff
path: root/app-i18n/uchardet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/uchardet
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/uchardet')
-rw-r--r--app-i18n/uchardet/Manifest4
-rw-r--r--app-i18n/uchardet/metadata.xml15
-rw-r--r--app-i18n/uchardet/uchardet-0.0.6.ebuild31
-rw-r--r--app-i18n/uchardet/uchardet-9999.ebuild27
4 files changed, 77 insertions, 0 deletions
diff --git a/app-i18n/uchardet/Manifest b/app-i18n/uchardet/Manifest
new file mode 100644
index 000000000000..00648d5f1755
--- /dev/null
+++ b/app-i18n/uchardet/Manifest
@@ -0,0 +1,4 @@
+DIST uchardet-0.0.6.tar.xz 169192 SHA256 8351328cdfbcb2432e63938721dd781eb8c11ebc56e3a89d0f84576b96002c61 SHA512 eceeadae060bf277e298d709856609dde32921271140dc1fb0a33c7b6e1381033fc2960d616ebbd82c92815936864d2c0743b1b5ea1b7d4a200df87df80d6de5 WHIRLPOOL 3fa915fa768be9cb4002e0a1b84c120db017f59fd0011df36a4853c53b403d5f3839647ab7aff8d8691a43ef0ecc90714475ef6a46a85d20abbd57fba7d90a13
+EBUILD uchardet-0.0.6.ebuild 783 SHA256 5204e50aa9c8500c93b4b1dfac4f4c1d1f4b032aad621461988ce569f90c8b37 SHA512 ead9165ebd16fd687de82e8650541a7656cc03bb8ef6702edd6169d05d0781e2b381d6e447884a9aaac44b9b977b70699e7bc9a5b7a5f78b0df2bc5be1810d10 WHIRLPOOL 59e7e86a609ac00179734de390532f7f02089e89096876dd609b5078bdf77872439d86cf164a1f3a067d12ab8f27b6451e4e970bcc7882571d532ac4f371392c
+EBUILD uchardet-9999.ebuild 614 SHA256 f4f7b032ea896d4473153c5ba523bad11976f4db9612d5bf3deb748d25cc4381 SHA512 bd7ad0e7c6f2579f88cf66c49bdc5a40ae8b7d0bc0cd05d435c0ab1f844f7bb2dae2d8fa21a4e9f80921ad19a1a98d777b6751ea332291da8f22ce461b5291b9 WHIRLPOOL 950d9d4c0a4a3e7fc1c73e4f5cf3a951d9d3b43483d80ac396938b63d234f41bf89ccd3227ab17bfc8e8bf77e7c7a9179a02b9a57e45ec8d29e86f066955c41d
+MISC metadata.xml 472 SHA256 a71aa88e9a24e6e01d47776ec56baeb3170d3638ca483f0088869344b161d340 SHA512 3cc702714648db5605638ba28364caa1e0ad0be1b9fb519b434f34fa993f76ba29a9ccdef0e8dea8f4b0fd89514c7196328a1f77efbb9aece30adce5063f7536 WHIRLPOOL dd6598374a41ccdf46867e65a5c02fccab9a505e3129eb95c8ca5f74a69b6cd307c08aadae40fa26d44bf3852d69d95ca78bd3f310f1a772361ce828d7eab63b
diff --git a/app-i18n/uchardet/metadata.xml b/app-i18n/uchardet/metadata.xml
new file mode 100644
index 000000000000..fea82382a727
--- /dev/null
+++ b/app-i18n/uchardet/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.freedesktop.org/enter_bug.cgi?product=uchardet</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/uchardet/uchardet-0.0.6.ebuild b/app-i18n/uchardet/uchardet-0.0.6.ebuild
new file mode 100644
index 000000000000..fc32c0008b49
--- /dev/null
+++ b/app-i18n/uchardet/uchardet-0.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An encoding detector library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
+SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 x86"
+IUSE="static-libs test"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use test || cmake_comment_add_subdirectory test
+
+ # Remove flaky test. See Gentoo bug 631852.
+ # Track https://bugs.freedesktop.org/show_bug.cgi?id=101033
+ rm test/th/tis-620.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/uchardet/uchardet-9999.ebuild b/app-i18n/uchardet/uchardet-9999.ebuild
new file mode 100644
index 000000000000..c268f955e469
--- /dev/null
+++ b/app-i18n/uchardet/uchardet-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="An encoding detector library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs test"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use test || cmake_comment_add_subdirectory test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}