summaryrefslogtreecommitdiff
path: root/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild')
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
new file mode 100644
index 000000000000..dde8e4a9a8a7
--- /dev/null
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
+HOMEPAGE="http://tomoe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-i18n/scim-1.2.0
+ >=app-i18n/tomoe-gtk-0.6.0
+ >=x11-libs/gtk+-2.4:2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35.0
+"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}