summaryrefslogtreecommitdiff
path: root/app-i18n/opencc/opencc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /app-i18n/opencc/opencc-9999.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'app-i18n/opencc/opencc-9999.ebuild')
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
index 877345405505..2bcf333bd7cf 100644
--- a/app-i18n/opencc/opencc-9999.ebuild
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2010-2020 Gentoo Authors
+# Copyright 2010-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -33,8 +33,8 @@ DEPEND="dev-cpp/tclap
dev-libs/marisa:0=
dev-libs/rapidjson
test? (
- dev-cpp/benchmark
dev-cpp/gtest
+ !hppa? ( !sparc? ( dev-cpp/benchmark ) )
)"
RDEPEND="dev-libs/marisa:0="
@@ -42,11 +42,6 @@ if [[ "${PV}" != "9999" ]]; then
S="${WORKDIR}/OpenCC-ver.${PV}"
fi
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.0-parallel_build.patch"
- "${FILESDIR}/${PN}-1.1.2-system_libraries.patch"
-)
-
DOCS=(AUTHORS NEWS.md README.md)
src_prepare() {
@@ -58,11 +53,9 @@ src_prepare() {
}
src_configure() {
- local -x CXXFLAGS="${CXXFLAGS} -I${ESYSROOT}/usr/include/rapidjson"
-
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc ON OFF)
- -DENABLE_BENCHMARK=$(usex test ON OFF)
+ -DENABLE_BENCHMARK=$(if use test && has_version -d dev-cpp/benchmark; then echo ON; else echo OFF; fi)
-DENABLE_GTEST=$(usex test ON OFF)
-DUSE_SYSTEM_DARTS=ON
-DUSE_SYSTEM_GOOGLE_BENCHMARK=ON