summaryrefslogtreecommitdiff
path: root/app-i18n/man-pages-de
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-i18n/man-pages-de
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-i18n/man-pages-de')
-rw-r--r--app-i18n/man-pages-de/Manifest1
-rw-r--r--app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-i18n/man-pages-de/Manifest b/app-i18n/man-pages-de/Manifest
index d342109cb31b..ff4b8bc22a59 100644
--- a/app-i18n/man-pages-de/Manifest
+++ b/app-i18n/man-pages-de/Manifest
@@ -1,3 +1,4 @@
DIST manpages-de-v2.12.tar.bz2 10242050 BLAKE2B fa497a6fce2c2387dad2ab9443584174d8d5fab530b94e0123e71286c588cb3a2e52aa96760dbfd6545bed013c460e1bf61eb4a5af0673bb84c1c0f0c960a357 SHA512 548d3dd500ce1eadc71365119e35072b71e3fbe36eba664d992e94897f442fb93f9397053f72363f83dff2e931d93e2af995976736d8513d11d7c42bdb471862
+EBUILD man-pages-de-2.12-r1.ebuild 1939 BLAKE2B 72a35122ddd8142df74d0d672085822586f3150fb099d86d632efc6023a946400b6b785d3303fa5bb392e6b5b47a3e07f6053c8a4790a0a7f6a84375ee1190b1 SHA512 0f02c403ac476ad1a62ead48b63c651e5bcaa38f9e5fa69cfd8b081a3e1015a66e7a0524171be5f1601758ee8e43587ab399ad50c5accb7743962fa26f08da51
EBUILD man-pages-de-2.12.ebuild 1884 BLAKE2B 80663f53a6c60144903e627c999cc85af7c8fcd0b6666abb1c29c352bcd9e01a686865617a7eaf094d50d728907ce6842449c18cf5d0f9fd07303f720093843d SHA512 05efb264a7f9f15afa2f786d3ff8aa361aa91598c17cbac1c78c9016ba9d8ad08abc0e1e824ea879097be62db35a5ab6923b11898105d9c5011f9ba8c815c1d8
MISC metadata.xml 369 BLAKE2B 41170815bcde0a65831b0453eee7b99359594bc67d345e31d1228d6b5def740d73087b96473511a8249528ac16a80b0eeee91791f9d4f113cb5caed918b40552 SHA512 e36208b3689927021e51ad2348ba3f5a5598b9657ffd7156d928dc817b90ed91a57d43605eb8a3e2fde1caf04349ba76b68ebc7ead1061ecca66280095179658
diff --git a/app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild b/app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild
new file mode 100644
index 000000000000..5901e1eda028
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN/-/}-v${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="https://salsa.debian.org/manpages-de-team/manpages-de"
+SRC_URI="https://salsa.debian.org/manpages-de-team/manpages-de/-/archive/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+BDEPEND="app-text/po4a"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ sed '/gzip --best/d' -i po/Makefile.am || die
+
+ # sys-apps/shadow has it's own translated man-page for this
+ local manpage
+ local noinst_manpages=(
+ upstream/debian-unstable/man1/groups.1
+ po/man1/free.1.po
+ po/man1/groups.1.po
+ po/man1/su.1.po
+ po/man1/uptime.1.po
+ )
+ for manpage in ${noinst_manpages[@]} ; do
+ rm "${manpage}" || die
+ done
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ local PORTAGE_COMPRESS_FLAGS_LOCAL=${PORTAGE_COMPRESS_FLAGS}
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip)
+ PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+
+ # Fix source files for symlinks
+ local LINKSOURCE
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2)
+ for LINKSOURCE in upstream/*/links.txt ; do
+ sed -i -e 's/\.gz/\.bz2/g' "${LINKSOURCE}" || die
+ done
+ ;;
+ gzip)
+ # pass
+ ;;
+ xz)
+ for LINKSOURCE in upstream/*/links.txt ; do
+ sed -i -e 's/\.gz/\.xz/g' "${LINKSOURCE}" || die
+ done
+ ;;
+ *)
+ ewarn "Unexpected compression command ${PORTAGE_COMPRESS} found, symlinks will not work."
+ ;;
+ esac
+
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES.md README.md
+}