summaryrefslogtreecommitdiff
path: root/app-i18n/libskk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/libskk
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/libskk')
-rw-r--r--app-i18n/libskk/Manifest5
-rw-r--r--app-i18n/libskk/libskk-1.0.1.ebuild48
-rw-r--r--app-i18n/libskk/libskk-1.0.2.ebuild48
-rw-r--r--app-i18n/libskk/metadata.xml11
4 files changed, 112 insertions, 0 deletions
diff --git a/app-i18n/libskk/Manifest b/app-i18n/libskk/Manifest
new file mode 100644
index 000000000000..202f8d51ede9
--- /dev/null
+++ b/app-i18n/libskk/Manifest
@@ -0,0 +1,5 @@
+DIST libskk-1.0.1.tar.gz 860453 BLAKE2B 95f386e34f479548c7b4a37c3d70d16e27fd238a83e09c9dfc539ec9c3cc1466bea6a1d694e9b1027d66955053b2af1719a96ea4b5a37f61fda82118250576cf SHA512 17dc7c0361083c08c29267b4fe2d066b079e5156728f461717044f99579ec2674b56c960d2be5a42a2dffb693106d2d3d78ec8cb833e8f189d48e421a25d91b0
+DIST libskk-1.0.2.tar.gz 867572 BLAKE2B 32f599e83bf7ced796d2f37f6f4bf5e45f47c90e144784b7b3e082866cc619a26e3aca4f16051685baa4d8ac54b0462930193f978bc1e8220b378679269c5833 SHA512 f8fff94b216c18f66bf1004ee068f8d737177f1b70ac36d054d9a68ce02ba9b8d1b7b4127d9a330f64054b2fe06f352070c750a3562d4be36fecf20cb854e6c0
+EBUILD libskk-1.0.1.ebuild 961 BLAKE2B 8fe2f6b546c554fd711ac6c40aef4a2ebdef29c009496afe0539fa95d3fafa76e80b6d7b400dc53b73312eb9bd90a85a310d88d4c9ab8d2db9c034367a8c4cdb SHA512 4ecdb60279c8ab8f7d90c19085a96b42892efad51879e841a0a54282ccba5dedd82b74ba5ce088ef25d23d8a51a7af16b51a4fe810be34d988516b46c1a7a141
+EBUILD libskk-1.0.2.ebuild 975 BLAKE2B f1af68240054e34cdf6c0c686f8c2c946d70b8fe8810837b9e5041155f3482f4f36d3f0c6827e186008be5756ca36576f7f8310e0e0de03759cc47e3a4611476 SHA512 04828d59aaa7b088bb1b2b567befc32abb937cd0b41a8c3e54114d67d68fa9d08940e501bb933897c510b39b92f00072f6649e259209fb83fa6b40468ba31db8
+MISC metadata.xml 320 BLAKE2B d8aac0823caa1962d5f1219492766ddec90fc92728b0f9f6f802d8f98d4d1c4cce00d3f6e688faf43729e8872f981582d9bbd586fcdc1cbf82aa7d54cd759d78 SHA512 a62e6d05067067cbcae666b635047834bca3c4ca7a4b217ffb20ace08fb05ba8917d8f413319a0ebe14d54c9fdf803c247644da9b22764335f5e9fc41529f67d
diff --git a/app-i18n/libskk/libskk-1.0.1.ebuild b/app-i18n/libskk/libskk-1.0.1.ebuild
new file mode 100644
index 000000000000..9dfbf773269b
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune vala virtualx
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="https://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ export GSETTINGS_BACKEND="memory"
+ virtx emake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/app-i18n/libskk/libskk-1.0.2.ebuild b/app-i18n/libskk/libskk-1.0.2.ebuild
new file mode 100644
index 000000000000..c2a5d159fe18
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune vala virtualx
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="https://github.com/ueno/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ export GSETTINGS_BACKEND="memory"
+ virtx emake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/app-i18n/libskk/metadata.xml b/app-i18n/libskk/metadata.xml
new file mode 100644
index 000000000000..47d519fd6058
--- /dev/null
+++ b/app-i18n/libskk/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ueno/libskk</remote-id>
+ </upstream>
+</pkgmetadata>