summaryrefslogtreecommitdiff
path: root/app-i18n/libime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-14 01:14:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-14 01:14:50 +0000
commit94eb99943eafb48140b436b347abaaee77209c01 (patch)
treebb4f0519a6c0880b24c88b1666976a36a464a8df /app-i18n/libime
parenta7ec94f7d22ee22df2e424c1d3f842510b7993aa (diff)
gentoo auto-resync : 14:01:2024 - 01:14:49
Diffstat (limited to 'app-i18n/libime')
-rw-r--r--app-i18n/libime/Manifest2
-rw-r--r--app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch79
-rw-r--r--app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch17
3 files changed, 0 insertions, 98 deletions
diff --git a/app-i18n/libime/Manifest b/app-i18n/libime/Manifest
index 16a8416a910e..c60070e80cee 100644
--- a/app-i18n/libime/Manifest
+++ b/app-i18n/libime/Manifest
@@ -1,5 +1,3 @@
-AUX libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch 2635 BLAKE2B d4c4390d030f4120d763d0a57e276609eafb7413048ce345dbb3f48f3eb84fc7407fcb23355bdbbd41891c480432d9d37d97bc8c99344843bdcaae95aebec4e7 SHA512 c1a04fc3dced63e00fbbbd0aafb5986cdebf175ca0a444f47208ee47fd72e166e96b11627b42adf9f12365ccf19f51c23098e05061fbd77da0a3014f7180ad4c
-AUX libime-1.1.3-use-c++11-for-kenlm.patch 800 BLAKE2B b2287dbc983c824fd4e3ba5f63faa2a0b2cd816f659832006c8a434200be46e329a411d37736fbba364c5954e49a97240151e66314aab13ccf0fd86514e5241d SHA512 ac9c1a847340437dafe994ccaa55f0d07f5fca276b4bdaab894ea21a8938c76208a94f27e06badb217965f80ad1f50a193c7d802dc287777c11002ceab9270da
DIST libime-1.1.4_dict.tar.xz 36440016 BLAKE2B 8bb6f4b39cacba4730145a23c53357a3ed42f2fdbeccd73d18f84434141219a7ea91bcbb1a38d5e61c9d72421649920dd393de4cb9248e8b8c6aeacf6e6f65db SHA512 8d3a565022da401fc338811b69905f000100be6cfdaa3cffb4fc1814854f4610b992fe3a43eeb49205b819d4a4382cacf16adf5d27d7d7f735293957f7db463c
EBUILD libime-1.1.4.ebuild 922 BLAKE2B b00a8ab9652a07f738dc0f8e188a136e693abdb585fd16b09c5ab8bdae9812d7835d760a13f1257ceebf009d6dc825f24fbade22e81faff52c2f5bb7b13f96b7 SHA512 33d491fc9ab818e6cca2767bb066e355a8203b39c31f4af234fd5b444408d701654cd6194dd4ccdf093116335742348eaf8199a075806ff41a2ab51f3fde5c91
MISC metadata.xml 624 BLAKE2B 7c0e1d29bf86d256ac8ace1404f3ef8e017171cf461f861b2b681c9bb6c7c3bb639b13cbdccc506a07805ea9e23f449e22bba1ac16d3f40ecdd10b894ea0632d SHA512 8449b74e190a0acf83f4e5b0c0ed023e5a37e203a4e514074b9e8165616c43659d993e165bb170aa8902865166a7ceaf65bec04645be7b1390ddc80c2e43066a
diff --git a/app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch b/app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch
deleted file mode 100644
index 73b94a07cff5..000000000000
--- a/app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-Backport of https://github.com/fcitx/libime/commit/59ae4a3ab4becdab164f29af07c502096c745b94.diff
-
-Backport upstream commit 59ae4a3 to fix the nanf value issue on musl
-
---- a/src/libime/core/datrie.cpp
-+++ b/src/libime/core/datrie.cpp
-@@ -47,12 +47,24 @@ struct NanValue {
- static inline int32_t NO_PATH() { return -2; }
- };
-
-+// Musl doesn't have nanf implementation we need, just check if they are the
-+// same value. If not, prefer old hardcoded value.
-+bool isGoodNanf() {
-+ int32_t noValue = decodeValue(std::nanf("1"));
-+ int32_t noPath = decodeValue(std::nanf("2"));
-+ return (noValue != noPath);
-+}
-+
- template <>
- struct NanValue<float> {
- static_assert(std::numeric_limits<float>::has_quiet_NaN,
- "Require support for quiet NaN.");
-- static inline int32_t NO_VALUE() { return decodeValue(std::nanf("1")); }
-- static inline int32_t NO_PATH() { return decodeValue(std::nanf("2")); }
-+ static inline int32_t NO_VALUE() {
-+ return isGoodNanf() ? decodeValue(std::nanf("1")) : 0x7fc00001;
-+ }
-+ static inline int32_t NO_PATH() {
-+ return isGoodNanf() ? decodeValue(std::nanf("2")) : 0x7fc00002;
-+ }
- };
-
- } // namespace
-@@ -1144,6 +1156,20 @@ bool DATrie<T>::isValid(value_type v) {
- return !(isNoPath(v) || isNoValue(v));
- }
-
-+template <typename T>
-+T DATrie<T>::noPath() {
-+ typename DATriePrivate<T>::decorder_type d;
-+ d.result = DATriePrivate<value_type>::CEDAR_NO_PATH;
-+ return d.result_value;
-+}
-+
-+template <typename T>
-+T DATrie<T>::noValue() {
-+ typename DATriePrivate<T>::decorder_type d;
-+ d.result = DATriePrivate<value_type>::CEDAR_NO_VALUE;
-+ return d.result_value;
-+}
-+
- template <typename T>
- size_t DATrie<T>::mem_size() const {
- // std::cout << "tail" << d->m_tail.size() << std::endl
---- a/src/libime/core/datrie.h
-+++ b/src/libime/core/datrie.h
-@@ -136,6 +136,9 @@ class DATrie {
- static bool isNoPath(value_type v);
- static bool isNoValue(value_type v);
-
-+ static value_type noPath();
-+ static value_type noValue();
-+
- size_t mem_size() const;
-
- private:
---- a/test/testtrie.cpp
-+++ b/test/testtrie.cpp
-@@ -40,8 +40,8 @@ int main() {
- FCITX_ASSERT(trie.size() == 4);
- DATrie<float>::position_type pos = 0;
- auto result = trie.traverse("aaa", pos);
-- auto nan1 = std::nanf("1");
-- auto nan2 = std::nanf("2");
-+ auto nan1 = trie.noValue();
-+ auto nan2 = trie.noPath();
- // NaN != NaN, we must use memcmp to do this.
- FCITX_ASSERT(memcmp(&nan1, &result, sizeof(float)) == 0);
- FCITX_ASSERT(trie.isNoValue(result));
diff --git a/app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch b/app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch
deleted file mode 100644
index 15b0024c4668..000000000000
--- a/app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Backport of https://github.com/fcitx/libime/commit/95c1433500b089b0c2edbdd17720f66e6eafd5e0
-
-Backport upstream commit 95c1433 in order to fix building with libcxx
-
---- a/src/libime/core/CMakeLists.txt
-+++ b/src/libime/core/CMakeLists.txt
-@@ -13,7 +13,9 @@ add_library(kenlm STATIC ${KENLM_SRCS})
- target_include_directories(kenlm PUBLIC $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/kenlm>)
- target_compile_definitions(kenlm PUBLIC -DKENLM_MAX_ORDER=3 PRIVATE -DNDEBUG)
- target_link_libraries(kenlm PUBLIC Boost::boost PkgConfig::ZSTD)
--set_target_properties(kenlm PROPERTIES POSITION_INDEPENDENT_CODE ON)
-+set_target_properties(kenlm PROPERTIES
-+ CXX_STANDARD 11
-+ POSITION_INDEPENDENT_CODE ON)
-
- if(UNIX)
- check_library_exists(rt clock_gettime "clock_gettime from librt" HAVE_CLOCKGETTIME_RT)