summaryrefslogtreecommitdiff
path: root/app-i18n/libhangul/libhangul-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/libhangul/libhangul-0.1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/libhangul/libhangul-0.1.0.ebuild')
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
new file mode 100644
index 000000000000..f8ec424da315
--- /dev/null
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Library for hangul input method logic, hanja dictionary"
+HOMEPAGE="https://github.com/choehwanjin/libhangul"
+SRC_URI="https://libhangul.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="nls static-libs test"
+
+RDEPEND="virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )"
+
+DOCS=(AUTHORS ChangeLog NEWS)
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ emake -C test check
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}