summaryrefslogtreecommitdiff
path: root/app-i18n/libchewing/libchewing-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/libchewing/libchewing-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/libchewing/libchewing-9999.ebuild')
-rw-r--r--app-i18n/libchewing/libchewing-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/libchewing/libchewing-9999.ebuild b/app-i18n/libchewing/libchewing-9999.ebuild
new file mode 100644
index 000000000000..3dbd6c51e6fe
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/chewing/libchewing"
+fi
+
+DESCRIPTION="Intelligent phonetic (Zhuyin/Bopomofo) input method library"
+HOMEPAGE="http://chewing.im/ https://github.com/chewing/libchewing"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/chewing/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS=""
+IUSE="static-libs test"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/ncurses[unicode] )"
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # libchewing.a is required for building of tests.
+ econf \
+ --with-sqlite3 \
+ $(if use static-libs || use test; then echo --enable-static; else echo --disable-static; fi)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+ use static-libs || find "${D}" -name "*.a" -delete || die
+}