summaryrefslogtreecommitdiff
path: root/app-i18n/kcm-fcitx/kcm-fcitx-4.5.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/kcm-fcitx/kcm-fcitx-4.5.9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/kcm-fcitx/kcm-fcitx-4.5.9999.ebuild')
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-4.5.9999.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-4.5.9999.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-4.5.9999.ebuild
new file mode 100644
index 000000000000..c15c02b02ec1
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-4.5.9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4-plasma5"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/fcitx-qt5-1.1:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kitemviews:5
+ kde-frameworks/knewstuff:5
+ kde-frameworks/kwidgetsaddons:5
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ !${CATEGORY}/${PN}:4[-minimal(-)]"
+DEPEND="${RDEPEND}
+ kde-frameworks/extra-cmake-modules:5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
+ )
+
+ cmake-utils_src_configure
+}