summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-typing-booster
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 21:33:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 21:33:19 +0100
commit19e23b194d10e420ec050c4d8a6253aad17694b1 (patch)
tree44ef9c9c2f5433a2251428352e4c9afb877e2500 /app-i18n/ibus-typing-booster
parentc74abf990d32765245eeb94b36ad4af642cae8c0 (diff)
gentoo auto-resync : 17:08:2023 - 21:33:19
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest2
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.23.4.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 6070135c0b59..ae707d68a711 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,5 @@
DIST ibus-typing-booster-2.22.5.tar.gz 11325715 BLAKE2B 21247eeffc520d96bb8a1d52e7af0966d257a586cad5f097b0b72fff420fe32a63cefd4a8ec15e0ac55915ccddab81be33d136e931934303d08cd34ea786634a SHA512 1dd9942b1d77eb48ac967c53882d83228e8a7ff25dc7bdff2f624d0dd731b5ee511631cd6759bf35e4e7b3093e4831c1996fcbe69cc4435fde9412514656dc89
+DIST ibus-typing-booster-2.23.4.tar.gz 11514625 BLAKE2B e4f2e79bc2e5f85581dd36bab82b1aca1a1a6232341cc35aeb717fbbc8e2f44c14364554c7f257cd70213fe1c5b7b7e1d6a891a5c751ed45c7c8a4703d620bed SHA512 ae13f5ed078fddd31dc81676516e2455ebe78bf9b621a44685da238db0f2eb792766875a49919ebaa3b91a225897558257d2e38901f2c5a6d890023a7b8c9606
EBUILD ibus-typing-booster-2.22.5.ebuild 1150 BLAKE2B 26782be5de356fbc4f5c80dcea51fe125033264fd3f991302b61544e9246785d5343a9c61abb3b149cc7d2baf544127fc993373ac228b54f3d12643d0c17ef04 SHA512 a1946ed113bf06accf1c0459a131fb26e3abfd3edb8ba67f42103311c700c43cbe3918d8d6d8ec3936d447d995d7c6e3e87bc41bcd0c2f9525bb4961b9530241
+EBUILD ibus-typing-booster-2.23.4.ebuild 1152 BLAKE2B 41f6476c89448b37d6ae312d7f35b88817136c36734c5e640e32ebb351b88fe6e290e3abb7ff45c0281d3cb18a8d45c8c0acca5ac8b01245f7ac6a41eae37870 SHA512 32f1ce4a75dcddaa2807c0490519e4414263cfef125ace7eb2651b372db97f16932bd8dd2d488ec109c0cb3fefc219275c1ce197ab412d3457ce4c63ed50b7de
MISC metadata.xml 331 BLAKE2B e076fda3780cbfebae0a799bcc320de0417dfc2a726320c014d253163625da4fd629b180442449368e316e134bf2024f7e03373f2ca0342c4b63a11c63475697 SHA512 f79eaa01a0ad3005064928ef7fbaed4bc98f8850ca36b23309096647b6158c7500e0075f149e4e764a89af99a8fe342eb6a1d9b83a347557300545ecf870e4d8
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.23.4.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.23.4.ebuild
new file mode 100644
index 000000000000..564f684f9809
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.23.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}