summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-table
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 08:09:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 08:09:34 +0100
commitda3552023d9aae2ee5183df71a80a8169414974e (patch)
treed26518a0f3fb7b5f62d9fa5f546757d405f4d380 /app-i18n/ibus-table
parent51f0d16e058c162dbce0f93d871ba45683b0ab3a (diff)
gentoo auto-resync : 06:08:2022 - 08:09:34
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/Manifest2
-rw-r--r--app-i18n/ibus-table/ibus-table-1.16.10.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index ac245c950ee1..96b95a2da1c2 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1,3 +1,5 @@
+DIST ibus-table-1.16.10.tar.gz 1518611 BLAKE2B 610f4448bb59cffef4e11b069dc5d3f6aa0eadffe6f6af7da07b2b24da0969dc63dc05717694c7b61ac5e18c14433b4af6a111a7076bd8a69871e70ea8fe357e SHA512 3e3dc4ec6aea974d7b0f171375448090e117c70a3ba3d1b6c218db481725e58c65adce55839f826ec274d33f926377d0390bcd505af1911c5b9f68910d0c3497
DIST ibus-table-1.16.9.tar.gz 1474440 BLAKE2B 8380c9549e4295850c81279e73b774beea610ebb632bc8a04fe0ce37a02c702652c0ec49ed3596851e05d2f151320daf60eb2631c8bbe439aee8c7e2834398f5 SHA512 840de16f62820456812c036ed84f99900d2d49885a9a6131da97efbec149ea426ab4a966541b16a18dbcedf38b6f78803b3fb04a5134258bb3796d3b9caf0b08
+EBUILD ibus-table-1.16.10.ebuild 1039 BLAKE2B bfa60c06635c734fc91125a997f134541fd481f37b81ab94b89c12f1262839a98e1ebdf67f340e1d59879bacc4db500444bd40c440216c31ac41e1cd5468f670 SHA512 67bcb9a5a1bd5730dc9de788f34566c27ef22167658e0510b80082a9740ab4cefb02c53d73a60bb3acfe5339e89dbd1362fede169d3e6b9fc6926551b39ea637
EBUILD ibus-table-1.16.9.ebuild 1037 BLAKE2B 6c6f34f6b9424d05e7af4e9c872f9a80bef1d3262b8d3355d66242ae296452b1f0787f29728e4c63137b58fff27b160de8c628d72750af4ed99120b26c1fa40d SHA512 05f427e142b4898a42f294045ebc56010651e143c9296bcbc2dea0b2c0de277df663a17017513f4079764e1f84ce4762976cf3d46fb89ea0a19c392eea63a707
MISC metadata.xml 315 BLAKE2B eeff056ce020201cb6e59f0f160232486fd94cc9de7cc90980155f9ef97988199d592b01190b13b013433853fbc25d9c4e5e29fe33fb74aa4239318cfac312fd SHA512 3329cc73468815ecf7f122ee8e8b81ca7295abcfeab95082841ae460c7ca76fdf2cb3d01b1548795bb525ce855052f512b8b2d77fa3afd302f41c156edf35de0
diff --git a/app-i18n/ibus-table/ibus-table-1.16.10.ebuild b/app-i18n/ibus-table/ibus-table-1.16.10.ebuild
new file mode 100644
index 000000000000..7314f41b0540
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.16.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}