summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-table
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-10 04:41:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-10 04:41:31 +0100
commitb9baffd9af9383cc886b1583814fe15163017d80 (patch)
treeac23c3bc28a85762e2792dcfd19921f08931a33e /app-i18n/ibus-table
parentf848d5eacad65f1f52c168d9b0f74dec3e89b203 (diff)
gentoo auto-resync : 10:09:2022 - 04:41:30
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/Manifest2
-rw-r--r--app-i18n/ibus-table/ibus-table-1.16.12.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 6e1c1319d95c..f875b0dcbd83 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1,3 +1,5 @@
DIST ibus-table-1.16.11.tar.gz 1518653 BLAKE2B fec1deed7b96492bc9cead734b5063e47d553f690f9c71362a213a81f905f176811d9f397ae72c4a40815611d47df90b5a2bb56851ac28d5ca2dc2efc405716b SHA512 f5da239a05337f368769e7679a0639e73812021579467a195795678d68cf8d70b1f9bd4d31739c60298d60c9da6291c704e592750677ecc59734dd8c4292bf43
+DIST ibus-table-1.16.12.tar.gz 1519559 BLAKE2B c0e236ae58cbcc7c52bc29f30f2be5ed02590bab96fb9866bb829986fef9e01964b3f4b55caa1d417840372b0c3c230a93713aa774272375b5cd21a2a851bba8 SHA512 edbbb4842a6b49cdf8a830187422b7042c47b9ddf4876eb114acdb1e449024a6f4f48d46cb97d4420d65dffc14b3e3e9400d31b92ac68ccd2e9a327151dcaa3f
EBUILD ibus-table-1.16.11.ebuild 1037 BLAKE2B 6c6f34f6b9424d05e7af4e9c872f9a80bef1d3262b8d3355d66242ae296452b1f0787f29728e4c63137b58fff27b160de8c628d72750af4ed99120b26c1fa40d SHA512 05f427e142b4898a42f294045ebc56010651e143c9296bcbc2dea0b2c0de277df663a17017513f4079764e1f84ce4762976cf3d46fb89ea0a19c392eea63a707
+EBUILD ibus-table-1.16.12.ebuild 1039 BLAKE2B bfa60c06635c734fc91125a997f134541fd481f37b81ab94b89c12f1262839a98e1ebdf67f340e1d59879bacc4db500444bd40c440216c31ac41e1cd5468f670 SHA512 67bcb9a5a1bd5730dc9de788f34566c27ef22167658e0510b80082a9740ab4cefb02c53d73a60bb3acfe5339e89dbd1362fede169d3e6b9fc6926551b39ea637
MISC metadata.xml 315 BLAKE2B eeff056ce020201cb6e59f0f160232486fd94cc9de7cc90980155f9ef97988199d592b01190b13b013433853fbc25d9c4e5e29fe33fb74aa4239318cfac312fd SHA512 3329cc73468815ecf7f122ee8e8b81ca7295abcfeab95082841ae460c7ca76fdf2cb3d01b1548795bb525ce855052f512b8b2d77fa3afd302f41c156edf35de0
diff --git a/app-i18n/ibus-table/ibus-table-1.16.12.ebuild b/app-i18n/ibus-table/ibus-table-1.16.12.ebuild
new file mode 100644
index 000000000000..7314f41b0540
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.16.12.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}