summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-table
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/ibus-table
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/Manifest5
-rw-r--r--app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild42
-rw-r--r--app-i18n/ibus-table/ibus-table-1.9.18.ebuild42
-rw-r--r--app-i18n/ibus-table/metadata.xml14
4 files changed, 103 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
new file mode 100644
index 000000000000..35f32abfd51e
--- /dev/null
+++ b/app-i18n/ibus-table/Manifest
@@ -0,0 +1,5 @@
+DIST ibus-table-1.5.0.tar.gz 432844 BLAKE2B 183c50be5545d176e44da4b5fae914d838cf4f43024fe56a0ba1e9a699e7f94ea3fb95e20775f8a28963c7e5e320332f51c33c58dcb1ac9a6017d87b6b3d60e9 SHA512 2c52da1b4d6ae8aec29e97a8a413b388912cfcfd15860ba0e65c97b139b14f8a7d4087eb196d516abe731df03a2e4904666194414242da8cf1f3f0b54696248e
+DIST ibus-table-1.9.18.tar.gz 585309 BLAKE2B 42d7d130bd2695c1c1a7010c0bcf29c1ecaa3899c8ef8d24b11e10434771415bfd8b91723ef4c489721f0276d05dce08de3472c49632b9d30da5be1a53f82dc7 SHA512 3f28269be1987023402eb6075b8e68b3bbba3c572a94551d072281677fde5fa14f8f4186455f8f9156b252934580c7a3837555d0edb46c76f13c8b109e26aca2
+EBUILD ibus-table-1.5.0-r1.ebuild 909 BLAKE2B 444c1043917802ce157c42c7975218543c0e2a25f72f280c770aa11a60283325afe693ad37507606eb8d15115740ca59a98db36023bf3cddfc7c41b8c5cc9c7a SHA512 93de9941ae6fc3f7fc984faf14511692c3e0a73998bb725e54fa465b2c4f417a7e2c40f630c6de482dbe1131ad34c7675fca306ca4c9ef038d9fd9a821ac53c5
+EBUILD ibus-table-1.9.18.ebuild 890 BLAKE2B 3a3cad572585b34b3094cc54874c80325b9ecde715ea25673b133be9fc7734b967ef4447e08c7c6bae730600cd9045595e2c50b7096131b7da63cc4dc8a00dff SHA512 ec786ca8823a3c4cc8933f26aa3505f21b408115c1f3d92f958a2efcffe295094368aa198a50cbcf602f3d0185411a056fbba606d457aca46fe7849527495f69
+MISC metadata.xml 433 BLAKE2B f165f823d61ad57b3db2925cd9dc184b23111bc4f375477673a908a3556fb68a668ec7f6bcf69aa72c5aedc7f15f34695a0bddaa8d77e72c75f4b9da7b0dd4d2 SHA512 827cf106065bdc9e3eb26c098a8480f3865f93e7bf667981437e725af60ad4fda297ed5d43cd9332f3131544e0ebec03dc058c688382a2a80ef34947339fc855
diff --git a/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild b/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..313b0d5d4716
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/ibus/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ "s/python/${EPYTHON}/" \
+ engine/${PN}-createdb.in \
+ engine/${PN/-/-engine-}.in
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-i18n/ibus-table/ibus-table-1.9.18.ebuild b/app-i18n/ibus-table/ibus-table-1.9.18.ebuild
new file mode 100644
index 000000000000..114b81267db0
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.9.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ "s/python/${EPYTHON}/" \
+ engine/${PN}-createdb.in \
+ engine/${PN/-/-engine-}.in
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-i18n/ibus-table/metadata.xml b/app-i18n/ibus-table/metadata.xml
new file mode 100644
index 000000000000..577d254feeb7
--- /dev/null
+++ b/app-i18n/ibus-table/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <longdescription lang="en">
+ A framework for table based input methods using IBus.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kaio/ibus-table</remote-id>
+ </upstream>
+</pkgmetadata>