summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-libpinyin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-i18n/ibus-libpinyin
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-i18n/ibus-libpinyin')
-rw-r--r--app-i18n/ibus-libpinyin/Manifest2
-rw-r--r--app-i18n/ibus-libpinyin/ibus-libpinyin-1.12.1.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/app-i18n/ibus-libpinyin/Manifest b/app-i18n/ibus-libpinyin/Manifest
index 2a6fb3ebcb13..091e001bfbda 100644
--- a/app-i18n/ibus-libpinyin/Manifest
+++ b/app-i18n/ibus-libpinyin/Manifest
@@ -1,3 +1,5 @@
DIST ibus-libpinyin-1.11.92.tar.gz 1730065 BLAKE2B 376bec6fa7616364c8ed4dc5b269edabda892ba4759ff03e93b4099c99440925126800ea3bf11eef91ea62c558fa7dbf05f3d68be5e25e701aaaeb37618b90a8 SHA512 b875b2fed6875806971b91e2abc62cdab1f70baef78840915f89466a7bcf3d1dfc70438ba85e7580bba92dec0ade50a2b05955fe6cd148bffd3888fa69f1c851
+DIST ibus-libpinyin-1.12.1.tar.gz 1766803 BLAKE2B 1de8a51b52688dede32c572b39bd379296480ab2b0f909357465370e346bdf50f4cade5ab3f105f62a74e59cf2dc5e8d5235aedde7571b70d3c5dcee86d2e36b SHA512 ad6e7507bdb468d506071135449383e5bd4fc878bcffda4be6e4e7915b79dbaf919d2fa941b92b177dc7790bd895eaa9a6d04a2610f85e1e80e8eb50f188211d
EBUILD ibus-libpinyin-1.11.92-r1.ebuild 1454 BLAKE2B 5af4b8432eda1aee0b498a3eeef53e3e7aa94252c7b44f252f6facfe4fe2cb4a60c779af9e95bc95b4fc29d614b83d61ae6bd4a871d2347595fe1b7cc87f0a08 SHA512 3da11471352e76016197604e5f26beb0868d0b307d9b5918c890e15329afb9e770e866f310c95b32f4da52728c0e6cb0ecb507f71b0bfbefaeda7e479ce80ed8
+EBUILD ibus-libpinyin-1.12.1.ebuild 1456 BLAKE2B c8926b46682e0b4b1b72711738d2c64938c576343e5ca53b4cb7d41c8300e130a05f9bd5aec8d6f3fbc75df5cf95846a1212dd4399dfca0b8e2b6718f2880129 SHA512 64919ed1e6a49df528558976a8238e672bf0d8209a5bf173c49c6606c2a0ac44f0cff7d770b62e9adb2de9c25c8c656d6f13d2a1782426495f15cb1e426e3ded
MISC metadata.xml 834 BLAKE2B ac644e5ceced4364c282f0766cfc5d85dfc14fc19fff46e96dee2aa8ff48c1c5d84dd496e3f83951983f311cbab0ea84652fab3e3a87e870dab999cf46821452 SHA512 dd1629baeddeb1ee4ab1670a4e29af865a75e40b7c6b58e9029af5900d5de9bfb98f71ccaf7eae508f0849ac85f4530d8770cc392d9bb8c31a881f8154ac5761
diff --git a/app-i18n/ibus-libpinyin/ibus-libpinyin-1.12.1.ebuild b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.12.1.ebuild
new file mode 100644
index 000000000000..7f8fdf0ab762
--- /dev/null
+++ b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.12.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2015-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+LUA_COMPAT=( lua5-{1..3} )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools gnome2-utils lua-single python-single-r1
+
+DESCRIPTION="Intelligent Pinyin and Bopomofo input methods based on LibPinyin for IBus"
+HOMEPAGE="https://github.com/libpinyin/ibus-libpinyin https://sourceforge.net/projects/libpinyin/"
+SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua opencc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+BDEPEND="dev-db/sqlite:3
+ virtual/pkgconfig"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-i18n/libpinyin-2.2.1:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ virtual/libintl
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ boost? ( dev-libs/boost:= )
+ lua? ( ${LUA_DEPS} )
+ opencc? ( app-i18n/opencc:= )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^appdatadir/s:/appdata:/metainfo:" \
+ data/Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-english-input-mode \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable opencc)
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}