summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-cangjie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /app-i18n/ibus-cangjie
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'app-i18n/ibus-cangjie')
-rw-r--r--app-i18n/ibus-cangjie/Manifest4
-rw-r--r--app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild46
-rw-r--r--app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild49
-rw-r--r--app-i18n/ibus-cangjie/metadata.xml14
4 files changed, 55 insertions, 58 deletions
diff --git a/app-i18n/ibus-cangjie/Manifest b/app-i18n/ibus-cangjie/Manifest
index 707258a0ee34..ba2e3bb32357 100644
--- a/app-i18n/ibus-cangjie/Manifest
+++ b/app-i18n/ibus-cangjie/Manifest
@@ -1,3 +1,3 @@
DIST ibus-cangjie-2.4.tar.xz 150616 BLAKE2B 2e59acc1b05ce0dc3dad26ba663440d067bf28a549e79ec9d127de414d715f5e376f426db5b415255eb63aa13677e59643889481f5e39c946399d4d4fe15a468 SHA512 cef9562fc4a5f3b78881c09b43e502f02322148e501022d3f80989caef4ca98ae26903e9a3dcc422feeba7712a8321c731ba229429e52fe919db5144aa0ead47
-EBUILD ibus-cangjie-2.4.ebuild 1076 BLAKE2B f712e22d0810a4fcf451d1ff00d55b894cffd4a34c9a1598a642c7d2bfa6aa9c8e1d7e8dafa52a459a91bda0a14e0e2723502322072eb9ca791c98019322f90f SHA512 4b6e6f7da94cea419fc6583df02e53f8057a555068b7eb97b5b075f50efaecd8ef4458a1c02479421a4800e5de3adc69b1d41678a77cab4a51fc77a5ef6a9acc
-MISC metadata.xml 331 BLAKE2B 51f11d81e4be33a58b3a32274cdefc59588c0eb488d8864ded4352fee4680a9d888a014fa5f7aa493819ead18d68baf2ce5b0ce19a665887653d16f2641342ff SHA512 d50524d308a7dae58c23a9b2e39e149d28dbe08d78dc96f53db98ebc96ef09e871792a9608108dff82dd1023b5bdc5998b4c8863a1f48be37f7c505d896ee62b
+EBUILD ibus-cangjie-2.4-r1.ebuild 920 BLAKE2B 74f5f87435abb38fdcb949ebae394a50464a0f51668226228505afce6da95addbac2587cdf81911645d79e8434e801740ae7c592e228b70d2cfdc1a42175935f SHA512 1f8147916f007af1a503616d8a410c2643b5c5bbbda3991e1c3649b96cc739d95642858475b98fccae773a741fda2025944fe83eac7a12d87b377979b765528b
+MISC metadata.xml 321 BLAKE2B f6906dfe6babd501643f94145258a76d52aabdf44274f8989d88b513157d178a3e564089e97b694371d85b750214d359213ed7ab00dab78c6262bc23314342ef SHA512 5681abe463968d6ac39a94d5b30428be7bcb9fa5ebb2318223ca9ab4261b303fa37eecb1d506f7131609856eba12deddccf7c8cd4d01954f5bd71a4e327551e7
diff --git a/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild b/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
new file mode 100644
index 000000000000..f7446f6ad8ae
--- /dev/null
+++ b/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2-utils python-r1
+
+DESCRIPTION="Chinese Cangjie and Quick engines for IBus"
+HOMEPAGE="http://cangjians.github.io/"
+SRC_URI="https://github.com/Cangjians/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ app-i18n/libcangjie
+ dev-python/cangjie[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ python_foreach_impl default
+}
+
+src_compile() {
+ python_foreach_impl default
+}
+
+src_install() {
+ python_foreach_impl default
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild b/app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild
deleted file mode 100644
index 766065c32132..000000000000
--- a/app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit autotools-utils gnome2-utils python-r1 eutils
-
-DESCRIPTION="The IBus engine for users of the Cangjie and Quick input methods"
-HOMEPAGE="http://cangjians.github.io"
-SRC_URI="https://github.com/Cangjians/ibus-cangjie/releases/download/v${PV}/ibus-cangjie-${PV}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=app-i18n/ibus-1.4.1
- app-i18n/libcangjie
- dev-python/cangjie[${PYTHON_USEDEP}]
- dev-util/intltool
- sys-devel/gettext"
-
-RDEPEND=">=app-i18n/ibus-1.4.1
- app-i18n/libcangjie
- dev-python/cangjie[${PYTHON_USEDEP}]
- virtual/libintl
- ${PYTHON_DEPS}"
-
-src_configure() {
- python_foreach_impl autotools-utils_src_configure
-}
-
-src_compile() {
- python_foreach_impl autotools-utils_src_compile
-}
-
-src_install() {
- python_foreach_impl autotools-utils_src_install
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
diff --git a/app-i18n/ibus-cangjie/metadata.xml b/app-i18n/ibus-cangjie/metadata.xml
index 9468326e6f9a..83985854d52a 100644
--- a/app-i18n/ibus-cangjie/metadata.xml
+++ b/app-i18n/ibus-cangjie/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
- </maintainer>
- <upstream>
- <remote-id type="github">Cangjians/ibus-cangjie</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Cangjians/ibus-cangjie</remote-id>
+ </upstream>
</pkgmetadata>