summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-anthy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-i18n/ibus-anthy
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest2
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index d5f9be455d4b..db650cc5c385 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1,3 +1,5 @@
DIST ibus-anthy-1.5.13.tar.gz 265252 BLAKE2B d35299dba3260b85f80f259e0a40ea1ec061ed8082b6e5c872eab6398b6242342b2ee4da0c3b191aa428ae2d8dc652b0e414fd0c9f7b93ca8dcd6303c0586b4d SHA512 058feb49b2fe50ae3ca959f4754b8070f3ebc1e6727fef4bca791aa45a23c95018000e2a8bca496d6592b052298a6fb2869a07c2cc56cc473c81cc437efa175b
+DIST ibus-anthy-1.5.14.tar.gz 267418 BLAKE2B a4da45588d8736f10ccf26af52179da85bd3a17a8f1fbdba622058d1eaed933b0102fe12357613574e377df323145487838c3f74c052c813462b435905d5c941 SHA512 4d06d4e177df62d22c61bf6ebfda04ddbf545ea1947d0c315e3dfe5e48d9ddc57e5fcc89919ae3b9f7430e6124a5dfb1295f4ca7362fbc35714d627f80fae6d8
EBUILD ibus-anthy-1.5.13.ebuild 1310 BLAKE2B 448f52507f33bbcea960398d1ff9e2b177c54bd3523ea63cd3ad034758cbfbc4708b668bd368fc0fb9cd73027f4d290a765f97d4f2cbf03a0fbc403dde28cb7b SHA512 0cbd544a986bce8d41829ec6b3d391ef1bd09e9a8ae7ea382aca72410d778e28e11ffae3c725f94833aaff6f2c132549d288a46a318307ac1e5b24096764bbb2
+EBUILD ibus-anthy-1.5.14.ebuild 1312 BLAKE2B 491e76a279bc1a25acc93ff98db1b6b742ad09d79c3b6f25d84ae5f9cd243f986ce6fd4d719cea1b37e8047dc03f807c2f405050fbea349d0f776350759aceaf SHA512 ae3879999fbbb0696fa1e9a35456c1dab3da437b24b75bf2831a8c9fc0f874a5073071bd4d1a3e3c12c481d4f0bad8b962b9c5711f1a2e72f3b02ef5e09db729
MISC metadata.xml 325 BLAKE2B ae0af274a4321f66c02696f5f6440ce55a1a8406efe0f5c17c76606ab536b157f528eb93508d1ac95a893a54ada06c538d627754f8795271e3bb99eb4bbfdcc1 SHA512 64b47eae1d72f07324b98eb1dbc9a2a4b7cc0c74172e0df55e9d5abdaf10ebe1d90f4217b973979e3b53c5a21084fcad6785203a7b4280dc0706d4e6d1bd74f6
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild
new file mode 100644
index 000000000000..d11f1e980d89
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}