summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-anthy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
commitd628c1f8493d09e3deb5d19971cd21691d8758e4 (patch)
tree7afecb9f9148ecf631ac2093143278e041cc5acd /app-i18n/ibus-anthy
parent4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (diff)
gentoo auto-resync : 01:03:2025 - 19:28:40
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest2
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.17.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index 853d2874ce6e..a44e0f3732b8 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1,3 +1,5 @@
DIST ibus-anthy-1.5.16.tar.gz 278846 BLAKE2B 9e6f297dc563eff88195008858694d737b88979117e95540fc9cfc8288df9f6a10027e19860dcaa97271aee82e112ac49cfd0cad834d22005689bd4816b1df08 SHA512 af782509c3a098864fc0327f0f1226b2f1b9890b36bf69c208ffe977fb07c1f71dea946e8ad4dc9b2cdd6c84252d34a8c8b17f855c6fa7320e3a58b7719e86c5
+DIST ibus-anthy-1.5.17.tar.gz 292242 BLAKE2B 5dd5fd5d10a7ee239e2f40bb4f31469f2fd024fdd5c3afc2d1ab6f8df54b23dc8b4c3494889ebdf4924e54a0ea61e92dbb109db3cf02628ceb3a9d4e5ce084e0 SHA512 c361452af73ef49278142e3eb63e7697bb6f4369fd26fdc94405aa976cb5b3a323cb67f31099d348cf3495160a1259b56c941cfb0facce1d3c050daa5264b3d2
EBUILD ibus-anthy-1.5.16.ebuild 1310 BLAKE2B 03e3385bb982c700e797678491fa0d6514d38dcca9b7442c43cb27d94f1f43d23b6e2b378902d3a6f4f90b112278a6a649f4c875871400f78b4fc23ffbcf5086 SHA512 1a1845c7656fbe588570c666a30c842b34e94c7ec15a5fa890a31fcf41b6b17fda54af13b0508e8fc5f1ec1ba579a8d6f8b58ebdc277a2bff7415385fe2aa99d
+EBUILD ibus-anthy-1.5.17.ebuild 1312 BLAKE2B 4a6e5d4c97a51ab53af7b664102ea6eb3962339705723a9142b69ef33524416d849a912795ddedbbf6dcd43bf832a6e52fdd99e0a24aa6aef951e84da037d1c1 SHA512 2064b3fa6743d81d392b7e13a925ece240381448927c1076df974c8c27a165e94ee450a3ea9ff77f5e00f14cb3aed5b8da6e5ded6409814ab12f9dbab73add48
MISC metadata.xml 325 BLAKE2B ae0af274a4321f66c02696f5f6440ce55a1a8406efe0f5c17c76606ab536b157f528eb93508d1ac95a893a54ada06c538d627754f8795271e3bb99eb4bbfdcc1 SHA512 64b47eae1d72f07324b98eb1dbc9a2a4b7cc0c74172e0df55e9d5abdaf10ebe1d90f4217b973979e3b53c5a21084fcad6785203a7b4280dc0706d4e6d1bd74f6
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.17.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.17.ebuild
new file mode 100644
index 000000000000..eb2df9207257
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.17.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..13} )
+
+inherit autotools gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}