summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-anthy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/ibus-anthy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest5
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild67
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.9.ebuild63
-rw-r--r--app-i18n/ibus-anthy/metadata.xml15
4 files changed, 150 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
new file mode 100644
index 000000000000..ada310e0f54c
--- /dev/null
+++ b/app-i18n/ibus-anthy/Manifest
@@ -0,0 +1,5 @@
+DIST ibus-anthy-1.5.10.tar.gz 758528 BLAKE2B 39496f5c3a5f2038f3f81e09504e472a32da85f27701741cbe77b576afcd8685c4f2209aaf24ef84420cbeec1614b251d2903c1ea4e7175a1014f92615399847 SHA512 963b1dfba18259aad2296c10de35f9f321b0169d6f85afa058ed57b6894fe4e1d44514ffadeee3c3108aac77f54aa645096ddf4bdb353fafaedb83d27d8c5d47
+DIST ibus-anthy-1.5.9.tar.gz 765672 BLAKE2B 88a2b935bfe1007bdcbd70af358509da77533a67df4b6d0be218b5f9d5e1c0ca093e62618765f1e2d7c06c2127458319bbf482ce8598398b9562ecec8a258301 SHA512 2f57db784ddbd4ea57afba245dc532fe4ee8c9fea5fc7df9b3ca26600816ef4c0626b4ebdbbd976826c391890216af587863707caa26c3926a6278cc6b720ef6
+EBUILD ibus-anthy-1.5.10.ebuild 1246 BLAKE2B a74e0ad08aea1155f397ad8461c738526dfd03b2482d2739b222895c60d660047cf6b77ff37441fa41659b20bc244c594e4485e23a3d32613d5a8e4b2dee71c8 SHA512 6e1998200bcdf487b3d0a0db99e30e96a28e7d1451279eab89290b38731ad78d2129901b2e2cff1cdb2109a1427e522a2ffa5a8a390a31df61db510809392c4e
+EBUILD ibus-anthy-1.5.9.ebuild 1225 BLAKE2B 60341a7f797697006025b7f5d1488c6bf839042e30c5dc2c07f1b73c7e99d639d0d4d90017c6153675d958166cc37883931bcb86b3314c68f282fe39461f859e SHA512 55f267f26a55942fcfd96f3d5772188785e2dff48be09f8f898f16597a93e402e5ed364a3d031aef95c7c0345073a395b290475ef8521991bbdff15715e30609
+MISC metadata.xml 476 BLAKE2B 33f4115e9bafa5d3f491ea05b8395123c9cb6b844959df2ee8b2cc9609b8fd20d25cc870adc117c9e96e17f215c806d82ff138b01c2b02e2e63eb99d568ea626 SHA512 024c387b5eb01279f8803df81b1d7dc2b86969ffee5986bef75987c066cce48f7d1fe8ea35790be4fafbff2281850f2b03904f41e06bc37fc9d40537eca96c07
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild
new file mode 100644
index 000000000000..497c5293094f
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.9.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.9.ebuild
new file mode 100644
index 000000000000..d87865637334
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/ibus-anthy/metadata.xml b/app-i18n/ibus-anthy/metadata.xml
new file mode 100644
index 000000000000..384ad03f3758
--- /dev/null
+++ b/app-i18n/ibus-anthy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Anthy engine for IBus. It provides Japanese input method from
+ <pkg>app-i18n/anthy</pkg>.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ibus/ibus-anthy</remote-id>
+ </upstream>
+</pkgmetadata>