summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-i18n/fcitx/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-i18n/fcitx/files')
-rw-r--r--app-i18n/fcitx/files/fcitx-4.2.9.8-enchant.patch32
-rw-r--r--app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch32
2 files changed, 64 insertions, 0 deletions
diff --git a/app-i18n/fcitx/files/fcitx-4.2.9.8-enchant.patch b/app-i18n/fcitx/files/fcitx-4.2.9.8-enchant.patch
new file mode 100644
index 000000000000..f152f1dc6e5a
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-4.2.9.8-enchant.patch
@@ -0,0 +1,32 @@
+https://github.com/fcitx/fcitx/issues/475
+
+--- /cmake/FindEnchant.cmake
++++ /cmake/FindEnchant.cmake
+@@ -16,15 +16,15 @@
+ endif(ENCHANT_INCLUDE_DIR AND ENCHANT_LIBRARIES)
+
+ find_package(PkgConfig)
+-pkg_check_modules(PC_ENCHANT enchant)
++pkg_check_modules(PC_ENCHANT enchant-2 enchant)
+
+ find_path(ENCHANT_INCLUDE_DIR
+ NAMES enchant.h
+ HINTS ${PC_ENCHANT_INCLUDE_DIRS}
+- PATH_SUFFIXES "enchant")
++ PATH_SUFFIXES enchant-2 enchant)
+
+ find_library(ENCHANT_LIBRARIES
+- NAMES enchant
++ NAMES enchant-2 enchant
+ HINTS ${PC_ENCHANT_LIBRARY_DIRS})
+
+ if(ENCHANT_INCLUDE_DIR AND ENCHANT_LIBRARIES)
+@@ -39,7 +39,7 @@
+ #include <stdlib.h>
+ #include <stddef.h>
+ #include <string.h>
+- #include <enchant/enchant.h>
++ #include <enchant.h>
+
+ EnchantBroker *enchant_broker_init();
+ char **enchant_dict_suggest(EnchantDict *dict, const char *str,
diff --git a/app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch b/app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch
new file mode 100644
index 000000000000..e21c3a1db7e8
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch
@@ -0,0 +1,32 @@
+https://github.com/fcitx/fcitx/issues/250
+
+--- /CMakeLists.txt
++++ /CMakeLists.txt
+@@ -96,12 +96,15 @@
+ endif()
+ endif()
+ if (ENABLE_XKB)
+- # Parse xkb xml file
+- find_package(LibXml2 REQUIRED)
+ find_package(IsoCodes REQUIRED)
+- find_package(XkbFile REQUIRED)
+ # Parse isocodes json
+ pkg_check_modules(JsonC "json-c" IMPORTED_TARGET REQUIRED)
++ if(ENABLE_X11)
++ # Parse xkb xml file
++ find_package(LibXml2 REQUIRED)
++ find_package(XkbFile REQUIRED)
++ find_package(XKeyboardConfig REQUIRED)
++ endif(ENABLE_X11)
+ endif (ENABLE_XKB)
+ if(ENABLE_PRESAGE)
+ find_package(Presage)
+@@ -121,8 +124,6 @@
+ message(FATAL_ERROR "Xkb is needed")
+ endif (NOT X11_Xkb_FOUND)
+
+-find_package(XKeyboardConfig REQUIRED)
+-
+ endif()
+
+ if (ENABLE_TEST)