summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-table-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-table-extra
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-table-extra')
-rw-r--r--app-i18n/fcitx-table-extra/Manifest4
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild39
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild39
-rw-r--r--app-i18n/fcitx-table-extra/metadata.xml15
4 files changed, 97 insertions, 0 deletions
diff --git a/app-i18n/fcitx-table-extra/Manifest b/app-i18n/fcitx-table-extra/Manifest
new file mode 100644
index 000000000000..959643f2efc8
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-table-extra-0.3.8.tar.xz 3700736 BLAKE2B b8ce4b3aa04eba8b594b86958bb83e348758c30688828a4834643cf7bdd62852c2ca89bc4f75f0cb1b16ce969b0454c58e3abadff9c78318dc0953e0905c75fa SHA512 454798e9bd25c630ce98e2daf7296e82ba5fbc98027171038a5a7b9ac3169c153302a6703d9416718ec3a0b76db6d732caf3f03c6e6005841c9d7798702542df
+EBUILD fcitx-table-extra-0.3.8.ebuild 780 BLAKE2B 53518ff05fedb94bfa1d29fd309be969d4c80e058a04c80d5e787579f94ecdd894c0dd116b8478cdbd0ddcb463d22dee879ea75bdcd00fdf19ccaece256f4208 SHA512 ef58a0c37f2cd142b2f72ce16d2f402bf34783445e50223d060130315da621ac91794b211135d14dcdf1ce71195208008ba2144945441bfab3b831f47d86a4e7
+EBUILD fcitx-table-extra-4.9999.ebuild 761 BLAKE2B bb577d020029b0e2c87883a60b768c866986313c01e9e48234eb4b767bb25955533f29026bc6f8cefc67c80a9acea8c74d7870638cb6fc7226eb10373b0be087 SHA512 e3247a4b041f08e0a3c61d68b485c647f55716b651aedc14cd27ae715a5fb93f56ab7bf04bcb9a18682c0edf70fb0405d3d208e63f17c088ab51cc6d0f2ccd4e
+MISC metadata.xml 456 BLAKE2B 78d966707f97ae5fbc5f83a323726f4fdc1e8344f031caf61a38e5ebc5f597bf075a132f9f97f761cce8c0313c83c77152f27babe069524f65f949be11ca1fa1 SHA512 f9e89b87bf3ca5d3478cc17f42f40a3aa78fa07dfa7bcac03e2b40d7a60de9321e0e255fb0a4fdab6e1742c7c22bbd992395a9ad1ad6f7ecebf606d706816df1
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild
new file mode 100644
index 000000000000..a2516d917e26
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-table-extra.git"
+fi
+
+DESCRIPTION="Extra Chinese table input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-table-extra"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[table]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild
new file mode 100644
index 000000000000..9a7d55beda2c
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-table-extra.git"
+fi
+
+DESCRIPTION="Extra Chinese table input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-table-extra"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[table]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-table-extra/metadata.xml b/app-i18n/fcitx-table-extra/metadata.xml
new file mode 100644
index 000000000000..4c163079a51f
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-table-extra</remote-id>
+ </upstream>
+</pkgmetadata>