summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-sayura
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-sayura
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-sayura')
-rw-r--r--app-i18n/fcitx-sayura/Manifest4
-rw-r--r--app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild41
-rw-r--r--app-i18n/fcitx-sayura/fcitx-sayura-4.9999.ebuild41
-rw-r--r--app-i18n/fcitx-sayura/metadata.xml15
4 files changed, 101 insertions, 0 deletions
diff --git a/app-i18n/fcitx-sayura/Manifest b/app-i18n/fcitx-sayura/Manifest
new file mode 100644
index 000000000000..6c6c87c329c0
--- /dev/null
+++ b/app-i18n/fcitx-sayura/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-sayura-0.1.2.tar.xz 25400 BLAKE2B 6bed1b86499b4448e87cb76c719d8fec3f7af7e5a4a4846ddc30e6e278f5e67c5ee47d39f4e19d3c8c927ce34bf66f51cf189d1147af0e509c3815ba4552a953 SHA512 2118c95d4f831e5f4e0af0549ae3eb4f16bff8b30b03452837bd14f35fcb524f730b27ceb7c14cf6a4db7400a67070929a75465195b5524187e97c7ca02de466
+EBUILD fcitx-sayura-0.1.2.ebuild 791 BLAKE2B f94e82f9820377bc8c34770887d6aecad5b99adfddcd84ef32eb8af761ad60c8b494a86f476a29475a29c6e5730c0ac93a70df065f6e63697e6a19e188b3493b SHA512 38fb7050b41d87491e8eb17e05a19fc221b8f800d39d5165f3e9c7f857c04efd9ebdd6375b8fa515321ffd0de7c6f9ad4dc807c194e480f667b974fd2286b340
+EBUILD fcitx-sayura-4.9999.ebuild 766 BLAKE2B 8d43dab894f122b97d445141d97b3395678c342f5d5e67823041e6bc1395d2266c7e9d389e51d862e12a1ac9ab535779567aa299047cab6175f6052729b142b4 SHA512 f48bac2e1168f8860bfe1d5b84dbeeefafbf54f9a878114ceaf27f31ecd51e5b25804a58c1cf0904c6fa5ca4b608a0f02b5853b51ab4d0f0014056a867ba0e49
+MISC metadata.xml 451 BLAKE2B 084d21e15c65487a7e4026c93f4a109cbad30bb760966b9d9e171644263de979ecc359cad3b7f86c1f9d346252eb67a3dd29102b728ae3a1c1b019446a83c6a3 SHA512 e1fd5d3abc6808d56d6ed7d3cb9e93aed582bf391f76c3bcc96ba20522eb5d72029662879c81dd02a0a9f3171f0ed6c8a13f3f2d4675c542ee180d6d3acb4bca
diff --git a/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
new file mode 100644
index 000000000000..aaecf413d372
--- /dev/null
+++ b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-sayura.git"
+fi
+
+DESCRIPTION="Sinhala Sayura input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-sayura"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-sayura/fcitx-sayura-4.9999.ebuild b/app-i18n/fcitx-sayura/fcitx-sayura-4.9999.ebuild
new file mode 100644
index 000000000000..96a0b8ba5369
--- /dev/null
+++ b/app-i18n/fcitx-sayura/fcitx-sayura-4.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-sayura.git"
+fi
+
+DESCRIPTION="Sinhala Sayura input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-sayura"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-sayura/metadata.xml b/app-i18n/fcitx-sayura/metadata.xml
new file mode 100644
index 000000000000..733b3cd2db79
--- /dev/null
+++ b/app-i18n/fcitx-sayura/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-sayura</remote-id>
+ </upstream>
+</pkgmetadata>