summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-rime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-rime
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-rime')
-rw-r--r--app-i18n/fcitx-rime/Manifest4
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild50
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild58
-rw-r--r--app-i18n/fcitx-rime/metadata.xml22
4 files changed, 134 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/Manifest b/app-i18n/fcitx-rime/Manifest
new file mode 100644
index 000000000000..51dcbe24a0ea
--- /dev/null
+++ b/app-i18n/fcitx-rime/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-rime-0.3.2.tar.xz 40960 BLAKE2B 1c9185dd9d2912e74b9916916fed09a01c30e0867d93fe94e04d5324883783dddbdca0f553d80aa19e2e59d2ec8fd2a50a7f89118c22cb09310296292a566760 SHA512 8c6d845b0899d9b8b9b41b895abd5c1b8916856b71f529aabd08d1c27a2b09bb5a9343912d088da460c2e22da0a3ce759a34fd13099a149bb8cd1ff4eafe29f1
+EBUILD fcitx-rime-0.3.2.ebuild 933 BLAKE2B e9840ab86bea7816d3fe0520035946aad7211a190c3a7d25629829a6d465cc4cddb2c4d13e26950aea51585632e5ba1d0b6001f509494828c31af50b2763eeb8 SHA512 1b129104f3e97c59e141221f43150e42496add2475dee89ee42cbf25baa707a5f714cd50b41f43a1186dd5ae38fddf399d973cc925cabe2e4be7c6f67a1a7c3d
+EBUILD fcitx-rime-4.9999.ebuild 1136 BLAKE2B 9da5484ab39db235ccfb150a6b47b8d9adae3f34dab468b2f8987cfb19fde3a68bc6cfcce33a518b289adc3027a7ab8650336077c066343da9590c2a3cdce353 SHA512 0578707d971620ace9b6a6b0ad5101a2b366c1131145db6df11db87ce9659af1f7ed4da6a3dbd694c1f3f09855a43b4a4aafab48c272743731425571028e5765
+MISC metadata.xml 633 BLAKE2B 9a5add83e197994f7b6c257f6297a25795c97c59c3d7232de6739ecb62a425f5d1f6c359034a71b0bfd7b8ac64e03f1a205f266226ee72fbda70d2439df48e6b SHA512 699528f389f754a6a49fad395d5c3678a62276f5ad455cc66e20f2268f301ec1f74f5ed3093224383d0a1415bbec6c784134a2c3f7991144be4949aa51cacbd3
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
new file mode 100644
index 000000000000..675cba41e886
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-rime.git"
+fi
+
+DESCRIPTION="Chinese RIME input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-rime"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/librime-1.0.0:=
+ app-i18n/rime-data
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR="${EPREFIX}/usr/share/rime-data"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
new file mode 100644
index 000000000000..b40865038567
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-rime.git"
+fi
+
+DESCRIPTION="Chinese RIME input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-rime"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS=""
+IUSE="+configuration_tool"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/librime-1.0.0:=
+ app-i18n/rime-data
+ virtual/libintl
+ configuration_tool? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ configuration_tool? ( dev-qt/qtconcurrent:5 )"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR="${EPREFIX}/usr/share/rime-data"
+ -DENABLE_QT5GUI=$(usex configuration_tool)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-rime/metadata.xml b/app-i18n/fcitx-rime/metadata.xml
new file mode 100644
index 000000000000..867246b6c0f5
--- /dev/null
+++ b/app-i18n/fcitx-rime/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <use>
+ <flag name="configuration_tool">Install configuration tool</flag>
+ </use>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-rime</remote-id>
+ </upstream>
+</pkgmetadata>