summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild')
-rw-r--r--app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild b/app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild
new file mode 100644
index 000000000000..b88697a1c677
--- /dev/null
+++ b/app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-m17n"
+fi
+
+DESCRIPTION="m17n-provided input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-m17n"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-libs/m17n-lib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()