summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-configtool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-configtool
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-configtool')
-rw-r--r--app-i18n/fcitx-configtool/Manifest4
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild43
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild43
-rw-r--r--app-i18n/fcitx-configtool/metadata.xml15
4 files changed, 105 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/Manifest b/app-i18n/fcitx-configtool/Manifest
new file mode 100644
index 000000000000..46186f4a42ca
--- /dev/null
+++ b/app-i18n/fcitx-configtool/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-configtool-0.4.10.tar.xz 50440 BLAKE2B f2f2241d3ea139f6f3de9b8c6ffcc71c789dfa291efe4c551596eebc8a04f13f9fe698cc25d8349a174399044d15ddca2aeab952ac2bc7f0f4e9e47d453329ca SHA512 1c1267e9de694bbd5f258b5bba1e7514c4f8556cdc82a1cce5eafd8a4ec571955285dade0acd02f128eca01f867a30c5c6264ee7e91d32a333eba6e4d275fe8f
+EBUILD fcitx-configtool-0.4.10.ebuild 831 BLAKE2B 5342138dc4af4354b5ca06c03260e407b63a45f1c3f522e8758034f729371751cf2375e6b6682f40e330b7e713e38d68d82e930a1f94b5d4c470ca9232ea9bb4 SHA512 ef003e011c72b05cae5daae39a2df95fb5e0d186f9868e4ebe86d4d0a2e41e9df6d085b02ac9eadfc398364dfec313a7ba36e08e128dc1bb84f6e983c77986f2
+EBUILD fcitx-configtool-4.9999.ebuild 812 BLAKE2B 5104f5a8249c301d2a0cf34b723fde5955fd9fd5a04dcd22db324a4df7a41137a4998c22e7ce8e1203d2e3792924e33f91ab3442bbe0407f8de8e17a2c1cf75a SHA512 f034a758bdb93e6ff25418680c20c1f46133bad1e975ac2dcdf4ecb353d9b146e8ae3c1380efee3956d2ba37b2927f1ad737665bf7f66f1ffc840ff16d73e94b
+MISC metadata.xml 455 BLAKE2B a7e9760354a785de1313e86c591681c8e3deee0e9debbbe9b1cdc4be1f6c4b669a86db8afaa94aefd7c598748dbedf0a4e4d19a3c18ae94c8876741a63e5bf17 SHA512 34d0456d670a277afe5579b57e5d403fdb936b75efeecba10f37b43fb78d55f57d2722bc9abdf605197e98497ccd71c6f21b55ce6dd6b4e55860f483622ef70e
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
new file mode 100644
index 000000000000..33805e7cbebd
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-configtool.git"
+fi
+
+DESCRIPTION="GTK+ GUI configuration tool for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-configtool"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2=OFF
+ -DENABLE_GTK3=ON
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild
new file mode 100644
index 000000000000..5778190ca4f5
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-configtool.git"
+fi
+
+DESCRIPTION="GTK+ GUI configuration tool for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-configtool"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2=OFF
+ -DENABLE_GTK3=ON
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/fcitx-configtool/metadata.xml b/app-i18n/fcitx-configtool/metadata.xml
new file mode 100644
index 000000000000..163f08b0b6df
--- /dev/null
+++ b/app-i18n/fcitx-configtool/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-configtool</remote-id>
+ </upstream>
+</pkgmetadata>