summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-cloudpinyin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-cloudpinyin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-cloudpinyin')
-rw-r--r--app-i18n/fcitx-cloudpinyin/Manifest4
-rw-r--r--app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild34
-rw-r--r--app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-4.9999.ebuild34
-rw-r--r--app-i18n/fcitx-cloudpinyin/metadata.xml15
4 files changed, 87 insertions, 0 deletions
diff --git a/app-i18n/fcitx-cloudpinyin/Manifest b/app-i18n/fcitx-cloudpinyin/Manifest
new file mode 100644
index 000000000000..314a299b1d91
--- /dev/null
+++ b/app-i18n/fcitx-cloudpinyin/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-cloudpinyin-0.3.6.tar.xz 22596 BLAKE2B e53f64dc999eb1ffb1d3c37b6ed75272da9a76d196df681b71876281ded778f83c73eef2f9100233f580a389e36bfc8681cd7be5e23ce4d9c27c26384062cf9a SHA512 d3a05fc48659db64a0a827c9b75cfb8b33f7cdb48bd936a2ba33f49469e29558a7da0f58cb7e6929b1265d451d23b0a37d87b7b69752599656c94049077d9914
+EBUILD fcitx-cloudpinyin-0.3.6.ebuild 739 BLAKE2B e431d4bec95c002becfaf8c68903bd306a03552a84b009b8c1fe6dcc6c1cbe74f7d1913a6aa33ed7e6e7134d2176c0b290c32ddea0048faa1bd073d592abfafd SHA512 09f06cb5f6e0c27faae6d9d1773d2dbf90f2fc3a4d5d0534c3635f9ca931618728f86493b9fafd8c9163b1aa726fe8f6faa65e1880b69cea16e09b7507cb2fab
+EBUILD fcitx-cloudpinyin-4.9999.ebuild 720 BLAKE2B 69e6893afb7bd87ac5f125cd31660e3d5fe62c76541a41ae244ff6f2a4f8b8d432e7d25384d118f7b54b7179d856bb32a4f2fe2ccb418fc990fa79b408f08f9d SHA512 faa3da2b4eaed62823f1b412ae5007de2436b0e2ee050fd1eb0f0c86b38f6ff0bd0a04b55988fe66e95bf5593144278317d4a3f620c01693f02d893189816ef2
+MISC metadata.xml 456 BLAKE2B 644db7a23b73c35e0aba40bfb444f6ffe24fa03ac461f57eae0c792428cd0396ccf3079da8ed31ccdb63b2edc32cc2ff2b0964444c77a8148aa4aaae90edcd9c SHA512 213d5df684d2ff47acc1cf54a122cbd345b311e814cb71c4a77e2b05e2d0e869e3d00d9f8d8f8691bdd119fd99e1ad4b8a5dd8e84d762ee8aa454f3d4765d554
diff --git a/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild b/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild
new file mode 100644
index 000000000000..5eda97b53959
--- /dev/null
+++ b/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-cloudpinyin.git"
+fi
+
+DESCRIPTION="Internet look-up support for Chinese Pinyin input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-cloudpinyin"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ net-misc/curl:=
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
diff --git a/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-4.9999.ebuild b/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-4.9999.ebuild
new file mode 100644
index 000000000000..14ed5cf98819
--- /dev/null
+++ b/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-4.9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-cloudpinyin.git"
+fi
+
+DESCRIPTION="Internet look-up support for Chinese Pinyin input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-cloudpinyin"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ net-misc/curl:=
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
diff --git a/app-i18n/fcitx-cloudpinyin/metadata.xml b/app-i18n/fcitx-cloudpinyin/metadata.xml
new file mode 100644
index 000000000000..183e87e5137e
--- /dev/null
+++ b/app-i18n/fcitx-cloudpinyin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-cloudpinyin</remote-id>
+ </upstream>
+</pkgmetadata>