summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-chinese-addons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-09 00:12:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-09 00:12:01 +0000
commitb95a6fd4a7b591baa7cfc689f8ce5643592d07be (patch)
tree6a7c4722b40bdb6c409879ce253d8b42817fec14 /app-i18n/fcitx-chinese-addons
parent8b3c41ecef8a1cdd270ce3aabcfdfb991839699c (diff)
gentoo auto-resync : 09:02:2025 - 00:12:00
Diffstat (limited to 'app-i18n/fcitx-chinese-addons')
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest2
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.8.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
index 3cfd9ba2b392..ea3d068a7d50 100644
--- a/app-i18n/fcitx-chinese-addons/Manifest
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -1,3 +1,5 @@
DIST fcitx5-chinese-addons-5.1.7_dict.tar.zst 1014942 BLAKE2B fb386dad971b2a8751202733ef593b72d35f9ab8a266f13e6839ea25010cf54e45c287e10d285a02d268f16b5b8f7a3dc6f6f20ffcc79759d8c1ef1136a29cb5 SHA512 fe04699672f034bde328049a19f23b9dbea75a980e706fcaf95138294b8aaaee54eb9ec5c696c343d5e4ce4788216821ad3eb45cd669d94d2f3b67551ae7360f
+DIST fcitx5-chinese-addons-5.1.8_dict.tar.zst 1009572 BLAKE2B 63014424ca758cce38b2bc24c08c9add503e73c1e94e574cbae5d051753c6bca134bc88f4e096c264a3731b556f748e8af9496f78d5348956aa5cc78cbb843a1 SHA512 0fc8d3daf608781b573bfb5239988ae07f251558fc1d963f99962eb33a35d374f4a3e146f5c7bec1c403fa268495075cb3805f6478788fa79220377c72a98ea9
EBUILD fcitx-chinese-addons-5.1.7.ebuild 1496 BLAKE2B ea2a720010ed485dc05903eb5931c6dc66b1ba99f1fa8631c5854cffa95803bd706978c60476df3e541d8a1c1698fb0ed35e9e40f719aaef065709a1be238c2e SHA512 f7dfc7d887c2b9330590ead67adaa6aad746ee49192cf7559a1096047fb38164427d29f7f38ed4f6b01c4db3394791557f4ec30192089ee172830a8ad917f1fe
+EBUILD fcitx-chinese-addons-5.1.8.ebuild 1498 BLAKE2B 2026defb8698bf3c22309760dd6bff30a19af766baec4291bb2d3ddacc44ac6747dae92176f5a57ffc0563d9940e3afeccca23da11cf9b607ff6eff13fc95bfd SHA512 f7bd4e03d21f6e498e81220c759195e8b606f5f1d0857c8041d0d19dedf90e0adbb7dda7a5189fcc99bf8cb25f5ee8060341a9df6ba34e1a49ff3739e68facaa
MISC metadata.xml 993 BLAKE2B 034a9f1ca3966a67fb884f3e0ce6baeb83c3ccfb2b7d7d99d41e54ef30087c94d5a0c9729902e08eb8b781deeb71daf57b27f3d238beebf6e356e690aae7723b SHA512 05140cdf9695922cf2ddad40744d51d197fc3beab99ca7ba5d19b38a7c22762195f2e3a3c2e2ded46f253e1efeab06259429725830328c5f2001fe0752cd2b26
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.8.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.8.ebuild
new file mode 100644
index 000000000000..8a30945075c0
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+data +gui webengine +cloudpinyin +qt5 qt6 lua +opencc test"
+REQUIRED_USE="
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.12:5
+ >=app-i18n/libime-1.1.7:5[data?]
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent]
+ app-i18n/fcitx-qt:5[qt6,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_DATA=$(usex data)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ -DUSE_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}