summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-chewing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-chewing
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-chewing')
-rw-r--r--app-i18n/fcitx-chewing/Manifest4
-rw-r--r--app-i18n/fcitx-chewing/fcitx-chewing-0.2.3.ebuild41
-rw-r--r--app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild41
-rw-r--r--app-i18n/fcitx-chewing/metadata.xml15
4 files changed, 101 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chewing/Manifest b/app-i18n/fcitx-chewing/Manifest
new file mode 100644
index 000000000000..f5ac621a3650
--- /dev/null
+++ b/app-i18n/fcitx-chewing/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-chewing-0.2.3.tar.xz 19804 BLAKE2B 0a83ae9a17eb74898e41471450a9054bb05e504a60d05bda91fa53f90cb4328b0db4bd5e1d662c81c9322268660e57a7f2cb9c547593913206a00394883341b1 SHA512 3492ad6ecaf00bb1ea07b76c9c23da075615597c1a68434a2da003cbe410d12172510d4306379777a1d04a359b017c49d278c002a7230b030693b668b6030bfd
+EBUILD fcitx-chewing-0.2.3.ebuild 808 BLAKE2B 99dbdc0625b869c94abe9ffad801da193ae4139925c9fa6a7f2810a358f8f8bf6d71259944e1c717bfcf1ab95e523ed707944b8824147516a43ed26087ecadda SHA512 027294d0a8f06c8900a9352ced15aaec8be43b24cc1766a9dd929e2ad0fde63b9d6323f8c790382a0a7fbddd901876da06274d76bcc244f96da449b4b8a29b79
+EBUILD fcitx-chewing-4.9999.ebuild 789 BLAKE2B 458a1280bfcf52b400836cd6aa2e0c1a2725823da488045105e1c670f3472b9bf285cc6d0a4b854e426af9ea7a47ddf05c549c1078184c2baddc293a675fdbff SHA512 35600562a60083fcdf1d1e33ebbcc0fb227f4aed22eefd4fbd99fe5b55c046a496f6736be83a684ba02d2a2c0c8a75442839a12ff75fbc285cbe643003229c66
+MISC metadata.xml 452 BLAKE2B 57060504d81e6cd26399a9c925569dee13e82f05b116461e9b5a770b4d85e84c4845750ec57fb863c91f5f1074120fef1416407de3d2250d48b042b998834877 SHA512 c48559820436222f9bb7a7e7decd0a5605b8cefdb08e2a35fd30041cdf61e923592f61cf58efa9c2f35d6c464ab1957c092dd69a324ff1a6a3553259054768fd
diff --git a/app-i18n/fcitx-chewing/fcitx-chewing-0.2.3.ebuild b/app-i18n/fcitx-chewing/fcitx-chewing-0.2.3.ebuild
new file mode 100644
index 000000000000..7b2a3ebd031f
--- /dev/null
+++ b/app-i18n/fcitx-chewing/fcitx-chewing-0.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-chewing.git"
+fi
+
+DESCRIPTION="Chinese Chewing input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-chewing"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/libchewing-0.5.0:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild b/app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild
new file mode 100644
index 000000000000..3d0c5778f7be
--- /dev/null
+++ b/app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-chewing.git"
+fi
+
+DESCRIPTION="Chinese Chewing input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-chewing"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/libchewing-0.5.0:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-chewing/metadata.xml b/app-i18n/fcitx-chewing/metadata.xml
new file mode 100644
index 000000000000..9a5bbb63bce1
--- /dev/null
+++ b/app-i18n/fcitx-chewing/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-chewing</remote-id>
+ </upstream>
+</pkgmetadata>