summaryrefslogtreecommitdiff
path: root/app-forensics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
commitda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (patch)
tree0a7a1b7b3ad60c3b21c697e75908b256fc9ed6b1 /app-forensics
parentb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (diff)
gentoo auto-resync : 20:04:2024 - 12:05:23
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/Manifest.gzbin4711 -> 4707 bytes
-rw-r--r--app-forensics/yara/Manifest2
-rw-r--r--app-forensics/yara/yara-4.5.0.ebuild60
3 files changed, 62 insertions, 0 deletions
diff --git a/app-forensics/Manifest.gz b/app-forensics/Manifest.gz
index 5aab73c12f79..49d42fabcd24 100644
--- a/app-forensics/Manifest.gz
+++ b/app-forensics/Manifest.gz
Binary files differ
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 8ead81cd4db2..20c126369be7 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,4 +1,6 @@
DIST yara-4.4.0.tar.gz 2220068 BLAKE2B f9654592f3dbe493dc31bcda80c9f0e31a2a8998f47d1172afe7456a9d4ead8f475e3f0999140c952343cdeca1cedc8060a3b42c1bbe57ce617fd5b5a86dbfb3 SHA512 705db57b73e5165a26e0aaea728521f372b9f7f613665860dd22066c30e75a614815fb17ee8654780fcfc157f0137cbeda015ec088a698f31adcf071e233205f
+DIST yara-4.5.0.tar.gz 2206492 BLAKE2B 788ed6c4989bbc2d0a113b46bcd1291e7544ab8f56ebe499725163b7b02feb016935210e8a08d9cb179fbffc09fafb461cc55156101d9616a23a480a78862d9e SHA512 c9fe8a89879d1a742236101f1754e6b25e70356cdf5c020b2583e3ac509600c3b462756c412b01f2ebcb17df351c83afcf04d1cfaa87e6753eb25bab0f797aa3
EBUILD yara-4.4.0.ebuild 1297 BLAKE2B b039bc6e8343b87edbd06fbfc16b1eae05dcd497ae0835cac3aa5940fe6479ec19bae1c5ab9d6792d9e33158f6f361d7e8cdb4135a766d5a87a68c3dbbe9bb5e SHA512 38cb38145ebb4c6eea9665f8ce8d4c701ce03fc3f4a3f8e626a2b8e7198a91f2a05e189fabbf3d65321d09f743c00b4ce10c4cbb84199619e33a43f145b5b781
+EBUILD yara-4.5.0.ebuild 1299 BLAKE2B 4208b45277ff07eb8ff437a7e44fa0a187c1db0e2d0140b943e965d03e5142fc6ab54129a016e7dbde9a386d6f07484105b443495d2b520b13993821ccad4e89 SHA512 db9c694679a26498fca4f15aaededc1e2d66bc149c114be6b4a2fc93e47e6856b61012b00422671ad7d73f682d0da2869a4f58bab90508237d96f074d0c60b99
EBUILD yara-9999.ebuild 1299 BLAKE2B 1bfd0ff1ce1aa183bc0b605d3bbde4660fa8b97c3502426bc76335e9b74a9528232556c82fcf1fb1bc77f1c22711ae4af042585834567211e429474496d03b24 SHA512 56cf978196ec23ca63fa5846bd928ade3dfc607dc9f91c7e8a5471936bbd9086bef5da8fc3f32ee376116dab92ed5cb959c97752b891f997b46b478fec046d1a
MISC metadata.xml 1284 BLAKE2B 5e8b7f95170b97d4d55fda012f1108acfb0cae362d4da0f3559375d529194b5e4f9644d8ca3d0fc7e438b873f3827aec307dc664808a56561153679fc0bd5729 SHA512 64048379eb1d51afeee050ea906a8fa7bda9d5bdc78807d04c1f5f5b5a425b512de5facb6b79f23ed8d5517caf779ef327d7eb148ae2a32407904db05efb337f
diff --git a/app-forensics/yara/yara-4.5.0.ebuild b/app-forensics/yara/yara-4.5.0.ebuild
new file mode 100644
index 000000000000..e5874a8e7202
--- /dev/null
+++ b/app-forensics/yara/yara-4.5.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="https://virustotal.github.io/yara/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara.git"
+else
+ SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}