summaryrefslogtreecommitdiff
path: root/app-forensics/zzuf/zzuf-0.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-forensics/zzuf/zzuf-0.15.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-forensics/zzuf/zzuf-0.15.ebuild')
-rw-r--r--app-forensics/zzuf/zzuf-0.15.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-forensics/zzuf/zzuf-0.15.ebuild b/app-forensics/zzuf/zzuf-0.15.ebuild
new file mode 100644
index 000000000000..189de28bc39c
--- /dev/null
+++ b/app-forensics/zzuf/zzuf-0.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Transparent application input fuzzer"
+HOMEPAGE="http://caca.zoy.org/wiki/zzuf"
+SRC_URI="https://github.com/samhocevar/zzuf/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+# Uses dlopen hack to hijack many libc functions.
+# Fails 2 tests with sandbox enabled: check-zzuf-A-autoinc check-utils
+RESTRICT="test"
+
+DOCS=( AUTHORS COPYING TODO )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete
+}