summaryrefslogtreecommitdiff
path: root/app-forensics/yara
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /app-forensics/yara
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'app-forensics/yara')
-rw-r--r--app-forensics/yara/Manifest2
-rw-r--r--app-forensics/yara/yara-4.2.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index de4566ba38b6..f0d2d4545a30 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,5 +1,7 @@
DIST yara-4.1.3.tar.gz 936462 BLAKE2B abfdd5918abe3641056ccde3eebb754cbd66eff5569978d3b1aad5d925d62fcb96b1f7367d0d014dd165db8634418259667be3b2441f93e0848bfbd905ca32dd SHA512 1bfa1787c62dfd9a87fa8db5e8c2fa68f082ae66b16b5373bdcc6bc66b32016fcaffd4baa7e59a7c1f6d3426c972eca9cc22f70d475067d7557b1014a4ab65fc
+DIST yara-4.2.0.tar.gz 1284059 BLAKE2B 735d161fde5f84199315f1ce6d31f1ad79488312bede85d2941a03cb97fe75c3c4db0b3cba75782d338a462d87e9d9ed57b393bbdb68decfb350a1bbd096258b SHA512 24ca707015c77d87126bcaac0991997f6b09403024765d615a06db47191a3f0177e1c1eb4a917ec8412876b61d28f4a708f36999ddd9214c3967968c71ae3b7c
DIST yara-4.2.0_rc1.tar.gz 1283822 BLAKE2B d7bf869e670a0223895aac31df0dbe063d3f0110d1981ae8a42ab26726976790c744b522f13a6963f521310a281fab2b27d6336b23e504a4a9a3d414473ae452 SHA512 03bd09d7c020078946101854e68b7f9ca17c04f7a68624e9e15dc476fe209cc11b010108a0e7aea9746f05aabdbb8d6a6a2ffc54516eb9cb86f170c4259934df
EBUILD yara-4.1.3.ebuild 1084 BLAKE2B 0a458d363a826219fca0b28da3d9520446597d89f5d51564b3801b7703421b2eead7360d0deb88382c4fd5459ff7165d60de16b060c3b3282f24ec71ce903d4e SHA512 a30a98f8a109130c06f578a76aa99f91bf2baaddaaa514b67e51cdc5957cb7b9f7a219827359a64df380425c26253e1114cfbed2007cbd5adf37cec9322c00b7
+EBUILD yara-4.2.0.ebuild 1154 BLAKE2B d881ba15e2b3bfcde9ce490981af10e8a2828edcfd6a729d5ce69b763fd4f6be1bd1c13fb83bc79602ba6d0be4f2c2f52cd840f07419687d2e8293bb2df1370c SHA512 edb5a75ad5fdef624320c18950a11faf45e5a04152afc3ec4c7621d07e9eb3000c8bd82e695ff8d5226ecb5347c3ab155dca98482d6bf102c261cf5c10f7b799
EBUILD yara-4.2.0_rc1.ebuild 1154 BLAKE2B d881ba15e2b3bfcde9ce490981af10e8a2828edcfd6a729d5ce69b763fd4f6be1bd1c13fb83bc79602ba6d0be4f2c2f52cd840f07419687d2e8293bb2df1370c SHA512 edb5a75ad5fdef624320c18950a11faf45e5a04152afc3ec4c7621d07e9eb3000c8bd82e695ff8d5226ecb5347c3ab155dca98482d6bf102c261cf5c10f7b799
MISC metadata.xml 1151 BLAKE2B a2f641c9c0f851884cc6482248446d7b509e4ca2c5cec26159063a0fec025b8928955cfefbdf87e26ace0d06a01a2cec7d1f3d10b09b99b1cf1040c09519adfa SHA512 5001e3a14dc458a6b27f69226fb346dc8bf07058270e20b81f325c0742300ccb6e241b3d3dc6f55eccc43b68f0fea74977d33d8bcca6d0612057f6015f857500
diff --git a/app-forensics/yara/yara-4.2.0.ebuild b/app-forensics/yara/yara-4.2.0.ebuild
new file mode 100644
index 000000000000..8bac51561719
--- /dev/null
+++ b/app-forensics/yara/yara-4.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="http://virustotal.github.io/yara/"
+SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" -name '*.a' -delete || die
+}