summaryrefslogtreecommitdiff
path: root/app-forensics/lynis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-forensics/lynis
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-forensics/lynis')
-rw-r--r--app-forensics/lynis/Manifest4
-rw-r--r--app-forensics/lynis/files/lynis.cron-new3
-rw-r--r--app-forensics/lynis/lynis-2.6.4.ebuild50
-rw-r--r--app-forensics/lynis/metadata.xml5
4 files changed, 62 insertions, 0 deletions
diff --git a/app-forensics/lynis/Manifest b/app-forensics/lynis/Manifest
new file mode 100644
index 000000000000..2e267c968b9c
--- /dev/null
+++ b/app-forensics/lynis/Manifest
@@ -0,0 +1,4 @@
+AUX lynis.cron-new 70 BLAKE2B 64ffbfa698bc13450503907bd9073a1266075c12fe709a5036b412a6a39e5730de0cf83f52864f7e474506ec5f1aeabf9415f2c0d58a6d7e41847670ce311f91 SHA512 f90592c9adb6617b367c22912ceb984cca9a64c1bfa092efb50f5f9df48b07f61c7e990b969f3871161d92ff28bdb131175d46b334947980b7ead49dd6ff70c7
+DIST lynis-2.6.4.tar.gz 273031 BLAKE2B 66d83050a348cc348f101f603c62eb3107ef7e088f57a6d0f36cb657a03cea48b93293b1c22a2bab68bd1ed1178e5bab7cf72cdcdd073637224559bb0c8b1198 SHA512 baa9f1c06b4d55b7962cb218707e057c7e7b5a5c4dbd89ba317c6525f08f80a5de53aa1371ad361611f8e44f0a32dda9409d2816caaedba4cd4f508929c5ab3c
+EBUILD lynis-2.6.4.ebuild 948 BLAKE2B bf6edb25a080382349878f4ee279c638e48c181dc0ba630f6f28e77984d2f9b95773f1eef6dfffa894fce73f355ebb5d6e8fe316d5f082effd286babd56920f5 SHA512 7a9f762e5e5ca0f6d7cd3f3c934d78b44c6c080bd926a0923eb21c6894f56fe27a8f355fd528d5276d2ddbc77967c728fc8e74fd29a7ec6d66edbae7e0644f4c
+MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/app-forensics/lynis/files/lynis.cron-new b/app-forensics/lynis/files/lynis.cron-new
new file mode 100644
index 000000000000..15a39f1ca235
--- /dev/null
+++ b/app-forensics/lynis/files/lynis.cron-new
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/sbin/lynis --checkall --auditor "automated" --cronjob
diff --git a/app-forensics/lynis/lynis-2.6.4.ebuild b/app-forensics/lynis/lynis-2.6.4.ebuild
new file mode 100644
index 000000000000..03c1f53b426a
--- /dev/null
+++ b/app-forensics/lynis/lynis-2.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
+ einfo
+}
diff --git a/app-forensics/lynis/metadata.xml b/app-forensics/lynis/metadata.xml
new file mode 100644
index 000000000000..7a38bb900964
--- /dev/null
+++ b/app-forensics/lynis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>