summaryrefslogtreecommitdiff
path: root/app-forensics/galleta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-forensics/galleta
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-forensics/galleta')
-rw-r--r--app-forensics/galleta/Manifest4
-rw-r--r--app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch11
-rw-r--r--app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch12
-rw-r--r--app-forensics/galleta/galleta-20040505_p1.ebuild21
4 files changed, 40 insertions, 8 deletions
diff --git a/app-forensics/galleta/Manifest b/app-forensics/galleta/Manifest
index f1fc2c3a4bf8..dc286dc76981 100644
--- a/app-forensics/galleta/Manifest
+++ b/app-forensics/galleta/Manifest
@@ -1,3 +1,5 @@
+AUX galleta-20040505_p1-Wimplicit-function-declaration.patch 177 BLAKE2B bcd13ac0d5ef6cf8758ad9da3a48e39ca4881c41d7cb1ead344b5c1e02c83f031f138f0a1e1f47d4073f3d2a3f2b2dda5e599d366df75d5b6b20ae25c9738b36 SHA512 3dc314a1902646b98709f860c1435fed8a2851258749137e1519cb3f522b5ef4f0b1b5859609db8523c0bb9538f454d4d537c7851c61390559a30699c6448c91
+AUX galleta-20040505_p1-fix-build-system.patch 262 BLAKE2B b9c1337dbbb72f68bf040e640855bfdd8b0f090923e1c5326d7040ddfd5e957d9f8007998c890ca3e9ddcdc7d426275ce3e18c16f4e51b84b7c4f4f8fa46e6f2 SHA512 d2f071c61ffa582ebaa554ecd51aae7fd4a73dbf6940d18ecb50024e186958f1e8124f008ec5fa73fbd75c383bc9ea5338c46d1f566d5104e17e0d783eba368d
DIST galleta_20040505_1.tar.gz 2813 BLAKE2B bbdbd2e004986f51a48c254d3ebfb795e24bf9623dc9254060fb68ddc94e365decf083c38fb8f04818db5c0634fdfde5457d05b44b59c57d9da452c3261d4384 SHA512 7c420a413371cd9d7d818941026bc6981c8a749b8d3c97a9f0fc867116f9e642a06ad2832ded6de08780ed24885c2de7e8b655400569cb7ae56844161308dc3d
-EBUILD galleta-20040505_p1.ebuild 544 BLAKE2B ca6179fbf486f25bc1b28697c3bc9e79685a204e47f4538b6414b4993f4be4a3275da5c03ed114e296c4d0bf8baa2bab09a27db6768b0a45dd7b7ad5678b823e SHA512 087290ad60531da7dc39a221cc969ea75722124dbc15ee8e79ec327ef0c6c024b513ed697e3d1973aadfff6ff5c09bd0653bf4c9e34a829c5dbf3025cd7d73c3
+EBUILD galleta-20040505_p1.ebuild 595 BLAKE2B 42f54d3e79e352944ac039385e7047e69bfa10a33f7cc82ca65f316dcc6a469370b09ee13f7da20fc39c0118bb54a2ea1dcb1e11c3e9f2267b699360d0b0579f SHA512 13fc7d78c92013168527461130becc24ebda17c962e23eed2d0097c96b335a4c50d39b901892614690e227bbda829d8dc12de51ec02d0b43b61ad488a6c98021
MISC metadata.xml 243 BLAKE2B 49032770463d42b7c19857cc2ea11f0a1a5cbdb1a44b0c77ea2660f377b7d04e113dbb3c7e45870aeb8032d2ef683a35f0f7a958ccadadcbd2de376dd513bed8 SHA512 4e97cd2b4cea4fe6059d375cd29eb5e97c8a40581126a624d1c7a48e2e9092472bc0f4e4f61a95a73121aa183995706b8111757e5dcb3d0bf0458e33029aeda1
diff --git a/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch b/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..396739d358fc
--- /dev/null
+++ b/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch
@@ -0,0 +1,11 @@
+--- a/galleta.c
++++ b/galleta.c
+@@ -35,6 +35,8 @@
+ #include <stdio.h>
+ #include <time.h>
+ #include <math.h>
++#include <stdlib.h>
++#include <string.h>
+
+ #define STRSIZE 1000
+
diff --git a/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch b/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch
new file mode 100644
index 000000000000..125643c894df
--- /dev/null
+++ b/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,6 @@
+-all: install
++LDLIBS += -lm
+
+-install: galleta.c
+- gcc -o galleta galleta.c -lm -lc;cp galleta ../bin
++all: galleta
+
+ installwin: galleta.c
+ gcc -DCYGWIN -o galleta.exe galleta.c -lm -lc;cp galleta.exe ../bin
diff --git a/app-forensics/galleta/galleta-20040505_p1.ebuild b/app-forensics/galleta/galleta-20040505_p1.ebuild
index 890ad5ab0d30..9192b6bdb8cb 100644
--- a/app-forensics/galleta/galleta-20040505_p1.ebuild
+++ b/app-forensics/galleta/galleta-20040505_p1.ebuild
@@ -1,25 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
MY_P=${PN}_${PV/_p/_}
+
DESCRIPTION="IE Cookie Parser"
HOMEPAGE="https://sourceforge.net/projects/odessa/"
SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-S=${WORKDIR}/${MY_P}
+S=${WORKDIR}/${MY_P}/src
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- cd src
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o galleta galleta.c -lm -lc || die "failed to compile"
+src_configure() {
+ tc-export CC
}
src_install() {
- dodoc Readme.txt
- dobin src/galleta
+ dobin ${PN}
+ dodoc ../{CHANGES,Readme.txt}
}