summaryrefslogtreecommitdiff
path: root/app-forensics/cmospwd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /app-forensics/cmospwd
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'app-forensics/cmospwd')
-rw-r--r--app-forensics/cmospwd/Manifest3
-rw-r--r--app-forensics/cmospwd/cmospwd-5.1-r1.ebuild25
-rw-r--r--app-forensics/cmospwd/cmospwd-5.1.ebuild6
3 files changed, 30 insertions, 4 deletions
diff --git a/app-forensics/cmospwd/Manifest b/app-forensics/cmospwd/Manifest
index 2cbf3f73f6de..2f306dc629d0 100644
--- a/app-forensics/cmospwd/Manifest
+++ b/app-forensics/cmospwd/Manifest
@@ -1,3 +1,4 @@
DIST cmospwd-5.1.tar.bz2 36792 BLAKE2B 763bf04af7591843190570d7084e16c2a4490319bc4a3aba9b4a32e440c66ee981f8d90749dca9df69f963294a29500da4641b51e74c7bb6f0f0e4f23a165d63 SHA512 eb76bbab2e686b54421556c5228b90a35c2883d59b31815ab04494df8e2d03e7193abdd83c4a7fa5915abdff1f189eb69bd29fc02ea9d84565ea8767e2c455a8
-EBUILD cmospwd-5.1.ebuild 523 BLAKE2B de4d378a0a8429a00b8888fbc82cc6d9ca92d22ce9be06160769f2546933e2e5a5e0e6846eac523991b9995ef83e0d92075df8b25ab0df60e7fd5cebf69fd830 SHA512 5ec19956ad8ba47f5c9e1b9444bf15cb0573a92f04b32fa9efe853bf77591a077f63c286509d527190f6e2ecf2334155b5362b8bdfe4e2db16b0199b5a9c3d5d
+EBUILD cmospwd-5.1-r1.ebuild 534 BLAKE2B 7c2e98cd5856915f616218eff0143810d330a689f6ff0b5e0331ea4aa55866311680931d75887a18bb85ffdc2909035b077dc44a5818bc347c8ec05136b51bd2 SHA512 b11de18eb59cd438bc64794315730fe6bb12d306c16999464b3f928dc72128d4a0c6349c7e18e663844139d9339d3a2d677c93ba860e5e25b0680228c146778a
+EBUILD cmospwd-5.1.ebuild 525 BLAKE2B aacc16565496c67f20b8c7ec394cddfda840f8d34b240d962128c6b74252e25e87b226225db4d71f5e716eb23b95739bd1a171a7cf553c5d885841cf63e2c3f4 SHA512 aba354443e4bd2aea621a045ffd93ce074a40588ea99131a5a451fa13c3d0dd3e75472091fb2707de1030813f03ce1d77bf0773ec09d5b662a6145c30b860314
MISC metadata.xml 675 BLAKE2B e1dec7335653927acf2ffbe7bfded2d55711d7df2585c4458c2e26e9f5a8d43f9943bae98f12554e669ba6b5438345024df2b11a9bbd161885436377a036e2ed SHA512 4caf9543690502df3320fcd85b841a2a17cad7d4a309bc40d539b23fcc260ffaf25ae3b0d62f7dd84319251bf65cd2e2fc997e9f8a196a15e016b795efc5f0ff
diff --git a/app-forensics/cmospwd/cmospwd-5.1-r1.ebuild b/app-forensics/cmospwd/cmospwd-5.1-r1.ebuild
new file mode 100644
index 000000000000..bf9611e3fd0d
--- /dev/null
+++ b/app-forensics/cmospwd/cmospwd-5.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="CmosPwd decrypts password stored in cmos used to access BIOS SETUP"
+HOMEPAGE="https://www.cgsecurity.org/wiki/CmosPwd"
+SRC_URI="https://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ cd src || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} cmospwd.c -o cmospwd || die
+}
+
+src_install() {
+ dosbin src/cmospwd
+ dodoc cmospwd.txt
+}
diff --git a/app-forensics/cmospwd/cmospwd-5.1.ebuild b/app-forensics/cmospwd/cmospwd-5.1.ebuild
index 1fbc8925130b..5d8abd99a5cd 100644
--- a/app-forensics/cmospwd/cmospwd-5.1.ebuild
+++ b/app-forensics/cmospwd/cmospwd-5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -6,8 +6,8 @@ EAPI=4
inherit toolchain-funcs
DESCRIPTION="CmosPwd decrypts password stored in cmos used to access BIOS SETUP"
-HOMEPAGE="http://www.cgsecurity.org/wiki/CmosPwd"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+HOMEPAGE="https://www.cgsecurity.org/wiki/CmosPwd"
+SRC_URI="https://www.cgsecurity.org/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"