summaryrefslogtreecommitdiff
path: root/app-forensics/chkrootkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-forensics/chkrootkit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-forensics/chkrootkit')
-rw-r--r--app-forensics/chkrootkit/Manifest7
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.51.ebuild57
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.52.ebuild57
-rw-r--r--app-forensics/chkrootkit/files/chkrootkit.cron6
-rw-r--r--app-forensics/chkrootkit/metadata.xml8
5 files changed, 135 insertions, 0 deletions
diff --git a/app-forensics/chkrootkit/Manifest b/app-forensics/chkrootkit/Manifest
new file mode 100644
index 000000000000..53e4619ea4ad
--- /dev/null
+++ b/app-forensics/chkrootkit/Manifest
@@ -0,0 +1,7 @@
+AUX chkrootkit.cron 78 BLAKE2B f43e9a4a0864c3914658298622aaf0e97374e4f8518c085f0c6c1b439583b36567652376a601eb039ca9d6a8bdda0cb18d9c58b36ab61839113048d32ce9fb54 SHA512 6839f3372d28673ee436349a107dc33b77cfd676fd16cda1ccfc5211514e840593d0f106e4e0a9331c4b658860992a9169f3a7cdd75c835a780a41097e7bd758
+DIST chkrootkit-0.51-gentoo.diff.xz 4708 BLAKE2B 0dacba47222319d9e5bb5d39e0eb4b7074fb3025be885c5fd9564c10f592e04ba4afe2d0c792a2e54fe4c9b1103e366f65af949e7c0db730bf61981fe8fe2364 SHA512 13dca9c272d85d35d736e14896058612f62e1781aac034f06882fe63d956f074a3c67bf308c104f0080323bb127ba01373967b2c28481741d17d83310fe52dd0
+DIST chkrootkit-0.51.tar 174080 BLAKE2B 36acd12801d2ac599b71d0c59165c1489309df0365442aa575bb4c505bbfea5d0daad837fa9b7b40c2aa3841fceda199f37fe5832f0685ad3a0a82ff5e653a3b SHA512 adef6823d069b32305605d0eaa3d3701c6a87900646d9509cebe0fd8a2fec0523595d0dcb4576b32245e7638388d3b43858dbc42be68de9971ac8461fcfdeb34
+DIST chkrootkit-0.52.tar 40031 BLAKE2B 8bd3518edc11a22dbc7e866de622454f55baa9fcd06a4034489596c0a24d867fec16d134dbc0aaf8b936640177d7dee8e061e39813a3ed261ae657d70f54a47d SHA512 45d66227c185c60166c9ea2a1f89f4594fa7c943c280fd6da5b59b5b355d5fe0d36806ef133fb29f9b2cac0bc05e9c10773ed4fae923a7115cc900818a596d42
+EBUILD chkrootkit-0.51.ebuild 1332 BLAKE2B 5d5bdb9a5edcb3bd08944f89592f24446f45f890859a80930adbe99831b26b5860e4f47804c1c27f101895c15a40b0c3d2c796c9dd687fd10bad3a3a25b1c971 SHA512 094c6e7003e1e5588d74e392ca2c6924f4172c42598601066b9858de5b01385abe444a1be9f5d81d55e0ef1125257914e68ba9bc5108c7fe018ee3cdd1a01232
+EBUILD chkrootkit-0.52.ebuild 1350 BLAKE2B 55270163c96b527542f576469743bfdab10af8b264c1084fb521dee56173b787a67273b676a64542a52e8e8d426e648a4556c61ac5982de210ed17baec0c2197 SHA512 4466b09949fb06257cedb02caf7d94b97f1771144fd9e08c135da61568080ffe8f49e1486c9045c41252d9199be4fbfac4f21f019958adc6f04cd58bf159d857
+MISC metadata.xml 254 BLAKE2B 82f42628c121ed27ad00d04687d2f6b52148571b49f1c8f4a81cf47ccf2e857b16c9d0c6a3da2f8bebd6a8803d433a874e8066f48bd18ff960923f53bd15da7b SHA512 f0b5ba232a76e933dd34a7e3e7fa04e627de0201610166f4758c5ccf888f509815b5cc39f5373b87a413496318f507bf28599ec0995d32bde98a7c65287d39bb
diff --git a/app-forensics/chkrootkit/chkrootkit-0.51.ebuild b/app-forensics/chkrootkit/chkrootkit-0.51.ebuild
new file mode 100644
index 000000000000..34028cf57fd9
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.51.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+# Upstream named their *uncompressed* tarball .tar.gz (*sigh*)
+SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz -> ${P}.tar
+ https://dev.gentoo.org/~polynomial-c/${P}-gentoo.diff.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="+cron"
+
+RDEPEND="cron? ( virtual/cron )"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-gentoo.diff
+)
+
+src_prepare() {
+ default
+ sed -e 's:/var/adm/:/var/log/:g' \
+ -i chklastlog.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=true sense
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
+ dodoc ACKNOWLEDGMENTS README*
+
+ if use cron ; then
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
+ fi
+}
+
+pkg_postinst() {
+ if use cron ; then
+ elog
+ elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ fi
+
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ elog
+}
diff --git a/app-forensics/chkrootkit/chkrootkit-0.52.ebuild b/app-forensics/chkrootkit/chkrootkit-0.52.ebuild
new file mode 100644
index 000000000000..2ca1931ac553
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.52.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+# Upstream named their *uncompressed* tarball .tar.gz (*sigh*)
+SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz -> ${P}.tar
+ https://dev.gentoo.org/~polynomial-c/${PN}-0.51-gentoo.diff.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86"
+IUSE="+cron"
+
+RDEPEND="cron? ( virtual/cron )"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-0.51-gentoo.diff
+)
+
+src_prepare() {
+ default
+ sed -e 's:/var/adm/:/var/log/:g' \
+ -i chklastlog.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=true sense
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
+ dodoc ACKNOWLEDGMENTS README*
+
+ if use cron ; then
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
+ fi
+}
+
+pkg_postinst() {
+ if use cron ; then
+ elog
+ elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ fi
+
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ elog
+}
diff --git a/app-forensics/chkrootkit/files/chkrootkit.cron b/app-forensics/chkrootkit/files/chkrootkit.cron
new file mode 100644
index 000000000000..9f7eb17b13b1
--- /dev/null
+++ b/app-forensics/chkrootkit/files/chkrootkit.cron
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# uncomment this to make it work
+#
+
+#exec /usr/sbin/chkrootkit -q
diff --git a/app-forensics/chkrootkit/metadata.xml b/app-forensics/chkrootkit/metadata.xml
new file mode 100644
index 000000000000..e02dd379868e
--- /dev/null
+++ b/app-forensics/chkrootkit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="cron">Install cron script for weekly rootkit scans</flag>
+ </use>
+</pkgmetadata>