summaryrefslogtreecommitdiff
path: root/app-forensics/aflplusplus/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-forensics/aflplusplus/files
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-forensics/aflplusplus/files')
-rw-r--r--app-forensics/aflplusplus/files/aflplusplus-3.0c-LDFLAGS.patch11
-rw-r--r--app-forensics/aflplusplus/files/aflplusplus-3.13c-CFLAGS.patch99
-rw-r--r--app-forensics/aflplusplus/files/aflplusplus-3.14c-no-ignore-errors-makefile.patch62
3 files changed, 0 insertions, 172 deletions
diff --git a/app-forensics/aflplusplus/files/aflplusplus-3.0c-LDFLAGS.patch b/app-forensics/aflplusplus/files/aflplusplus-3.0c-LDFLAGS.patch
deleted file mode 100644
index 3e8f4dd92d1a..000000000000
--- a/app-forensics/aflplusplus/files/aflplusplus-3.0c-LDFLAGS.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/GNUmakefile.gcc_plugin
-+++ b/GNUmakefile.gcc_plugin
-@@ -129,7 +129,7 @@ afl-common.o: ./src/afl-common.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@ $(LDFLAGS)
-
- ./afl-gcc-pass.so: instrumentation/afl-gcc-pass.so.cc | test_deps
-- $(CXX) $(CXXEFLAGS) $(PLUGIN_FLAGS) -shared $< -o $@
-+ $(CXX) $(CXXEFLAGS) $(PLUGIN_FLAGS) -shared $< -o $@ $(LDFLAGS)
- ln -sf afl-cc afl-gcc-fast
- ln -sf afl-cc afl-g++-fast
- ln -sf afl-cc.8 afl-gcc-fast.8
diff --git a/app-forensics/aflplusplus/files/aflplusplus-3.13c-CFLAGS.patch b/app-forensics/aflplusplus/files/aflplusplus-3.13c-CFLAGS.patch
deleted file mode 100644
index a3f54b437b83..000000000000
--- a/app-forensics/aflplusplus/files/aflplusplus-3.13c-CFLAGS.patch
+++ /dev/null
@@ -1,99 +0,0 @@
---- a/GNUmakefile.gcc_plugin
-+++ b/GNUmakefile.gcc_plugin
-@@ -28,14 +28,14 @@ MAN_PATH ?= $(PREFIX)/share/man/man8
-
- VERSION = $(shell grep '^$(HASH)define VERSION ' ./config.h | cut -d '"' -f2)
-
--CFLAGS ?= -O3 -g -funroll-loops -D_FORTIFY_SOURCE=2
-+CFLAGS ?= -D_FORTIFY_SOURCE=2
- CFLAGS_SAFE := -Wall -Iinclude -Wno-pointer-sign \
- -DAFL_PATH=\"$(HELPER_PATH)\" -DBIN_PATH=\"$(BIN_PATH)\" \
- -DGCC_VERSION=\"$(GCCVER)\" -DGCC_BINDIR=\"$(GCCBINDIR)\" \
- -Wno-unused-function
- override CFLAGS += $(CFLAGS_SAFE)
-
--CXXFLAGS ?= -O3 -g -funroll-loops -D_FORTIFY_SOURCE=2
-+CXXFLAGS ?= -D_FORTIFY_SOURCE=2
- CXXEFLAGS := $(CXXFLAGS) -Wall -std=c++11
-
- CC ?= gcc
---- a/GNUmakefile.llvm
-+++ b/GNUmakefile.llvm
-@@ -237,7 +237,7 @@ else
- AFL_CLANG_DEBUG_PREFIX =
- endif
-
--CFLAGS ?= -O3 -funroll-loops -fPIC -D_FORTIFY_SOURCE=2
-+CFLAGS ?= -fPIC -D_FORTIFY_SOURCE=2
- CFLAGS_SAFE := -Wall -g -Wno-cast-qual -Wno-variadic-macros -Wno-pointer-sign -I ./include/ -I ./instrumentation/ \
- -DAFL_PATH=\"$(HELPER_PATH)\" -DBIN_PATH=\"$(BIN_PATH)\" \
- -DLLVM_BINDIR=\"$(LLVM_BINDIR)\" -DVERSION=\"$(VERSION)\" \
-@@ -254,7 +254,7 @@ ifdef AFL_TRACE_PC
- $(info Compile option AFL_TRACE_PC is deprecated, just set AFL_LLVM_INSTRUMENT=PCGUARD to activate when compiling targets )
- endif
-
--CXXFLAGS ?= -O3 -funroll-loops -fPIC -D_FORTIFY_SOURCE=2
-+CXXFLAGS ?= -fPIC -D_FORTIFY_SOURCE=2
- override CXXFLAGS += -Wall -g -I ./include/ \
- -DVERSION=\"$(VERSION)\" -Wno-variadic-macros \
- -DLLVM_MINOR=$(LLVM_MINOR) -DLLVM_MAJOR=$(LLVM_MAJOR)
-@@ -434,20 +434,20 @@ afl-llvm-dict2file.so: instrumentation/afl-llvm-dict2file.so.cc instrumentation/
-
- .PHONY: document
- document:
-- $(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt.o
-- @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -m32 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-32.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-- @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -m64 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-64.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-+ $(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt.o
-+ @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -m32 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-32.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-+ @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -m64 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-64.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-
- ./afl-compiler-rt.o: instrumentation/afl-compiler-rt.o.c
-- $(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -fPIC -c $< -o $@
-+ $(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -fPIC -c $< -o $@
-
- ./afl-compiler-rt-32.o: instrumentation/afl-compiler-rt.o.c
- @printf "[*] Building 32-bit variant of the runtime (-m32)... "
-- @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-32.o afl-llvm-rt-32.o; else echo "failed (that's fine)"; fi
-+ @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-32.o afl-llvm-rt-32.o; else echo "failed (that's fine)"; fi
-
- ./afl-compiler-rt-64.o: instrumentation/afl-compiler-rt.o.c
- @printf "[*] Building 64-bit variant of the runtime (-m64)... "
-- @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-64.o afl-llvm-rt-64.o; else echo "failed (that's fine)"; fi
-+ @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-64.o afl-llvm-rt-64.o; else echo "failed (that's fine)"; fi
-
- .PHONY: test_build
- test_build: $(PROGS)
---- a/unicorn_mode/samples/c/Makefile
-+++ b/unicorn_mode/samples/c/Makefile
-@@ -35,7 +35,7 @@ clean:
- rm -rf *.o harness harness-debug
-
- harness.o: harness.c ../../unicornafl/include/unicorn/*.h
-- ${MYCC} ${CFLAGS} -O3 -c harness.c
-+ ${MYCC} ${CFLAGS} -c harness.c
-
- harness-debug.o: harness.c ../../unicornafl/include/unicorn/*.h
- ${MYCC} ${CFLAGS} -g -c harness.c -o $@
---- a/unicorn_mode/samples/persistent/Makefile
-+++ b/unicorn_mode/samples/persistent/Makefile
-@@ -35,7 +35,7 @@ clean:
- rm -rf *.o harness harness-debug
-
- harness.o: harness.c ../../unicornafl/include/unicorn/*.h
-- ${MYCC} ${CFLAGS} -O3 -c harness.c
-+ ${MYCC} ${CFLAGS} -c harness.c
-
- harness-debug.o: harness.c ../../unicornafl/include/unicorn/*.h
- ${MYCC} ${CFLAGS} -DAFL_DEBUG=1 -g -c harness.c -o $@
---- a/utils/afl_untracer/Makefile
-+++ b/utils/afl_untracer/Makefile
-@@ -1,7 +1,7 @@
- ifdef DEBUG
- OPT=-O0
- else
-- OPT=-O3
-+ OPT?=-O2
- endif
-
- all: afl-untracer libtestinstr.so
diff --git a/app-forensics/aflplusplus/files/aflplusplus-3.14c-no-ignore-errors-makefile.patch b/app-forensics/aflplusplus/files/aflplusplus-3.14c-no-ignore-errors-makefile.patch
deleted file mode 100644
index 0b029396390c..000000000000
--- a/app-forensics/aflplusplus/files/aflplusplus-3.14c-no-ignore-errors-makefile.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-https://bugs.gentoo.org/800941
-
---- a/GNUmakefile
-+++ b/GNUmakefile
-@@ -310,12 +310,12 @@ all: test_x86 test_shm test_python ready $(PROGS) afl-as llvm gcc_plugin test_bu
-
- .PHONY: llvm
- llvm:
-- -$(MAKE) -j -f GNUmakefile.llvm
-+ $(MAKE) -j -f GNUmakefile.llvm
- @test -e afl-cc || { echo "[-] Compiling afl-cc failed. You seem not to have a working compiler." ; exit 1; }
-
- .PHONY: gcc_plugin
- gcc_plugin:
-- -$(MAKE) -f GNUmakefile.gcc_plugin
-+ $(MAKE) -f GNUmakefile.gcc_plugin
-
- .PHONY: man
- man: $(MANPAGES)
-@@ -562,8 +562,8 @@ all_done: test_build
- .PHONY: clean
- clean:
- rm -f $(PROGS) libradamsa.so afl-fuzz-document afl-as as afl-g++ afl-clang afl-clang++ *.o src/*.o *~ a.out core core.[1-9][0-9]* *.stackdump .test .test1 .test2 test-instr .test-instr0 .test-instr1 afl-qemu-trace afl-gcc-fast afl-gcc-pass.so afl-g++-fast ld *.so *.8 test/unittests/*.o test/unittests/unit_maybe_alloc test/unittests/preallocable .afl-* afl-gcc afl-g++ afl-clang afl-clang++ test/unittests/unit_hash test/unittests/unit_rand
-- -$(MAKE) -f GNUmakefile.llvm clean
-- -$(MAKE) -f GNUmakefile.gcc_plugin clean
-+ $(MAKE) -f GNUmakefile.llvm clean
-+ $(MAKE) -f GNUmakefile.gcc_plugin clean
- $(MAKE) -C utils/libdislocator clean
- $(MAKE) -C utils/libtokencap clean
- $(MAKE) -C utils/aflpp_driver clean
-@@ -618,8 +618,8 @@ binary-only: test_shm test_python ready $(PROGS)
-
- .PHONY: source-only
- source-only: all
-- -$(MAKE) -j -f GNUmakefile.llvm
-- -$(MAKE) -f GNUmakefile.gcc_plugin
-+ $(MAKE) -j -f GNUmakefile.llvm
-+ $(MAKE) -f GNUmakefile.gcc_plugin
- $(MAKE) -C utils/libdislocator
- $(MAKE) -C utils/libtokencap
-
-@@ -661,8 +661,8 @@ install: all $(MANPAGES)
- @if [ -f utils/afl_network_proxy/afl-network-server ]; then $(MAKE) -C utils/afl_network_proxy install; fi
- @if [ -f utils/aflpp_driver/libAFLDriver.a ]; then set -e; install -m 644 utils/aflpp_driver/libAFLDriver.a $${DESTDIR}$(HELPER_PATH); fi
- @if [ -f utils/aflpp_driver/libAFLQemuDriver.a ]; then set -e; install -m 644 utils/aflpp_driver/libAFLQemuDriver.a $${DESTDIR}$(HELPER_PATH); fi
-- -$(MAKE) -f GNUmakefile.llvm install
-- -$(MAKE) -f GNUmakefile.gcc_plugin install
-+ $(MAKE) -f GNUmakefile.llvm install
-+ $(MAKE) -f GNUmakefile.gcc_plugin install
- ln -sf afl-cc $${DESTDIR}$(BIN_PATH)/afl-gcc
- ln -sf afl-cc $${DESTDIR}$(BIN_PATH)/afl-g++
- ln -sf afl-cc $${DESTDIR}$(BIN_PATH)/afl-clang
---- a/GNUmakefile.llvm
-+++ b/GNUmakefile.llvm
-@@ -460,6 +460,7 @@ document:
- test_build: $(PROGS)
- @echo "[*] Testing the CC wrapper and instrumentation output..."
- unset AFL_USE_ASAN AFL_USE_MSAN AFL_INST_RATIO; ASAN_OPTIONS=detect_leaks=0 AFL_QUIET=1 AFL_PATH=. AFL_LLVM_LAF_ALL=1 ./afl-cc $(CFLAGS) $(CPPFLAGS) ./test-instr.c -o test-instr $(LDFLAGS)
-+ @test -e test-instr || { echo "[-] Testing CC wrapper failed. You seem not to have a working compiler." ; exit 1; }
- ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr0 ./test-instr < /dev/null
- echo 1 | ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr1 ./test-instr
- @rm -f test-instr