summaryrefslogtreecommitdiff
path: root/app-eselect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-eselect
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/Manifest.gzbin7550 -> 7551 bytes
-rw-r--r--app-eselect/eselect-lua/Manifest1
-rw-r--r--app-eselect/eselect-lua/files/lua.eselect-1150
-rw-r--r--app-eselect/eselect-php/Manifest9
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.4-r5.ebuild44
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.5.ebuild44
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.6.ebuild2
-rw-r--r--app-eselect/eselect-php/files/php-fpm-launcher7
-rw-r--r--app-eselect/eselect-php/files/php-fpm-launcher-r311
-rw-r--r--app-eselect/eselect-php/files/php-fpm.conf1
-rw-r--r--app-eselect/eselect-repository/Manifest4
-rw-r--r--app-eselect/eselect-repository/eselect-repository-7.ebuild42
-rw-r--r--app-eselect/eselect-repository/eselect-repository-8.ebuild4
13 files changed, 5 insertions, 314 deletions
diff --git a/app-eselect/Manifest.gz b/app-eselect/Manifest.gz
index 6cc13dd6deb0..050932f0c35f 100644
--- a/app-eselect/Manifest.gz
+++ b/app-eselect/Manifest.gz
Binary files differ
diff --git a/app-eselect/eselect-lua/Manifest b/app-eselect/eselect-lua/Manifest
index 667940d3f7db..a00dba09c646 100644
--- a/app-eselect/eselect-lua/Manifest
+++ b/app-eselect/eselect-lua/Manifest
@@ -1,4 +1,3 @@
-AUX lua.eselect-1 3217 BLAKE2B c3f2723afd8177878443bad6fbb51d16a0b90a9f439fe0f2dd150105488db540481136e2ff5f3d2a0b71bdcc88e95f6751a63c7c0a6bea4c32445f8871aa4163 SHA512 653aa84caf8a3706206099de78d8e1b2bbd41cda40dd7dac2b022c85a1988d864a80f490389db3fc2450555d301f965189df132a964a4425ee2bab6c2b7be220
AUX lua.eselect-2 4192 BLAKE2B 90c8241a3dcc822466aa9a95420143bcdcd5a9aed3d8688958cc2bd30005f298399f8d34834ffb7a727a1186acfd9e98b765cc5a949ef81e39ca96e83c028afa SHA512 fa7dfa52542d9410dcc5f60bc4ef63db7b8396c7ba6115f2d83951a171d996aea3c13530ac2d7ef5025b5047aacb2e4936527377aec0d53229f46d518bd79845
EBUILD eselect-lua-2.ebuild 791 BLAKE2B 029dd825b07c7a8406658dd34dd1e5699624900a35683befe97e045cd3c492bc9acbeee0c7d1a963742a4284da4e5f231ab27952ab9e971fe0822f9d8fad1d16 SHA512 bc52a5adf91a1029fea819be865040f5f6d77d88d4e22e9f6af1780966b1bb1f07e4d7bf19a83c87abdb5df2560d9a6ea3e9cd2a29eed96976317cdd7536236c
MISC metadata.xml 361 BLAKE2B d4e3b671abc0924f33030927fed5591df325b49a42711b7d5d9c4c9052433903414434402c12dbebf907f8197fb0f82bf9d44202599e255ccbc01b6e3d78bbed SHA512 425998f090c34d79e2190c0aa0ad81601a9e2fca458f7e9fe0fd4b09f2abb10c7eb4a02307d97e28d5b3aee3098eda57715d0e0cdbe254ba9f2768def2e74654
diff --git a/app-eselect/eselect-lua/files/lua.eselect-1 b/app-eselect/eselect-lua/files/lua.eselect-1
deleted file mode 100644
index d6f951098354..000000000000
--- a/app-eselect/eselect-lua/files/lua.eselect-1
+++ /dev/null
@@ -1,150 +0,0 @@
-# -*-eselect-*- vim: ft=eselect
-# Copyright 2014-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit config multilib
-
-DESCRIPTION="Manage lua symlinks"
-MAINTAINER="mabi@gentoo.org"
-
-HEADER_FILES="lauxlib.h luaconf.h lua.h lua.hpp lualib.h"
-
-remove_symlinks() {
- rm -f "${EROOT}"/usr/bin/{lua,luac} &>/dev/null
- for dir in $(get_libdirs) ; do
- rm -f "${EROOT}"${dir}/liblua.so &>/dev/null && \
- rm -f "${EROOT}"${dir}/pkgconfig/lua.pc &>/dev/null
- done
- for f in $HEADER_FILES ; do
- rm -f "${EROOT}"/usr/include/$f
- done
- rm -f "${EROOT}"/usr/share/man/man1/{lua,luac}.1{,.gz,.bz2,.lzma} &>/dev/null
-}
-
-set_symlinks() {
- local ver=$1
- ln -s "${EROOT}"/usr/bin/lua{$ver,}
- ln -s "${EROOT}"/usr/bin/luac{$ver,}
- for dir in $(get_libdirs) ; do
- ln -s "${dir}"/liblua{$ver,}.so
- ln -s "${dir}"/pkgconfig/lua{$ver,}.pc
- done
- for orig in "${EROOT}"/usr/share/man/man1/lua*$ver.1* ; do
- ln -s "${orig}" "${orig//$ver}"
- done
- for f in $HEADER_FILES ; do
- ln -s "${EROOT}"/usr/include/lua$ver/$f "${EROOT}"/usr/include
- done
-}
-
-get_libdirs() {
- local dir libdirs
- for dir in $(list_libdirs); do
- [[ -L ${EROOT}/usr/${dir} ]] && continue
- ls "${EROOT}"/usr/${dir}/liblua*.* > /dev/null 2>&1 || continue
-
- libdirs+=' '${EPREFIX}/usr/${dir}
- done
- echo ${libdirs:-${EPREFIX}/usr/lib}
-}
-
-find_targets() {
- local dirs
- local prefix="${EROOT}/usr/bin/lua"
- for f in ${prefix}5* ; do
- dirs="${dirs} ${f##$prefix}"
- done
- echo $dirs
-}
-
-resolv_target() {
- local targets=( $(find_targets) )
- if is_number $1; then
- [[ $1 -le ${#targets[@]} && $1 -gt 0 ]] && echo "${targets[ $(( $1 - 1 )) ]}"
- elif has $1 ${targets[@]}; then
- echo $1
- fi
-}
-
-get_active_version() {
- readlink -e "${EROOT}"/usr/bin/lua | sed -ne "s:.*/usr/bin/lua\([\d.-]*\):\1:p"
-}
-
-## Actual actions
-
-## set action
-
-describe_set() {
- echo "Sets the current version of lua"
-}
-
-describe_set_parameters() {
- echo '<target>'
-}
-
-describe_set_options() {
- echo 'target: Target name or number (from "list" action)'
-}
-
-
-do_set() {
- local target=$(resolv_target $1)
- if [[ -z "${target}" ]]; then
- die -q "You need to specify a version"
- fi
- remove_symlinks
- set_symlinks $target
-}
-
-## List action
-
-describe_list() {
- echo 'Lists available lua versions'
-}
-
-do_list() {
- local targets
- local a
- targets=( $(find_targets) )
- a=$(get_active_version)
- for (( i = 0; i < ${#targets[@]}; i++ )) ; do
- [[ $a == ${targets[i]} ]] && targets[i]=$(highlight_marker "${targets[i]}")
- done
- write_numbered_list -m '(none found)' "${targets[@]}"
-}
-
-## Show action
-
-describe_show() {
- echo 'Show the active lua version'
-}
-
-do_show() {
- get_active_version
-}
-
-## update action
-
-describe_update() {
- echo 'Automatically update the lua version'
-}
-
-describe_update_options() {
- echo 'ifunset : Do not override existing implementation'
-}
-
-do_update() {
- [[ -n ${1} && ! ( ${1} == ifunset || ${1} == '--if-unset' ) ]] && \
- die -q 'Usage error'
-
- [[ ( ${1} == ifunset || ${1} == '--if-unset' ) && -n $(get_active_version) ]] && \
- return
-
- remove_symlinks
-
- local targets=( $(find_targets) )
- if [[ -n ${#targets[@]} ]] ; then
- local target=${targets[${#targets[@]} - 1]}
- set_symlinks $target || echo 'Nothing to update'
- fi
-}
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index 79d92dbaf9e2..52ae1899e68f 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1,11 +1,4 @@
-AUX php-fpm-launcher 134 BLAKE2B fdbb99bbbd0d171975aff6f55ba7c41fe152c330cfb05dff81ab033d2490af27c52b8e43e5ed1ae80ee3c6ba8a1471adb01778d6b76bdd7776845f7c93e12428 SHA512 4304ea6df7093af06f1b7df5bf5d8ed7692403cc64a5c4c516e49d36fa866b33e4815876d28cc365f5ccb1e301ef7ce9b57e15ed959a41c91fb25af7236fed29
-AUX php-fpm-launcher-r3 223 BLAKE2B 80c90d2388118e6dbdceacebbc87de145e94e34a6d9691b6c3179df4f05631d904c1c3e5647dd080ff2080c346bffcb71bee96d4d4123f6c4d3be0120161c960 SHA512 9dfd36f88457a57a31c17cb251a8aeeef505f811f9ac59c5715532c3780b543034a6a9d356f4111fab1998883299ece0a68508dd3e154bc54de84ce6805bf351
-AUX php-fpm.conf 29 BLAKE2B 505e957038315f8668a558f91eac2ad8ae6bc3e87db238001042ddfe7d817c1589891235d88edc91e213215b7a632fa9358795290599223097ac66f546085c1c SHA512 824e9a0d10063283357d49a81ab49bf834afd24f098482bdbaa9ab60bbad2b0dea6f5879259b73717d437626b02fb4f2d3ef68b7bcbb26bee274a7b61144720f
-DIST eselect-php-0.9.4.tar.xz 49576 BLAKE2B 417956b355ffec7d7cda03dffa94e4d749a2b33a64a216c2ed8492181a5385f5219078efe6cc4d0d2d81b0fac40901c0cf07914a826484b83833542a12b47359 SHA512 2ba1dd75d4bb9611c6687ed4449f715728263538f772652aa1ac013103cf9ddf328c854326cf6da4f9b3ff2279bf99d973325520fe8b4e3ba7a76a9c3264e78e
-DIST eselect-php-0.9.5.tar.xz 49732 BLAKE2B 78c2010abcb1c9efd4d5f2f3f934365b338901a98bc8528131f2b9f564c1c3f740ab2dc2a28a0a58912e750062e61f75a7c6611c2f37019ca6525d729ffb5fd2 SHA512 55e401cb0c3ed19fed90485d62ba3deed3355503542898ff0d1b5404bd5fafb2f887df433609d4d4b28f32c0034100ea32c9e58547ef6417ea0b0f60d061d119
DIST eselect-php-0.9.6.tar.xz 53236 BLAKE2B 38478d4792f8a527e5f519abd7765211aff8c1d132ceeba5eec70ea3b8d1f254be52564334fed3840950c2461ff4a30784b92fbb8b21cc448083617797eab1d4 SHA512 d3f14288b3493cb48717c1f27430ae8b60881e9f6f48e4b7644a4596d9fc1b9823a6af8b7101a62b28a92e3bff164b1717617a2642a5bb02e8dd46de56d4f410
-EBUILD eselect-php-0.9.4-r5.ebuild 1356 BLAKE2B dc14c86dcb6323af5bed9cc11c3712800d4cff90fae5912c0bf26b74ec46aa22c4d4d9ac39b295e91798bd7505141ba81e0a35726f6225120b1ac891b611087e SHA512 b6be738c14ad455eed657e30fa9495e5cd9a26744ca3e10ff465aad60ba29b6a1fb8416eb41059e593e30bb60b476e0a80a37f4f6092b039943db978fe6fe05d
-EBUILD eselect-php-0.9.5.ebuild 1364 BLAKE2B 9053d4938b14989de8de1436bcf877845d376f1d44628e2adf93fbf6259d1c589a78ec65b539dafc401f299bcb6d7cda9671c1b315417cde29f3cda89617740d SHA512 eb08bcee2dccd2fb09f5091daa2b09de3a5adb2493ca5af025c46abdba01396de04cb34a26e54b0f2c3dd25bf54582d9ab67b16326172144a01f480cdc612c24
-EBUILD eselect-php-0.9.6.ebuild 1103 BLAKE2B 97d545fcfa214c93477cab816ae7f312434308efcb5ba067ffa254a34dbf60c341ab6e7c8767f2ce62a8c0f0269f37b2d1eee954dd3584268b852c9ef9bb17fa SHA512 975c9e633477afe859ef60a1ac422ecfa4c7e9b1e0f1e541420ecb36c06bd51beba61c347a7b65eca1065fec87fc8262fe6ca80d6a96d9e217a0b841161f8b37
+EBUILD eselect-php-0.9.6.ebuild 1095 BLAKE2B 8d6950a14070043e62a30a8528f92ac89e6f86b87989cfe13ab7e3035a5c78331824c8aa7657c333b188a7af9a7e760bcb4dbb19990ebd308c89c650bcb9ad00 SHA512 1dbbde280a8569e064eac769b266561c5fbd31d7abc6aa79248f2604353a275ea1f0b8aa2cd3a508c9611c4b95ea58b1d112a90252e024f636e6b21ee7b8860a
EBUILD eselect-php-9999.ebuild 1031 BLAKE2B 137e895ef07fe7c229cd111a101b17854685bdfc98772f4dae61dd391a31e8fcaf3505a1accf3d15754b0ac6d424defe2bb3ca6368623f0ac818cd078dcb5cfe SHA512 183e490a9c40858d8d48a94a8096604834fdabede72cc6b5917bccba2a377f5fa05d1512b19e22c6354c510f50b86462a1e788eb21214b5e616aa65db37ff901
MISC metadata.xml 443 BLAKE2B d18f03330bdb4792f92dd86801ab889e1f311dd1be1c3e5047e86621864f38eb27c6d9d0252418a411236696f766a5813bda8717e12cf8015581fb4cff1824f5 SHA512 2651faf212833d425cd58c866b030d17543f84826a911a01c358815c3dc8fa0629870c901953746ad4029dbd7d16fba0db161d27f866e4763cc380f60934ef94
diff --git a/app-eselect/eselect-php/eselect-php-0.9.4-r5.ebuild b/app-eselect/eselect-php/eselect-php-0.9.4-r5.ebuild
deleted file mode 100644
index 294500392640..000000000000
--- a/app-eselect/eselect-php/eselect-php-0.9.4-r5.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit systemd
-
-DESCRIPTION="PHP eselect module"
-HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
-SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="fpm apache2"
-
-# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
-RDEPEND="app-admin/eselect
- apache2? ( www-servers/apache[apache2_modules_dir] )"
-
-src_configure() {
- # We expect localstatedir to be "var"ish, not "var/lib"ish, because
- # that's what PHP upstream expects. See for example the FPM
- # configuration where they put logs in @localstatedir@/log.
- #
- # The libdir is passed explicitly in case the /usr/lib symlink
- # is not present (bug 624528).
- econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --localstatedir="${EPREFIX}/var" \
- --with-piddir="${EPREFIX}/run" \
- $(use_enable apache2) \
- $(use_enable fpm)
-}
-
-src_install() {
- default
-
- if use fpm ; then
- systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
- sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
- exeinto /usr/libexec
- doexe "${T}"/php-fpm-launcher
- fi
-}
diff --git a/app-eselect/eselect-php/eselect-php-0.9.5.ebuild b/app-eselect/eselect-php/eselect-php-0.9.5.ebuild
deleted file mode 100644
index a38c7b0c3c11..000000000000
--- a/app-eselect/eselect-php/eselect-php-0.9.5.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit systemd
-
-DESCRIPTION="PHP eselect module"
-HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
-SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="fpm apache2"
-
-# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
-RDEPEND="app-admin/eselect
- apache2? ( www-servers/apache[apache2_modules_dir] )"
-
-src_configure() {
- # We expect localstatedir to be "var"ish, not "var/lib"ish, because
- # that's what PHP upstream expects. See for example the FPM
- # configuration where they put logs in @localstatedir@/log.
- #
- # The libdir is passed explicitly in case the /usr/lib symlink
- # is not present (bug 624528).
- econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --localstatedir="${EPREFIX}/var" \
- --with-piddir="${EPREFIX}/run" \
- $(use_enable apache2) \
- $(use_enable fpm)
-}
-
-src_install() {
- default
-
- if use fpm ; then
- systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
- sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
- exeinto /usr/libexec
- doexe "${T}"/php-fpm-launcher
- fi
-}
diff --git a/app-eselect/eselect-php/eselect-php-0.9.6.ebuild b/app-eselect/eselect-php/eselect-php-0.9.6.ebuild
index d2a17e02f7af..37510b414c4b 100644
--- a/app-eselect/eselect-php/eselect-php-0.9.6.ebuild
+++ b/app-eselect/eselect-php/eselect-php-0.9.6.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="fpm apache2"
# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
diff --git a/app-eselect/eselect-php/files/php-fpm-launcher b/app-eselect/eselect-php/files/php-fpm-launcher
deleted file mode 100644
index 7a1c1c9f918b..000000000000
--- a/app-eselect/eselect-php/files/php-fpm-launcher
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-PHPSLOT="${1}"
-[ -z "${PHPSLOT}" ] && PHPSLOT="$(eselect php show fpm)"
-shift
-
-exec /usr/lib/${PHPSLOT}/bin/php-fpm "${@}"
diff --git a/app-eselect/eselect-php/files/php-fpm-launcher-r3 b/app-eselect/eselect-php/files/php-fpm-launcher-r3
deleted file mode 100644
index a2b6eabc4da5..000000000000
--- a/app-eselect/eselect-php/files/php-fpm-launcher-r3
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-# If there are no arguments, then "shift" will fail (bug 626496).
-if [ $# -eq 0 ]; then
- PHP_SLOT=$(eselect php show fpm)
-else
- PHP_SLOT=$1
- shift
-fi
-
-exec "/usr/@libdir@/${PHP_SLOT}/bin/php-fpm" "${@}"
diff --git a/app-eselect/eselect-php/files/php-fpm.conf b/app-eselect/eselect-php/files/php-fpm.conf
deleted file mode 100644
index 801e74f1e620..000000000000
--- a/app-eselect/eselect-php/files/php-fpm.conf
+++ /dev/null
@@ -1 +0,0 @@
-d /run/php-fpm 755 root root
diff --git a/app-eselect/eselect-repository/Manifest b/app-eselect/eselect-repository/Manifest
index bca4d1c7395c..d1631b58ca2b 100644
--- a/app-eselect/eselect-repository/Manifest
+++ b/app-eselect/eselect-repository/Manifest
@@ -1,5 +1,3 @@
-DIST eselect-repository-7.tar.gz 6768 BLAKE2B f648b880ab188b5beb21161dd011d8cea0bc9dd124d524d747a1867a37f334667363be9c0ad9f04275aa1534b904a519d7551c25ea547ae2acff625382c35dbd SHA512 87569158dce3acfdd81a469387fe1a7a7c268cae2e15cfdb12d8377984be5feb674c9b385f0171d27dbe8c2066ae98b2c9a74214340e85380cba173ba26d6f0f
DIST eselect-repository-8.tar.gz 6774 BLAKE2B d22c2befc744e21b7619a490e9c41f1052c4077135ba5247ea9558f15f7dc5c06642dd934c41ad8cb3bedb40398876ea9d508276bde6f214fe06d5f80b19911b SHA512 b1fd13e3bfa323dea7fec53a33865352545a070df472c9db0b2901945a795833eb8a2b7b264005d94fe6e92dce57414a7e995157d28c8d26048bedcbf42adf96
-EBUILD eselect-repository-7.ebuild 989 BLAKE2B f36d97d72eac56bf47369477b618bcd9d0b9e2a65b3ceba0dc72ffcb4ced58f9f02eca7b900c7495cb58e961328657b1fcb6620228ac60091d02bc7eff80f01d SHA512 780e12566c8b1454330a229f63665ff45bf28d04f4fda62392c2d5a7ad77b89c9beda0f2513032cf9b62fa0e564c350f801b6a0572d4484d806e4274f61ff624
-EBUILD eselect-repository-8.ebuild 993 BLAKE2B 9756d93308ccbc15958460218cbd8d11f301826cf0b729765e2cebef79a3dc2dff25de05c4093b42ccabfee092832ad011d30d983f3e2433a689bf9a6626ae31 SHA512 667d0473b210a6459c50db305e32b562938e51dec09e3a1f2517d4f9ee0ce239d9fab6f2ae82c0904025ef50b7616f585dd51b437fbb47845d8bff92c9d20f6d
+EBUILD eselect-repository-8.ebuild 993 BLAKE2B 31acb2e5f29e0e39318e7d65312ae62890504852664492f280159bf38fdd6e4bf9834bf1c3c0bc253ff6f596f8586c3f5150132d513ebd51d3f382f3ad798316 SHA512 65061aa60e2462cd98614ecf69a95aeb692af5c5b50069e7c642ac7972f02cd98f33097697b371ab61854bccdd6b4ecac072daf9612b58b321ddf645d0af728b
MISC metadata.xml 361 BLAKE2B 65f6d76855e7205041fd10b416774d373f2cbf3ef3c13ccbad5069edb5f2d980c67cd1f188471df59ce784ff5b8a100c984644dadacaa4ace8d42c22993fc594 SHA512 40082f5d7899074e331edbe92d13784a3ccff5e04f60db71297ded20b2f1cca88e70b1f4fd6cc94e76048b7f3a718b586ced406452d816333e969e64ac5a3c8e
diff --git a/app-eselect/eselect-repository/eselect-repository-7.ebuild b/app-eselect/eselect-repository/eselect-repository-7.ebuild
deleted file mode 100644
index 33798b53e492..000000000000
--- a/app-eselect/eselect-repository/eselect-repository-7.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit python-single-r1
-
-DESCRIPTION="Manage repos.conf via eselect"
-HOMEPAGE="https://github.com/mgorny/eselect-repository"
-SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="${PYTHON_DEPS}
- app-admin/eselect
- $(python_gen_cond_dep '
- dev-python/lxml[${PYTHON_MULTI_USEDEP}]
- ')
- net-misc/wget"
-
-src_compile() {
- MAKEARGS=(
- PREFIX="${EPREFIX}/usr"
- SYSCONFDIR="${EPREFIX}/etc"
- SHAREDSTATEDIR="${EPREFIX}/var"
- ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
- )
-
- emake "${MAKEARGS[@]}"
- python_fix_shebang eselect-repo-helper
-}
-
-src_install() {
- emake "${MAKEARGS[@]}" DESTDIR="${D}" install
- keepdir /var/db/repos
- einstalldocs
-}
diff --git a/app-eselect/eselect-repository/eselect-repository-8.ebuild b/app-eselect/eselect-repository/eselect-repository-8.ebuild
index f0bf9cebf269..add50e4e5a97 100644
--- a/app-eselect/eselect-repository/eselect-repository-8.ebuild
+++ b/app-eselect/eselect-repository/eselect-repository-8.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
inherit python-single-r1
DESCRIPTION="Manage repos.conf via eselect"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> $
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
IUSE=""
REQUIRED_USE=${PYTHON_REQUIRED_USE}