summaryrefslogtreecommitdiff
path: root/app-eselect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-eselect
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/Manifest.gzbin8535 -> 8532 bytes
-rw-r--r--app-eselect/eselect-opengl/Manifest2
-rw-r--r--app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild14
3 files changed, 10 insertions, 6 deletions
diff --git a/app-eselect/Manifest.gz b/app-eselect/Manifest.gz
index 75ead6e5d2c7..19cbd9418a14 100644
--- a/app-eselect/Manifest.gz
+++ b/app-eselect/Manifest.gz
Binary files differ
diff --git a/app-eselect/eselect-opengl/Manifest b/app-eselect/eselect-opengl/Manifest
index 8debd5b5bd0d..ec38109575ea 100644
--- a/app-eselect/eselect-opengl/Manifest
+++ b/app-eselect/eselect-opengl/Manifest
@@ -1,3 +1,3 @@
DIST opengl.eselect-1.3.1.xz 2588 BLAKE2B 5be8bd3efc510a3e55a666136e0f4e8a3214b347981db1413f84268e788a4d708b83eeccddc75766dd4cc29cf99b6930062b274a6ecf79c5c5f8a5817c7af32f SHA512 052a804e96d8e8afe8b588fdc8996aad21675ea05e3e668c33293df4b9523dde8be083e4a7909a22ec83260c9735694fe4e8aa7e5d8a3736a8e243f29368e532
-EBUILD eselect-opengl-1.3.1-r4.ebuild 2187 BLAKE2B 28586f78a51907215bc15091a4e13610521ba53357fb96d0a75950b1a2e7256ca1502c7195288e65ba45d0106f844c4280c2a8a870de4237046802ba84521951 SHA512 2320f4707e00fe63a48481f772f789db59c9c0350c2cfa1076cb914614cfc5cba27eaeef6ca32127352c6a891de5266ea6f885d3744fe863cfc5ff1f33018eb7
+EBUILD eselect-opengl-1.3.1-r4.ebuild 2283 BLAKE2B 033476e5fdaf5b29a1bcb221cdea32cc9e1e4b18ac578763ee56d08973ecb40c22afae7e43bc4a422cabf438ef1fdc9518f2291c61b271653d26fc2ce28752af SHA512 4de94653d7d301998b962e1d7ce91fda4ed90f7a8e23e87c93244f96c280481beadd689667aa946f38a73ca3272681914e354f8177a307afa7f2825cf15890bd
MISC metadata.xml 437 BLAKE2B da333685e92af6504ddf471c1d87e13c09e7240941851196758247e7eb276d67ef798f661f2ae62f3456c3c6897d35caee4f328af8b3d7e3ae53e9b1e2c17d21 SHA512 4e1c5f16407ad8a0eb5212d6396bd708047da78f3a97a395b80f60cb21f375f308624f01a8b2bff28ad8bdfca04ac2a3f573f3d5c0f679fdad30b4c0b2751552
diff --git a/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild b/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
index 1206be17c265..4254b036e4ec 100644
--- a/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
+++ b/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,7 +20,7 @@ SRC_URI="https://dev.gentoo.org/~mgorny/dist/opengl.eselect-${PV}.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE=""
DEPEND="app-arch/xz-utils"
@@ -49,11 +49,15 @@ pkg_preinst() {
}
pkg_postinst() {
- if path_exists "${EROOT}"/usr/lib*/opengl; then
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local opengl_dirs=( "${EROOT}"/usr/lib*/opengl )
+ ${shopt_save}
+ if [[ -n ${opengl_dirs[@]} ]]; then
# delete broken symlinks
- find "${EROOT}"/usr/lib*/opengl -xtype l -delete
+ find "${opengl_dirs[@]}" -xtype l -delete
# delete empty leftover directories (they confuse eselect)
- find "${EROOT}"/usr/lib*/opengl -depth -type d -empty -exec rmdir -v {} +
+ find "${opengl_dirs[@]}" -depth -type d -empty -exec rmdir -v {} +
fi
if [[ -n "${OLD_IMPL}" && "${OLD_IMPL}" != '(none)' ]] ; then